Mixed network with Sonos Beam, One and Move

  • 22 December 2020
  • 19 replies
  • 265 views

Badge
  • Contributor I
  • 9 replies

Hi,

I have a Beam connected to ethernet. When the Beam and my Sonos One are the only devices turned on, the Sonos One automatically joins Sonosnet via wireless, all good. But as soon as my Move is turned on, the Sonos One switches to Wifi (WM:1). The Beam is on my Living Room while the Sonos One and Move are near each other in my Bedroom.

 

Is it possible for Sonos One to join the Sonosnet when it's near a Move? I know the Move doesn't support Sonosnet, but I don't understand why the One also needs to be in Wifi.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

Userlevel 7
Badge +17

Though it seems strange behaviour, my first question is would be if the One workslike it does on Sonosnetwhen it switches over to wifi. If it does, why bother?

Badge

Well, it does. But then what's the benefit of having the Beam connected to Ethernet? If I can't make it work, I'm better off freeing that router port to connect another device 😅.

This does seem a little strange, unless Sonos has become clever enough to figure that two adjacent units which might be grouped are better off on the same channel. If so, it’s not something I’ve seen before.

A more obvious explanation could be that the One has a borderline SonosNet signal and reverts to a better WiFi signal. We’d need a bit more info to test this idea. Get the One onto SonosNet then go to http://x.x.x.x:1400/support/review (where x.x.x.x is the IP address of the Beam, from About My System) and screenshot the Network Matrix.

azee,
I would first reset/remove any WiFi credentials that maybe stored in the area of the Sonos App under “Settings/System/Network/Wireless Setup” these are not required when your main speakers are running on SonosNet and just to add this has no bearing on the ‘Move’s’ WiFi connection.


You might also want to go onto try this (if necessary):

If the Move is perhaps operating on the 2.4ghz WiFi band in this case  -  you could consider factory resetting it and then setting it up on the 5ghz band instead and see if that helps to also stop the problem. There are other ways to achieve the same outcome, but factory resetting is perhaps the easier method.

 

Also note you will still have the 2.4ghz credentials showing in the Sonos App’s network settings under ‘Networks Not in Use’ It pays to also remove the 2.4ghz credentials from there. I find there is ‘less chance’ of the SonosNet connected speakers dropping back to a 5ghz WiFi signal.

 

 

Shoving the Move onto 5GHz is definitely a possibility, but I’m still curious as to why the One is falling through onto WiFi.

Badge

Ok, so I don't know exactly what happened, but I couldn't get the One to join Sonosnet again even with the Move turned off. I ended up resetting the network settings in the app so it could join it. Even after resetting the network settings, as soon as the Move is turned on, the One shows as WM: 1.

Here's the Network Matrix with just the Beam and the One, both on Sonosnet:

And here's the same with all devices, Beam (Family Room) in the Sonosnet, the others over Wifi:

 

Switching the Move to 5Ghz would mean I need to have different SSIDS for the 5Gh and 2.4Ghz networks?

According to the network matrix the Bedroom player is not on SonosNet.

Badge

Hmm, let me try once again, app was showing WM: 0. How do I figure this out from the screenshot above? (Or any other place in the support/review link?).

  1. There should be data in the squares where Family Room and Bedroom intersect.
  2. In the left column the Bedroom should say “Secondary Node” below the room name.

Have you disabled the “WiFi” (i.e. SonosNet) on the Beam? Try re-enabling it...

Badge

Ok, so… app shows WM: 0 for One, but Network Matrix is almost the same (changes are: Noise Floor: -107, -108, -108 and OFDM ANI level: 3), it doesn't show Secondary or no data in the intersection.

Have you disabled the “WiFi” (i.e. SonosNet) on the Beam? Try re-enabling it...

 

Badge

And now app just changed to WM: 1. Weird!

Our posts appear to be crossing. See above. 

Badge

Have you disabled the “WiFi” (i.e. SonosNet) on the Beam? Try re-enabling it...

Yes, that was disabled. After enabling it again, Move is now also on Sonosnet.

What was confusing to me was the app showing the One under WM: 0 when Move was turned off, then moving to WM: 1 when Move was turned on.

Badge

And here's the Network Matrix after enabling "Wifi" on Beam.

@ratty thanks for your help!

 

Badge

And the One now stays in the network after Move is turned on (or at least has not left it in the past minutes).

That matrix looks healthy. I can’t imagine why the Bedroom One won’t stay on SonosNet now.

And, by the way, the Move never uses SonosNet; it’s always on WiFi.

Badge

Yeah, I know Move won't join Sonosnet. Do you think that's an issue? A lot of time I have the One and the Move grouped.

I can't remember why I disabled Wifi under the Beam settings, but thinking about it, it probably led me to believe disabling this would make it only work with Sonosnet. So, the Wifi in there is actually Sonosnet?

Yeah, I know Move won't join Sonosnet. Do you think that's an issue? A lot of time I have the One and the Move grouped.

They should work together fine when grouped.

 

So, the Wifi in there is actually Sonosnet?

It is, and it’s egregiously confusing labelling that a number of us have called out in countless posts…