Every time I talk to Alexa, the Move 2 is off!

  • 20 October 2023
  • 20 replies
  • 335 views

Userlevel 1
Badge

How can I make sure Alexa is always around when I call for her on Move 2?

 

Every time when I need Alexa, the Move 2 is off. When I called Sonos support, they said there is no way to resolve this issue.

 

It doesn’t make sense to me that I have to go up to the Move 2 to turn in on or go get my phone and open the Sonos app in order to talk to Alexa…….

 

I need help!! Thanks y’all!


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

20 replies

Userlevel 7

Keep the Move 2 turned on and on the charging base and Alexa will always be available.

Userlevel 1
Badge

Thanks @GuitarSuperstar, but that completely defeats the purpose of Move 2 being a portable speaker in my opinion……

I just leave the Sonos Move sat on it’s charger-loop when being used inside the Home and the Alexa voice assistant is always available - 24/7.

Outdoors (whilst off it’s charger) often with the battery ‘power saver’ feature disabled, the voice assistant is there too whilst playing any audio - and for a good 30 minutes of any inactivity, post playback, but even following that, I only need open the Sonos App, or quick touch of a button, to wake-up the speaker and be able to immediately use it again, or its voice assistant.

Userlevel 7

Thanks @GuitarSuperstar, but that completely defeats the purpose of Move 2 being a portable speaker in my opinion……

You can disable Battery Saver in the Sonos app. This will allow the Move 2 to stay on while idle for 30 minutes while not on the charger rather than only 10 minutes.

Or keep the Move 2 always on by always streaming music to it.

Userlevel 1
Badge

Thanks @Ken_Griffiths and @GuitarSuperstar , we purchased Move 2 because the wall outlet is too close to the Sonos Five we have, so while we’re watching TV, our Sonos One (Alexa) can’t hear us.

 

That is the sole reason why we bought Move 2 is because we thought we can place it in the middle of the room (away from the Five) so we can talk Alexa without muting TV.

 

But so far it looks like Move 2 is not going to work for us at all…….

Thanks @Ken_Griffiths and @GuitarSuperstar , we purchased Move 2 because the wall outlet is too close to the Sonos Five we have, so while we’re watching TV, our Sonos One (Alexa) can’t hear us.

 

That is the sole reason why we bought Move 2 is because we thought we can place it in the middle of the room (away from the Five) so we can talk Alexa without muting TV.

 

But so far it looks like Move 2 is not going to work for us at all…….

If that’s it’s sole purpose - I really don’t understand why you didn’t just get the much cheaper Roam… it’s buttons work the same and it can be sat on the arm of the chair etc. right next to you.

Anyway, what you really need to do, is place your ‘Five’ speaker in the 2nd section of an Alexa enabled group in the Amazon Alexa App and put any Alexa components (Move/One) in the 1st section of the same group and all will duck their audio when you say ‘Alexa’ and will be ready to listen to your instruction. 

So perhaps just do a little research on ‘Alexa enabled groups’ and you will likely/quickly resolve the Alexa listening issues that you mention.

Userlevel 1
Badge

That’s super helpful, thanks @Ken_Griffiths ! Currently I’d have to yell “ALEXA!!!!!” or mute the Five when I call for her because the One can only hear what the Five has to say while we’re watching TV.

 

I will try the grouping thingy and see if that makes a difference.

 

(We had some credits we could use in our local electronic store and we got the Move 2 for about half price, that’s why we went with it, in case you’re curious….. Lol)

@va2yes,

Ah okay, I see - nice discount.👍

In the Alexa App, create a group and put the ‘One’ and ‘Move’ in the first section of the group and the ‘Five’ in the second section - ALL speakers will then ‘duck’ their audio when you speak to Alexa installed on either the ‘One’ or ‘Move’.

The 3rd ‘speaker’ section of the Alexa group can be used for automatic grouping/ungrouping of your Sonos speakers. As an example, if you were to add all three speakers to that section and asked Alexa to play music, she will auto-group your Sonos speakers and play the requested music to all.

Userlevel 1
Badge

@Ken_Griffiths 

 

Alexa app is driving me nuts…… it can’t fine the Five so I can’t do the grouping thing…… aggghhh

Userlevel 1
Badge

Also, the Move 2 is recognized as a ‘speaker’ instead of an ‘Alexa-enabled device’ in the Alexa app. This grouping thing is not going very well……

 

Note an Alexa device can only be used once only to control a group - so first, perhaps make sure you only have the one group in the Alexa App - you likely don’t need multiple groups here to achieve what you’re looking for anyway. - if you cannot put the Move in the first section of the group, then place it in the second section of the group, just for now.

Just to add aswell, in the Alexa App device list there are two icons/components that represent a Sonos Move - there’s the speaker itself and the Alexa component of that speaker - the latter you will find inside the speaker icon in the list. So you merely add the speaker to the first section of the Alexa group. 
 

My two Move 2’s are called ‘Moveable’ and ‘Traveller’ and as you can perhaps see in the attached image, I have added them to the first section of the Alexa group called ‘Bedroom’, alongside other Alexa components I have in that room - Beam (Main Bedroom) and an Echo Speaker (Amazon Bedroom Alexa) - so all these devices will ‘duck’ their audio whenever I use the Alexa wake word.

Userlevel 1
Badge

Hmmm….. so this is what my group looks like.

 

The ‘Home Theatre’ has 1 Arc, 2 Subs and 2 Fives. This is set up in the Sonos app, and is picked up as Home Theatre in the Alexa app.

 

Inside of the ‘2 Sonos Speakers’, there are the Move 2 and the Home Theatre.

 

 

So in my LIVING ROOM group, there is no ALEXA devices, only SPEAKERS.

 

(by the way, Move 2 is the only device that’s set up with Alexa, I didn’t do this for the Arc)

 

With this setup, will the Home Theatre duck when I say ‘Alexa’?

I see you have Alexa installed on ‘Home Theatre’ Arc (…it includes any surrounds etc; as they are ‘bonded’ as one Sonos room), but you should have your Move2 in the first section of the group too, that's assuming you have the Alexa assistant installed on that speaker🤔. 

You mentioned that you have a ‘Five’ speaker in your earlier post - I assume you meant that was a separate Sonos room (not a bonded surround) - if that’s the case, simply place that in the second section of the Alexa group to make it ‘duck’ its audio. If you just have the Fives ‘bonded’ (not grouped) to the Arc, they will duck their audio along with the Arc anyway, simply by leaving the Arc ‘Home Theatre’ in the first section of the group.

The third ‘speaker’ section of the Alexa group is for those you want the enabler/controlling Alexa devices to play the music to - if you have more than one speaker in that 3rd section (and the groups ‘playback options’ are set to ‘ALWAYS’) - then the speakers will auto-group together when you ask Alexa to play music .. example "Alexa, play Pink Floyd” etc.

Here is a ‘mock-up’ Alexa group (see attached) - that’s if you have a separate standalone ‘Five’ Sonos speaker not bonded to the Arc Home Theatre. If your Five is bonded as a surround only, then just ignore the second section of the Alexa group, as the Arc called Home Theatre will duck it’s own surrounds when you speak to any Alexa device in the first section of the group anyway.

Hope that assists?

Userlevel 1
Badge

I actually don’t have voice assistant set up on the Arc, so the Arc is simply used as a speaker.

 

Earlier I mentioned that I couldn’t add the Fives in the group but soon realized that in the Alexa app, the entire set of speakers (Arc, Sub, Five) is recognized as ‘Home Theatre’ but I couldn’t figure out how to delete that post… Lol

 

In my living room, I’m using the Move 2 as my Alexa device, and the ‘Home Theatre’ (=1 Arc, 2 Subs, 2 Fives) as speakers. But in the Alexa app, everything is recognized as speakers including the Move 2, so in the group I created in the Alexa app, there is no Alexa device…….

 

I have tried deregistering Move 2 from the Alexa app, disabled Sonos Skill, factory reset Move 2. Re-added Move 2 in Sonos app, set up voice assistant with Alexa in the Sonos app, enabled Sonos Skill in Alexa app.

 

Still, the Move 2 in the Alexa app is NOT recognized as an Alexa device. So frustrating…… T_____T

To check that an Alexa group playback options are set to ‘ALWAYS’ - goto ‘change’ next to the speakers in the 3rd section of the group and scroll to the bottom of the speaker list where you will see the ‘playback options’ for the current group. See attached.

Sorry, our posts crossed - I’m not sure why you are not seeing the Move 2 as an Alexa group ‘enabling’ (controlling) device - maybe it’s still to be rolled out to the area where you are?

Maybe speak to either Sonos Support, or Amazon Support, just to check… here is the link for Sonos Support:

https://support.sonos.com/s/contact

Userlevel 1
Badge

Thanks a lot, @Ken_Griffiths! The best solution for me would still be being able to make Move 2 stay awake all the time. I think it’d be super helpful if that is an option (people can decide whether they’d like to turn on battery saving mode or not, instead having no choice). I’ll reach out to support and see if they can help with the group thingy. Appreciate your assistance!!

Thanks a lot, @Ken_Griffiths! The best solution for me would still be being able to make Move 2 stay awake all the time. I think it’d be super helpful if that is an option (people can decide whether they’d like to turn on battery saving mode or not, instead having no choice). I’ll reach out to support and see if they can help with the group thingy. Appreciate your assistance!!

If you leave the Move plugged into any compatible charger, or placed on its charger-loop, it never falls asleep - it only sleeps (when it’s running on its battery) after 30 mins of inactivity - I just leave mine on its charger-loop, when indoors. 

Anyhow, I hope you find the answers you’re looking for… 👍