Amazon Ultra HD not showing badge on Play:5 (gen 2)

  • 9 December 2021
  • 65 replies
  • 1742 views

Badge +2

I’m not seeing the “Ultra HD” badge when I stream Amazon HD on my Play:5 (gen 2) pair + Sub. It’s working fine on my Arc + Sub + Surrounds. Any thoughts?

Mr. T 6 months ago

Just off a call with Sonos Support.

Apparently it’s a known DRM issue and the technicians are working on a fix.

He said the Arc/Beam covers DRM so that’s why the Sub/gen2 works under HT conditions, but if bonded with a single unit or a stereo pair (Ones in my case) then Ultra HD not currently possible.

No timescale given but hopefully a software update will be available soon to fix this issue.

 

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

65 replies

Are you playing exactly the same source in the same way on the two speakers? That is, using the Sonos app not Alexa or the Amazon app?

Badge +2

Yes, same song from the phone app.

Just to say, you’re not alone. Exact same for me. Wondering if the Play:5 gen 2 are incorrectly listed as supporting it or something.

Userlevel 7

I am able to play Ultra HD music from Amazon Music on my Play:5 (Gen 2). Try selecting the entire album and tapping PLAY rather than selecting individual album tracks.

Thanks for the suggestion. That doesn’t work for me. Do you just have one Play:5 on that set up?

We have a pair with a sub. Wonder if it’s that combination that is the issue.

Userlevel 7

It’s just one Play:5.

You might try checking your Audio Quality settings in your Amazon Music account and make sure it is set to “HD/Ultra HD” rather than “Best Available”.

Userlevel 7
Badge +21

Just tried this.  I had to change the settings in the Amazon Music app to play HD in at least 2 places.

I then stopped the Amazon music stream and re-authorised Amazon Music within the Sonos App.

Now the HD appears when playing.  This is on 2 Gen2 Play 5s and a Gen2 sub.

I think my issue is a little different as I have Atmos or Ultra HD showing for other set ups as expected. But only HD shows on 2x stereo Play:5 gen 2 plus sub set up. Which apparently should be capable of Ultra HD.

Userlevel 7
Badge +21

Apols if you’ve already done so, but have you checked for updates again, you may have kit on different versions?

 

Userlevel 6

What generation Sub do you have?

If you remove the Sub can you play Ultra HD on the Play:5s?

I think the Sub is causing the issue here as I’m having the same issue with Ones and a Sub gen 2. The Ones will play Ultra HD if I remove the Sub, but only HD with the Sub, even although the Sub is supported for UHD playback…

 

Userlevel 6

Just tried this.  I had to change the settings in the Amazon Music app to play HD in at least 2 places.

I then stopped the Amazon music stream and re-authorised Amazon Music within the Sonos App.

Now the HD appears when playing.  This is on 2 Gen2 Play 5s and a Gen2 sub.


But is the song you’re playing actually capable of being Ultra HD? If so, then your stream is being downgraded to HD.

Thanks for the suggestions guys. I thought it might be the sub. I didn’t remove it, I turned it off though earlier and still didn’t work. I think it’s gen 2 sub.

Definitely seems that it’s being downgraded due to one of the devices.

Userlevel 6

It’s just one Play:5.

You might try checking your Audio Quality settings in your Amazon Music account and make sure it is set to “HD/Ultra HD” rather than “Best Available”.

 

 

I am not sure that the Audio Quality settings within the Amazon Music app have any effect when initiating playback from the Sonos app. Sonos will always get the “best available”. For instance, as a trial, I still get Dolby Atmos music on my Arc when the Amazon setting is set to “standard”.

Userlevel 6

Thanks for the suggestions guys. I thought it might be the sub. I didn’t remove it, I turned it off though earlier and still didn’t work. I think it’s gen 2 sub.

Definitely seems that it’s being downgraded due to one of the devices.


Just turning off the Sub won’t work as the stereo pair still think they are bonded with the Sub. It literally takes seconds to remove the Sub or bond it with another player. For reference, I’ve rebooted modem/router/all sonos speakers to no avail with getting the Sub to play UHD with a One stereo pair.

It’s just one Play:5.

You might try checking your Audio Quality settings in your Amazon Music account and make sure it is set to “HD/Ultra HD” rather than “Best Available”.

 

 

I am not sure that the Audio Quality settings within the Amazon Music app have any effect when initiating playback from the Sonos app. Sonos will always get the “best available”. For instance, as a trial, I still get Dolby Atmos music on my Arc when the Amazon setting is set to “standard”.

FWIW There is a separate setting in the Amazon Music App that enables Dolby Atmos/Sony 360. I’m not sure if that setting is relevant to Sonos, but it is in addition to setting the quality of the Amazon Audio. I would just enable it anyway if it’s not set already. I can’t see a reason though why it has any bearing on Sonos playback, as I’ve not seen anything mentioned in that regard. I mention it here, just in case.

Userlevel 6

Thanks Ken, yes aware of that setting too which was also turned off in my trial. I may be wrong but I believe the Amazon Music settings are only relevant for the relevant controller (ie. iPhone/iPad etc), rather than having any impact on the stream when playback is initiated from within the Sonos app.

Thanks for the suggestions guys. I thought it might be the sub. I didn’t remove it, I turned it off though earlier and still didn’t work. I think it’s gen 2 sub.

Definitely seems that it’s being downgraded due to one of the devices.

I would perhaps try the Sub (gen2) ‘unbonded’ and ‘bonded’ with the pair and just see if it changes anything. It might be a case that a Sub (gen3) is required, but I’ve not (yet) personally seen anything mentioned about the different Subs in the release notes/media reports.

Userlevel 6

Thanks for the suggestions guys. I thought it might be the sub. I didn’t remove it, I turned it off though earlier and still didn’t work. I think it’s gen 2 sub.

Definitely seems that it’s being downgraded due to one of the devices.

I would perhaps try the Sub (gen2) ‘unbonded’ and ‘bonded’ with the pair and just see if it changes anything. It might be a case that a Sub (gen3) is required, but I’ve not (yet) personally seen anything mentioned about the different Subs in the release notes/media reports.

 

In this article it states that all generations of Sub are supported for hi res.

https://blog.sonos.com/en-us/hi-res-audio-guide?fbclid=IwAR3vPVBv0X8742pTgY0ncI8FV-5Ola2a6TCIBnSEO1mOc8_5IGWKf27uaA0

How to listen to hi-res on Sonos

As of this post’s publish date, the following Sonos products are capable of playing 24-bit music at 48 kHz: RoamArcBeam (both generations), FiveSub (all generations), MoveOneOne SLPortAmp, SYMFONISK Bookshelf, SYMFONISK Table Lamp, Play:5 (Gen 2), Connect (Gen 2), and Connect:Amp (Gen 2).

 

I have three gen 2 Subs. I have no issue playing Dolby Atmos/Ultra HD on my Arc, Play:3 surrounds and Sub gen2 setup. Therefore the Sub gen 2 is supported for hi-res but maybe only when bonded with Arc/Beam…

In this article it states that all generations of Sub are supported for hi res.

https://blog.sonos.com/en-us/hi-res-audio-guide?fbclid=IwAR3vPVBv0X8742pTgY0ncI8FV-5Ola2a6TCIBnSEO1mOc8_5IGWKf27uaA0

How to listen to hi-res on Sonos

As of this post’s publish date, the following Sonos products are capable of playing 24-bit music at 48 kHz: RoamArcBeam (both generations), FiveSub (all generations), MoveOneOne SLPortAmp, SYMFONISK Bookshelf, SYMFONISK Table Lamp, Play:5 (Gen 2), Connect (Gen 2), and Connect:Amp (Gen 2).

 

I have three gen 2 Subs. I have no issue playing Dolby Atmos/Ultra HD on my Arc, Play:3 surrounds and Sub gen2 setup. Therefore the Sub gen 2 is supported for hi-res but maybe only when bonded with Arc/Beam…

Thanks for that link👍. It certainly reads to me like ANY Sub should work with the other devices listed (including the Play:5 (gen2) and Sonos One). It’s worth in your case trying rebooting/unbonding/bonding the players, I think, as my thoughts are that this should be working for UltraHD playback IMHO.

@Mr. T, just curious, but are your Sonos Ones gen1 or gen2, maybe it’s just the One (gen2) devices that are supported as the article doesn’t mention that it’s all generations of the Sonos One?… it’s a little ambiguous.

Userlevel 6

Thanks for that link👍. It certainly reads to me like ANY Sub should work with the other devices listed (including the Play:5 (gen2)). It’s worth in your case trying rebooting/unbonding/bonding the players, I think, as my thoughts are that this should be working for UltraHD playback IMHO.


Tried all that before and it didn’t help… Reboots of modem/router and lost count of how many times I’ve unbonded and bonded the Sub and every time with it bonded, only HD. Changing SonosNet channel doesn’t help either. I’ve even tried a hard-wired Sub and turned WiFi on the Sub off and still didn’t get UHD.

Just to perhaps assist, in the Sonos App ‘about box’ the hardware version begins…

Sonos One (gen1) : 1.21

Sonos One (gen2): 1.26 

Userlevel 6

@Mr. T, just curious, but are your Sonos Ones gen1 or gen2, maybe it’s just the One (gen2) devices that are supported as the article doesn’t mention that it’s all generations of the Sonos One?… it’s a little ambiguous.


I have a gen 1 and gen 2 in a stereo pair, and another two gen 2’s in a stereo pair. Same issue with both stereo pairs. I can get Ultra HD on the One (gen1)

I have several Sonos One (Gen 1s) and they do not play HD or Ultra HD from Amazon Music.

Userlevel 7
Badge +21

Just tried this.  I had to change the settings in the Amazon Music app to play HD in at least 2 places.

I then stopped the Amazon music stream and re-authorised Amazon Music within the Sonos App.

Now the HD appears when playing.  This is on 2 Gen2 Play 5s and a Gen2 sub.


But is the song you’re playing actually capable of being Ultra HD? If so, then your stream is being downgraded to HD.

Correct it only shows HD never Ultra HD.

If I play an Ultra HD track in the Amazon App and share to Sonos it shows Ultra HD still on the Amazon Music app but no HD or Ultra when displaying on Sonos App.