Sonos Sub less than 2 years STOP WORKING (NO POWER)

  • 24 October 2020
  • 9 replies
  • 1193 views

Hi 

I have Sonos Sub was working fine and all of sudden stopped working, no power at all, tried everything. changed the power cord, tried another power point. nothing worked. The Sub is less than 2 years old. 

Any one can advice Please.

Thank you


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 4
Badge +4

So sorry to hear of your trouble…..I’d assume that Sonos will aid you,if you reach out to them…..Worst case scenario would be for them to give you a new one at a hefty discount.

I know this doesn’t make you feel any better,but I was into ultra high end audio for decades and that stuff had numerous reliability issues over time...Far more expensive than a new sub from Sonos.

Good luck

Userlevel 4
Badge +4

Btw,I have my 2 Play 5’s(Gen 2) and the Sub all plugged into a quality Surge protector/line filter(Furman).

I had always remembered,from reports in audio publications, that our power lines introduce noise and a somewhat inconsistent current over time….From what I remember these articles stating is,it’s not so good for delicate electronics to be plugged directly into a wall outlet.

I don’t know how accurate that statement is,but for the lousey $100 that my Furman cost me,it’s pretty much peace of mind.

Just my 2 cents-:)

Thank you, Magictwanger, for your reply; I will contact the support line; I thought there would be a fix I don’t know about. You know how disappointing to have an expensive sub like this suddenly dies in less than 2 years.

Userlevel 5
Badge +14

Hi @alfredlotfy.

Welcome, thank you for reaching out to Sonos Community. I totally understand where you're coming from and I’m here to help.

Since it's a completely dead device, calling our customer phone support on weekdays is available.

If you need help with any other information, please be sure to let us know.

 

Hi @alfredlotfy.

Welcome, thank you for reaching out to Sonos Community. I totally understand where you're coming from, and I’m here to help.

Since it's a completely dead device, calling our customer phone support on weekdays is available.

If you need help with any other information, please be sure to let us know.

 

Thank you, @Mark P; I will contact Sonos support Monday, will post the updates here until the issue is fixed.

Userlevel 5
Badge +14

Hi @alfredlotfy.

Welcome, thank you for reaching back to Sonos Community.

No worries.

Cheers.

If you need help with any other information, please be sure to let us know.

Userlevel 4
Badge +4

Alfred,

This is pretty much exactly why I am a Sonos user these days,after investing multiple thousands of dollars on good sound,for years.

“Caring company,with good customer service”!

Please let me know how things turn out!

Userlevel 5
Badge +14

Hi @Magictwanger.

Welcome, thank you for reaching out to Sonos Community and providing good feedback about Sonos.

We deeply appreciate you doing business with us.

In the Sonos community, we also have our peer group that is very helpful and informative about their experience with our product.

Anyone is welcome to share their own opinion and helping one another.

Hoping to see any of your suggestions and helping other community folks.

Cheers.

If you need help with any other information, please be sure to let us know.

I have the same issue. Just under 2 years old and sub stopped working. Not sure what the outcome will be. Will contact Sonos tomorrow (mon am). Anyone have info as to likely outcome???