Sonos Era 100s Cut Out when Streaming From TV

  • 22 February 2024
  • 11 replies
  • 160 views

I have a Sonos Playbar and Sub connected to my TV, and two Era 100s (just replaced Play 1s) that I have in the kitchen (one large room kitchen + family room). They sound great and perform really well when grouped through the Sonos App. 

We use Hulu TV and also like YouTube. We like to watch games and watch live music performances on YouTube. Unfortunately, when I try to play through the TV, the Era 100s (and the Play 1s before) cut out a lot. The Playbar sounds fine, but it is directly connected to the TV. Is this an issue I’m getting from the TV itself, the internet or something else?

I’m considering getting a new tv regardless, but am curious if this issue will still exist after getting the TV.

Thanks  


11 replies

You may want to read the wifi interference FAQ, and consider interference in the 5Ghz range, which is what the surrounds use to get the signal from the PLAYBAR.

As a note, most, if not all videos from YouTube are in stereo, even when they claim not to be. Hulu, to my knowledge, streams some content in Dolby Digital Plus (potentially Atmos), but it depends on the source. Not every program is in that format. 

Userlevel 7
Badge +22

Probably WiFi issues.

https://support.sonos.com/en-us/article/improve-your-sonos-products-wifi-connection

Userlevel 7

A new television is unlikely to resolve the WiFi interference issue you are currently facing, as the sound still has to be passed from the Playbar to the grouped Era 100s.

Try increasing the Group Audio Delay under the Playbar’s room settings.

When I increase the group audio delay to max, it streams better. There are rare cut outs (that last a lot longer due to the delay), but few of them. Does that problem align with WiFi issues?

We have a google mesh WiFi that auto selects the channel, so it’s on 5ghz and we can’t seem to manually select. 

I assume the playbar transmits a signal from the tv through the WiFi to the other speakers on the network as selected through the app. Is my understanding correct?

Userlevel 7
Badge +22

For your setup I do think that is correct.

The auto channel selection can be a real pain if it switches while you are listening or if it lands on a channel that Sonos is using so turning it off would be a very good idea.

On a google WiFi mesh, it does not appear you can turn the auto-channel selection off. Getting a different router is not a big deal if that’s the upshot. Think i should replace?

Userlevel 7
Badge +22

I would, but wait a bit and see if anyone here has a better idea.

Userlevel 7

@geoffprints - If it’s easy enough to do, I would try wiring the Playbar to the main Google mesh node. Although the Era 100s don’t use SonosNet, I’m thinking if there’s a wired connection between the Playbar and Google Mesh, it may result in less dropouts if Google changes channel.

Thanks guys - picking up a new router tonight to see if it will do the trick. Wiring the Playbar isn’t an option. 

Just bought 100’s and Sub and have exact same issue.  I have added the Sub to my Arc soundbar.  The 100’s I have set up as separate stereo pair (I am using them as extra L/R Front channels, not rear surrounds). To play music video I Group the stereo 100 pair with the Arc + Sub.   Terrible.  The 100’s cut out every few seconds.   I don’t understand why I cannot “add” a Front stereo pair to the Arc like you can with the Sub or as Surrounds!?  
 

When I play eg Spotify through Sonos to the 100’s grouped with the Arc + Sub it sounds great, no cut outs.   It’s ONLY when using  the Samsung TV as the Source.   But that was the whole point of adding these speakers, to improve the sound for music video streams.  
 

Will contact Support but I sense a return coming.   (Don’t want to add Amp)

User583992 - after replacing every single component, including my modem, router, arc, sub and era 100s, the issue remains. I also have a Samsung tv. New tv comes friday just so i can listen to my tv in my open kitchen. 

I called customer service and after 35 minutes on the phone, they got me to level 2 support at which time they told me this is a KNOWN issue and that the system is functioning properly. 

I did put it in surround sound during the troubleshooting process, and it did not skip. They told me it’s too much data for it to be in stereo. 

Bummer. If anyone has any other bright ideas, I’m all ears because i really am invested at this point. 

 

Reply