Sonos Arc loud pop then audio loss



Show first post

1195 replies

Userlevel 1

Diagnostic info sent in case it might be of any help: 1973970356

Thanks. It’s not exactly fantastic looking at how many here have had an issue and how long it’s going back without a fix. I’m based in Europe where warranty rules are very strong so I’ll reach out to them and see what happens but will be insisting on a replacement if they can’t fix it. I’ve two other Arcs with Apple TVs and subs etc with no issues so to me it’s a hardware issue. 

Userlevel 1
Badge +3

Unfortunately, also need to report this issue. Started happening today when playing Xbox Series X on my LG C2 with the Arc connected. Really loud pop when playing Forza Horizon 5 and now it keeps returning. Hope Sonos comes through with an update to finally fix it for us all.

I had same issue yesterday night, it never happened before. Seems no solution available. In the meantime change XBOX audio output from ATMOS to DOLBY DIGITAL, not the best solution but it works

Userlevel 3
Badge

Any idea when we’ll hear back from that engineer who worked with @ProfessorFrag ?

Userlevel 4
Badge +2

Unfortunately, also need to report this issue. Started happening today when playing Xbox Series X on my LG C2 with the Arc connected. Really loud pop when playing Forza Horizon 5 and now it keeps returning. Hope Sonos comes through with an update to finally fix it for us all.

Again, why there should be a warning on the Sonos Site declaring not to plug in an Xbox Series X to the Sonos Arc. 

Userlevel 4
Badge +2

Bingo! I captured and submitted an Xbox pop as well.

I’ll stop now as this is quite time-intensive work. I’m looking forward to hearing what insights come out of this process. 

Thank you again for your efforts and everyone else on this board who are communicating with Sonos. 

Userlevel 3
Badge +3

Thanks. It’s not exactly fantastic looking at how many here have had an issue and how long it’s going back without a fix. I’m based in Europe where warranty rules are very strong so I’ll reach out to them and see what happens but will be insisting on a replacement if they can’t fix it. I’ve two other Arcs with Apple TVs and subs etc with no issues so to me it’s a hardware issue.  

That is interesting — assuming the others are both using Dolby Atmos, also?

Yes they are all using Atmos

Userlevel 3
Badge +3

Yes they are all using Atmos

Curious.

For me, I’m sold on it being a software issue as I was using the Arc in the same hardware configuration for a good 12 months before I experienced the pop, which only occurred after major revisions to the Sonos OS, Apple TV, and BRAVIA XH92. 🤔

My daughter told me when it started happening just recently she had it happen to her about 10 months ago when it was just installed. That was before all the Apple TV updates etc. 

Same issue here.  Has happened while streaming and also playing Xbox.  Have owned arc for about 3 weeks.  Has happened a handful of times.  Also concerned something could be damaged.  Sound is gone until I change inputs or reposed device.  Anyone figure this out yet? Seems like an ongoing 2 year issue 

Userlevel 1

Answer received by Dutch Sonos customer support:

"It is a known problem and is being looked into, but it is not a Sonos problem, all soundbars have this problem (like Samsung, LG, etc.).
It is not a Sonos specific problem, it happens to all soundbars, and right now the solution is this:
Disable Dolby Atmos and use Dolby Digital 5.1 instead."

Very unsatisfactory.

Userlevel 4
Badge +3

Unfortunately, also need to report this issue. Started happening today when playing Xbox Series X on my LG C2 with the Arc connected. Really loud pop when playing Forza Horizon 5 and now it keeps returning. Hope Sonos comes through with an update to finally fix it for us all.

I had same issue yesterday night, it never happened before. Seems no solution available. In the meantime change XBOX audio output from ATMOS to DOLBY DIGITAL, not the best solution but it works

Do you have Dolby vision enabled in tandem?  I turned that off and it completely solved the popping issue for me

Do you turn Dolby Vision off from the TV, Apple TV or Sonos itself?

and once you do aren’t you loosing something? 
 

Thanks

S

Userlevel 4
Badge +3

Do you turn Dolby Vision off from the TV, Apple TV or Sonos itself?

and once you do aren’t you loosing something? 
 

Thanks

S

In this case it’s on the Xbox itself.  There aren’t many games that supports Dolby vision for gaming and the benefits so far don’t really outweigh the marginal increase in quality plus the added lag

I’m having my issue when using my Apple TV so turning off Dolby Vision will have an impact I think. 

Userlevel 4
Badge +2

Same issue here.  Has happened while streaming and also playing Xbox.  Have owned arc for about 3 weeks.  Has happened a handful of times.  Also concerned something could be damaged.  Sound is gone until I change inputs or reposed device.  Anyone figure this out yet? Seems like an ongoing 2 year issue 

It is an ongoing issue that was first reported 2 years ago, unfortunately for all of us, there was no warning, no information, nothing to tarnish or affect the sales of the Sonos Brand.

We all bought into this system blind, believing we were purchasing a top tier product of the sound bar category.

And here we all are.

Userlevel 1
Badge +3

Do you turn Dolby Vision off from the TV, Apple TV or Sonos itself?

and once you do aren’t you loosing something? 
 

Thanks

I just removed ALEXA from SONOS ARC and issue was gone! That was changing point from my previous setup (no issue happened before), I added ALEXA a couple of weeks ago (never enabled before). Hope this solution works for all.

 

current setup is:

XBOX SERIES X DOLBY ATMOS enabled.

EARC MODE AUTO

PASS-THRU AUTO

DOLBY AUDIO DIGITAL PLUS enabled

 

Userlevel 1
Badge +3

Just forget it, just happened again!!!

But now this time I changed in SONOS APP from COMPRESSED AUDIO AUTO to UNCOMPRESSED AUDIO and finally is working great. No pop sound and ATMOS working great. And actually makes sense because my tv is configured for uncompressed audio output. That AUTO function from SONOS APP may not be working as expected.

Userlevel 1

Just forget it, just happened again!!!

But now this time I changed in SONOS APP from COMPRESSED AUDIO AUTO to UNCOMPRESSED AUDIO and finally is working great. No pop sound and ATMOS working great. And actually makes sense because my tv is configured for uncompressed audio output. That AUTO function from SONOS APP may not be working as expected.

Sounds promising! And you don’t get the pops anymore when playing DV+DA content from Xbox?

Userlevel 6
Badge +5

The compressed audio option is for Sonos products that use line in, not HDMI like Beam and Arc. Don’t get me wrong, I’ll test it when I have time. But it shouldn’t do anything on Arc since Arc doesn’t have a line in. 
 

As for the Dolby Vision discussion, please keep in mind that pops happen on the Xbox even if DV is turned off. Turning off DV is not a solution for Xbox. 

Userlevel 1
Badge +3

The compressed audio option is for Sonos products that use line in, not HDMI like Beam and Arc. Don’t get me wrong, I’ll test it when I have time. But it shouldn’t do anything on Arc since Arc doesn’t have a line in. 
 

As for the Dolby Vision discussion, please keep in mind that pops happen on the Xbox even if DV is turned off. Turning off DV is not a solution for Xbox. 

Thanks for pointing out. However my results are:

I’ve been playing HALO INFINITE for an hour by now and no issue happened. I have DV and DA enabled so far good results.

DV doesn’t have any relation with audio. I played yesterday night with DV de activated and no issue as well

Note: issue happened around 5 or 10 min after initiate a Xbox game

Userlevel 6
Badge +5

@ilh23mx first of all, I appreciate what you’re doing. Maybe, just maybe, you’re the one to have cracked this which would be amazing! I am not trying to dispute that the compressed audio setting matters. I’m saying that it shouldn’t because it’s a setting for line in. So of course nobody will have tried that yet  

My DV comment wasn’t aimed at you. Earlier in the discussion there was a recommendation to turn off DV on the Xbox. Turning off DV seems to help on Apple TV, but not on Xbox.

I’m about to go in a 4-day trip, which is terrible timing because I would love to help you replicate your result. If you’re willing to spend the time, I think it would be super helpful for you to try to return to a state where the pop happens. That would give us a lot of information about:

  1. Do Compressed Audio and Alexa matter in combination, or only one of them?
  2. Does your move fix it even when you return the settings to previous? This would lend credence to the hypothesis that Arc works fine until something triggers the “pop vulnerability”, and maybe your steps just happen to clear that trigger. 

If you can find a setting where you can make the pop disappear and reappear, you’ve won and solved this! If it’s now gone for good on the other hand, it might reappear and there’s something really complex going on. 

Userlevel 1
Badge +3

@ilh23mx first of all, I appreciate what you’re doing. Maybe, just maybe, you’re the one to have cracked this which would be amazing! I am not trying to dispute that the compressed audio setting matters. I’m saying that it shouldn’t because it’s a setting for line in. So of course nobody will have tried that yet  

My DV comment wasn’t aimed at you. Earlier in the discussion there was a recommendation to turn off DV on the Xbox. Turning off DV seems to help on Apple TV, but not on Xbox.

I’m about to go in a 4-day trip, which is terrible timing because I would love to help you replicate your result. If you’re willing to spend the time, I think it would be super helpful for you to try to return to a state where the pop happens. That would give us a lot of information about:

  1. Do Compressed Audio and Alexa matter in combination, or only one of them?
  2. Does your move fix it even when you return the settings to previous? This would lend credence to the hypothesis that Arc works fine until something triggers the “pop vulnerability”, and maybe your steps just happen to clear that trigger. 

If you can find a setting where you can make the pop disappear and reappear, you’ve won and solved this! If it’s now gone for good on the other hand, it might reappear and there’s something really complex going on. 

No worries I totally understood you previous comment. Also I tried to emphasize your statement.

Before returning to my original setup, I did a step before. I just removed ALEXA and I kept COMPRESSED AUDIO AUTO enabled in SONOS APP and issue occurred (ALEXA may not be the issue)

Final step I changed COMPRESSED AUIDO setting to UNCOMPRESSED and tried both DV on/off and issue disappear.

Later today I’ll go back to first step UNCOMPRESSED to AUTO and report if issue appears again.

Also I will try to enable ALEXA with UNCOMPRESSED setting to re-confirm if works well.

Thanks for the comments and advice, as soon as you return home safely please try my setup and confirm if works.

Userlevel 6
Badge +5

@ilh23mx amazing! You got it to pop and not pop just by changing the compressed audio setting? I’m blown away. 
 

I cannot wait to try this myself. Anybody else have some time to change Compressed Audio to Uncompressed and see if the pop disappears, and reappears when it’s back on auto?

Reply