Samsung + Arc + eARC issue

  • 28 November 2020
  • 3 replies
  • 468 views

Hi, 

As many other people I am having issues with a Samsung TV and Arc setup. Everyday sounds is cutting out until I restart the Arc (which should have a way to restart from Sonos app instead of unplug and plug the power cord)

 

I have a Samsung Q959TS with software 1403 and I have submitted diagnostic under 1445706949.

 

I bought both TV and Arc 2 months ago and I have regret that from day one. 
 

Please let me know if you find something in diagnostics or if there is anything I can do

 

thank you


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @ajibarra, thank you for reaching out to the Sonos community. We appreciate you for letting us know your concern as well as the steps you have performed and for submitting the diagnostic. I do understand how you feel but let me assist you with this.

Upon checking the diagnostic, your Sonos Arc is not getting a signal from your Samsung TV and the HDMI-CEC was detected disabled. Let me suggest the following troubleshooting and let us know if it works for you.

  1. Reboot your Sonos Arc and Samsung TV
    • Unplug the HDMI cable from the Sonos Arc and the Samsung TV. 
    • Unplug the power cable from your TV, the Sonos Arc, and any connected audio source (such as a cable box or video game console). Wait 30 seconds before you plug them back in.
    • Reconnect the HDMI cable to your TV and the Sonos Arc. Inspect the HDMI cable to ensure it’s not bent or kinked and check to see that it’s fully inserted into both devices.
  2. Update the TV’s software (if available)
  3. Adjust the group audio delay - Settings > System > Tap your Sonos Beam > Group Audio Delay and then choose a delay option.
  4. Check for Sonos update - Settings > System > Check for updates.
  5. Enable HDMI-CEC on your Samsung TV
    • Press the Home button your TV remote > Settings > General > External Device Manager > Select Anynet+ (HDMI-CEC) to turn it on. 
    • If you can't find it on your TV, please consult your TV manual.

Kindly update us after performing the steps above. Run another diagnostic report and let us know the confirmation number for us to check. We’ll wait for your reply.

CEC is enabled but since the sound is on and off then diagnostics were probably submitted when sound was off and Arc was not detecting an input..

 

I can try again rebooting both even when I have done that already and won’t make any difference. Both devices are updated to latest firmware. About group delay, which value should I set there?

Userlevel 5
Badge +16

Hi @ajibarra, thank you for your response and for updating us that the CEC is enabled on your TV. Please perform the steps that we provided. In group delay, 75s is selected by default, you may toggle between other selections and check the audio. If the issue still the same, you try to repeat the TV setup.
On the Sonos app, go to Settings > System > Tap on Living Room (Beam) > TV setup. Please follow the steps on the app to complete the setup. Once completed, test your Beam if it’s working.

If there’s no improvement with the sound, it would be best for you to continue working with us over the phone with our Sonos Customer Care support to perform in-depth troubleshooting. Our phone support has the tools to check what's going on in your system and to remotely access your device to provide the best option for you. Please let us know if you still have further questions or concerns. We are always here to help.