Pause behavior when grouping/ungrouping

  • 11 November 2021
  • 3 replies
  • 72 views

I have a Beam soundbar I use for TV, and a pair of Ones in the same room for music. I’m aware I could put the Ones in the back of the room and pair them to the Beam as surrounds, but I really like where they are towards the front of the room for music. Music sounds great when the Ones and Beam are grouped.

However, I’m having a bit of a frustrating experience switching back and forth between music and TV. I can’t leave the speakers grouped, because for whatever reason there is a minimum delay between the Beam and Ones of 75ms (I think) that causes an echo effect. So I set the beam to “ungroup on autoplay” for when the TV comes on. This works fine if the TV comes on when music is already playing: The Beam and Ones are ungrouped, the Beam starts playing TV and the Ones are paused. However, if the TV comes on when the speakers are grouped with music already paused things get weird: The Beam and Ones are ungrouped, the Beam starts playing TV and music is unpaused on the Ones. This creates quite the cacophony and typically makes my girlfriend mad.

Is there any way to have a little more control over this? I would really love it if I could just leave the Ones and Beam in a permanent group for music and TV, but I haven’t had any luck figuring that out due to the mandatory delay settings. At the very least I’d like the Ones to stop blasting music whenever someone turns on the TV.


3 replies

Just wondering if you normally use Spotify as your music source? .. The reason I ask is that another forum user reported a similar issue here with their TV recently, whilst using Spotify:

I can’t suggest anything to prevent the ‘paused’ playback of the music audio from resuming on your ‘One’s’, other than to reboot your local router and all your Sonos players, but I can perhaps suggest a few things to try, if you prefer to leave the speaker room ‘grouped’ with your Beam, which may help to keep all in sync with TV audio - but it needs to be TV stereo audio, rather than Dolby surround audio - if you want to try that? (Let me know and I will reply back with some suggestions to try).

I do use Spotify, and that issue looks pretty similar! I don't think it's an IP issue, as the router has been power cycled a few times while this problem has persisted, and I can see on the DHCP table that all the speakers have unique IP addresses. The Beam is connected via Ethernet cable and the ones via SonosNet. It seems like if one of the speakers starts autoplay when grouped, then the rest are sent a pause command, but the pause seems to work like a play/pause toggle instead of just a pause.

I'd be very interested to hear how to keep the Ones synced with TV audio!

Yes that’s interesting re TV ‘grouped’ audio and Spotify resuming when the TV is powered on - I will see if I can try to reproduce that issue this coming weekend and let you know what I find.

When you group ‘other’ speakers to a Sonos HT however, you will of course see that it works extremely well for playback of music-audio via the Sonos App etc; but you will likely encounter a slight audio-delay (echo) when playing the TV audio,  due to the way the ‘grouping’ works. So you may notice lip-sync issues with the video on the TV screen.

To possibly remedy this for TV PCM stereo audio, first goto“Settings/System/[Beam Room Name]/Group Audio Delay’ and ensure the delay/buffer is set to its lowest setting (75ms)

There is a another feature in the Sonos App to help with audio (lip-sync) delay in a TV grouped room situation in “Settings/System/[Beam Room Name]/TV Dialog Sync" - if you adjust the slider bar towards the right-hand-side, it should assist to bring the audio into sync in some cases, but whilst it may eliminate the TV audio echo, it may not always keep it in perfect lip sync with the video seen on screen… it’s a case of trying this feature to see if it works for you and your TV/network/setup.

HTH.

 

Reply