Answered

Other speakers not working with Arc

  • 15 March 2021
  • 3 replies
  • 646 views

Long time Sonos customer with many speakers.  Added an Arc recently but there is no output from speakers (sub, surrounds) in the same room with the Arc - neither (full) music nor surround (dolby digital).  The same speakers work fine in another room, including with a Playbar instead of the Arc or when added to a different room and grouped.

 

Diagnostic:  1191244377

icon

Best answer by Corry P 15 March 2021, 16:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +18

HI @Kevin2021 

Welcome to the Sonos Community!

Generally, for analysis of your diagnostics, you should get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system. I did take a quick peek, however, and all of your speakers, with the exception of the Arc and Master Bedroom (R), are operating on channel 6 whereas the two mentioned are on channel 1. This mismatch is a bit of a problem, but easy to fix.

As your WiFi is on channel 7, which overlaps with 6 (not good), we’ll pick channel 1 for Sonos.

Please open the Sonos app and make very sure all your speakers are online and visible in the app.

Select Settings » System » Network » Change SonosNet Channel » 1

The change should basically be instant, but after doing this, please switch the Arc off (or unplug) for about 30 seconds. Wait for a solid white light once it’s back on, then wait another minute. Test, and if the surrounds are either missing or don’t play, please reboot them too.

Master Bedroom (R) should take care of itself, but if there are any problems, reboot it too.

Thanks!  Switching the SONOS WIFI channel to “1” and powering the Arc off / on worked.  I couldn’t find a way in the app to see which channel each SONOS speaker is using.  Is there a way for me to check this in the future and adjust as necessary?  It’d be nice if this info was available in the SONOS app (e.g. under the System » About My System under “Sonos System Info”.  Would also be nice if the app alerted to such issues rather than having the speakers just not emit sound.  I added and re-added the SUB and surrounds dozens of times before discovering this.  Perhaps the SONOS systems auto selecting a non-conflicting WIFI channel would be better too.  Thoughts / suggestions?

Userlevel 7
Badge +18

All Sonos speakers default to channel 6 for Sonosnet, by default. The issue only really arises when the channel is adjusted on the system and some speakers don’t get the message - this is why I asked you to make sure all speakers were visible in the app before doing so. Any speakers that don’t get the message are “left behind”. I can only presume that this is exactly what happened in the past, at some point.

Some things are best left to technical support, as without full understanding or precautions, a user can make a situation worse for themselves, rather than better. Certainly, as soon as I opened the diagnostics, I was informed in red writing of the channel mismatch so it would always have been the first thing to be addressed had you got in touch with technical support.

We really do suggest getting in touch with our team before you try anything drastic like factory resets or spending hours troubleshooting - some things just need the diagnostics to get a full picture of what’s wrong, and what should be done about it. We’d rather get people calling with the occasional easy fix (“reboot the speaker, please”) than have them get frustrated with something they have purchased for no reason but to provide musical pleasure.