Answered

Only stereo pcm from samsung qn90 and applevtv | No DD 5.1

  • 11 February 2024
  • 14 replies
  • 112 views

Badge

I’m facing this issue only from last few weeks. All I get is stereo pcm when watching 5.1 content. No issues with Atmos content. 

Samsung qn90 with Apple TV 4K, Arc, Sub, 300s. Arc is connected via hdmi eArc to my tv. 

Apple TV audio is set to Auto/Atmos.  Sound is not right when I change Apple TV audio to ON ( I hear voice from surround and not from Arc).

icon

Best answer by Coltsguy 17 February 2024, 15:27

View original

14 replies

I would leave the Apple TV audio ‘change format’ to ‘ON’ and see what happens when you switch ‘OFF’ eARC on the TV and just leave it as a HDMI-ARC connection only.

Badge

I tried it. Did not make any difference - still get only stereo pcm

What is the DTV audio output set to on the TV?

Is the audio-out on the Arc/eArc port also set to ‘pass-through’ and is the ‘HDMI input format’ set to ‘Bitstream’ in the TV audio settings?

Updating to the beta versions of Apple TV, seems to have solved this issue for me.

 

Edit(nvm, on the same source sometimes it’s stereo PCM or 5.1 pcm multichannel) seems completely random. I have to jump in and out of the source to get 5.1 multichannel.

Updating to the beta versions of Apple TV, seems to have solved this issue for me.

 

Edit(nvm, on the same source sometimes it’s stereo PCM or 5.1 pcm multichannel) seems completely random. I have to jump in and out of the source to get 5.1 multichannel.

You should not get Multichannel PCM if you switched ‘ON’ the change audio format on the ATV and was just using an HDMI-ARC connection, as mentioned earlier, but if McPCM works, then just go with that.

Badge

What is the DTV audio output set to on the TV?

Is the audio-out on the Arc/eArc port also set to ‘pass-through’ and is the ‘HDMI input format’ set to ‘Bitstream’ in the TV audio settings?


Sorry for the delay in getting back. I don’t find bitstream option in my tv. HDMI eARC is turned off and digital output format is set to Auto. 
I get pass through option only when eArc is Auto but the sound keeps cutting off when watching Atmos content. I get McPCM 5.1 for 5.1 content in this case.  

Sonos says it’s something to do with Samsung eARC but in my case it was always disabled and I used to get 5.1 and Atmos for respective content until few weeks ago. 

also I took Apple TV out of equation. I get DD plus 5.1 on Samsung native apps for both Atmos and 5.1 content. 
 

I am clueless at this point 😔

Badge

@Ken_Griffiths 

Here’s my findings from various attempts 

 

Content Samsung TV eARC / Sound Output Apple TV Audio O/P Sonos App Findings
Atmos Off / Auto Auto, Atmos Atmos  
5.1 Off / Auto Auto, Atmos Stereo PCM  
5.1 Off / Auto On, DD 5.1 DD 5.1 It doesn’t sound right. I hear voice in surrounds for some content. 
Atmos Auto/ Pass thru Auto, Atmos Atmos Constant sound cut off
5.1 Auto/ Pass thru Auto, Atmos MCPCM 5.1  
5.1 Auto/ Pass thru On, DD 5.1 DD 5.1 It doesn’t sound right. I hear voice in surrounds for some content. 
Atmos & 5.1 Auto/ Pass thru N/A DD Plus 5.1  Samsung Native Apps.

Have you perhaps tried different cables for both the Apple TV and the Sonos Arc, just to rule out those as being the issue. I would also disconnect any other devices connected to your TV’s other HDMI ports (if applicable) and try powering things off for a couple of minutes. Just see if those things make any difference.

If not then it maybe best to reproduce the issue and then immediately submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

Oh, one other thing, that is to check your Samsung TV, Apple TV and Sonos setup are all running on the latest software updates too.

Badge

All running on latest software updates. I did try changing hdmi cable for arc and same results. 
I spent couple of hours with Sonos support and they conclude it’s a TV issue. 

All running on latest software updates. I did try changing hdmi cable for arc and same results. 
I spent couple of hours with Sonos support and they conclude it’s a TV issue. 

It’s perhaps worth contacting Samsung Support too then and see if they can help - it’s true they have had some issues with connected soundbars on their TV’s (as you can maybe see via a Google search) but Samsung was supposed to have fixed the issues with updates last September 2023. Maybe see if they have any suggestions for you to try.

Userlevel 1
Badge +2

If everything is up to date and you have actively checked for updates then my only advice is to turn off all power to your devices. In other words, pull the plug out of the socket and wait 5 minutes before turning it on again (TV, Apple TV, All SONOS)
Also try restarting your modem/router..

Badge

I’ve pulled the plug and restarted multiple times on all my devices including router but no luck. My wifi signal is very strong ~500 mbps, so it not wifi issue either. 
 

i am tempted to factory reset my tv but im afraid it will make things worse. 

I’ve pulled the plug and restarted multiple times on all my devices including router but no luck. My wifi signal is very strong ~500 mbps, so it not wifi issue either. 
 

i am tempted to factory reset my tv but im afraid it will make things worse. 

I personally think you’re best to seek advice from Samsung Customer Support - it’s often a real nuisance resetting a TV I would see what they say. If it was a WiFi issue I would expect the video to stop/break-up too, so I don’t think the WiFi connection is part of the issue you’re seeing here.

Reply