More set up trouble

  • 19 December 2020
  • 4 replies
  • 1151 views

I’ve got a new router and lost all my Sonos connections. Message says “Your Beam has been added but may not appear in the System tab. If so, unplug the power cord and plug it back in to finish set up from the System tab.”  I’ve done so, and it doesn’t work. I’ve tried to factory reset several times - doesn’t help.  Tried with a friend’s android device instead of my iPhone- no luck. Tried plugging it into my router directly, and that worked, but when I unplugged it and moved it to its proper location - same problem.   Having the same problem with a Play:1
 

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +18

It’s often easiest to give the new router and it’s wifi the same SSID and password as the outgoing one, but you’ve gone a bit beyond that stage by the sound of it - especially since you’ve done a factory reset. 
 

Have you read and followed the guidance on the support pages? https://support.sonos.com/s/article/1061?language=en_US Have you reset the speakers’ wifi credentials?

Userlevel 1

I’m having a similar issue.  Sonos connectivitity is so damned fragile and I’ve waisted two days on this.  I can’t get more than one speaker to be in the system at any given time.

Userlevel 7
Badge +18

I’m having a similar issue.  Sonos connectivitity is so damned fragile and I’ve waisted two days on this.  I can’t get more than one speaker to be in the system at any given time.

Power off (unplug) all your Sonos speakers. Restart your router. When it’s fully restarted and wifi is running, power up one Sonos speaker (Beam or Arc if you have a home theatre products). When it’s fully running power up the next speaker. Continue one device at a time. This ensures fresh ip addresses are allocated. If this sorts the problem, consider setting allocated ip addresses as the next step, to minimise risk of the situation repeating. 

I also have a similar issue trying to re-connect my Sonos Connect.

Each time I come across the same error whilst trying to re-add the Connect “Your Connect has been added but may not appear in the System tab. If so, unplug the power cord and plug it back in to finish setup from the System tab.” There is just a single “Done” button.

I was having issues with audio breakup, so I switched ethernet ports to see if that would help (wi-fi is disabled as the Connect constantly reboots if it is enabled, but that’s another story).

Nothing else changed.

Apart from the audio issues (and lack of Connect wi-fi), my Sonos system was functioning perfectly happily. Both Sonos items (One and Connect) have had allocated IP addresses from day one, and I have a narrow DHCP pool to ensure there are no overlaps. I have also taken the time to delete the old MAC bindings and re-assign a new IP address, as part of the troubleshooting procedure.

I can check the router and I see that, after receiving the error message, the Connect is connected via an ethernet port, and has a suitable IP address.

I am using the S2 app on iOS 14.3, and have restarted the iPhone and deleted and reinstalled the Sonos S2 app.

If I do as it suggests and unplug the Connect and plug it back in, then press the “Done” button, I am dumped back into the system tab with no further information on how to proceed, and no Connect in the system.

The Connect seems to be happily on the network (it’s showing a solid white light), but I cannot control it with any Sonos apps (iPhone, PC or Mac). Indeed, I can browse to the status pages on the 1400 port of the address that was assigned. (I just cannot make any sense of the data: I’m not an engineer...)

The only option is to reset the Connect and repeat, hoping, against all evidence to the contrary, that *this time* it might work.

Any help would be greatly appreciated, otherwise the Connect has just become my most expensive paperweight, and my loyalty to the Sonos brand a thing fading into the past.