How do i stop my Sonos Arc from resetting its volume to zero when I turn off TV?


Whenever I turn off my TV, my Sonos arc always resets itself back to zero on the volume scale.

So I ways have to grab my remote and turn the volume back up to what I want it to be.

How can I prevent us so it just keeps the same volume on when I turn the TV on?

 

TV is: VIZIO 75-Inch P-Series 4K QLED HDR Smart TV w/Voice Remote, Dolby Vision, 4K 120Hz Gaming, Alexa Compatibility, P75Q9-J01, 2022 Model


18 replies

Userlevel 7
Badge +15

Hi @Obizues,

The Sonos Arc shouldn’t set itself to 0 when the TV is turned off. It accepts volume changes from the TV, TV remote, Sonos App, and volume touch buttons, so it’ll be one of those that is changing the volume to 0.

The best way for us to check what’s causing this, is to replicate the issue and submit a diagnostics then reply here with the confirmation number. I can then check the diagnostics to see where the volume command came from.

You can also reach out to our support team to perform some live troubleshooting of this issue with them, as it seems easy enough for you to replicate it.

I hope this helps!

Submitted: 2109350559

Userlevel 7
Badge +15

Hi @Obizues,

The diagnostics is showing Sonos Not Found, meaning the controller can’t find or connect to your Sonos system.

I’m not able to see any system information with this type of diagnostics, so I wont be able to check what is causing the volume issues.

Make sure the controller you’re using can see the Sonos system before you submit a diagnostics. If you aren’t connected to the same Wi-Fi or you don’t see any speakers in the Sonos app then I wont get the full picture.

Badge

Sonos:

Was this person’s issue resolved - How do i stop my Sonos Arc from resetting its volume to zero when I turn off TV? 

I have the same problem with the Arc, Sub and Sonos One speakers.  Volume drops to zero when I turn off the Samsung 4K HDR Smart TV, leave it for awhile, and then turn it back on wherein I need to reset the volume.  Also the same when I pause a streaming program and come back to it after 10 minutes or so.  Did not have this problem with my previous Samsung speakers but only when I changed over to Sonos.  It’s like the Sonos are timing out!   Any resolution options a year later from this fellows problem identification?

What did Sonos say when you submitted the diagnostics that the Sonos rep asked for, and called Sonos Support directly to discuss it?

Badge

I was not asked to submit a diagnostics to Sonos?  I thought that someone might have figured this out by now.  How do I submit this diagnostics and do I do it before or after Sonos reaches out to me?

Userlevel 7

@BrianDen

There is chatter on the internet regarding Samsung TV’s lowering the volume. Although it speaks to the internal speaker there may be some bleed through into Sonos sounbars. I searched with the wording below and then found the 2nd link to Samsung. 

Search Wording:

Did you mean: do samsung 4k smart tvs automatically lower volume when turned off or paused

2nd Link:

https://www.samsung.com/au/support/tv-audio-video/how-to-troubleshoot-the-samsung-qled-tv-that-turns-the-volume-up-and-down-automatically/

Diagnostic:

Recreate the issue and run the diagnostic within 10 minutes, post the reference ID # and the call Sonos Support.

  • How to Submit Diagnostic Link
Badge

Thanks and I’ll take a closer look at these and see how they might apply to my situation.

Userlevel 7

@BrianDen 

I edited my post and sent you info on submitting a diagnostic 😊

Badge

Thanks!

In my opinion you should be careful what you wish for. In my area the cable box will update in the middle of the night and then turn ON. At this point the TV will assume that the viewer wants to watch TV and it will turn ON and pass audio through to the soundbar. This is not what I want and I must make a point of setting the soundbar’s volume to zero as I end each viewing session — else the next session, planned or not, might come through with an inappropriate Volume level. I would appreciate this ‘auto zero’ function.

Userlevel 7

In my opinion you should be careful what you wish for. In my area the cable box will update in the middle of the night and then turn ON. At this point the TV will assume that the viewer wants to watch TV and it will turn ON and pass audio through to the soundbar. This is not what I want and I must make a point of setting the soundbar’s volume to zero as I end each viewing session — else the next session, planned or not, might come through with an inappropriate Volume level. I would appreciate this ‘auto zero’ function.

@buzz 

Are you serious??? Who’s your cable provider. I want to make sure I don’t use their service. 😂😂😂

Badge

Thanks for the feedback!  For sure I don’t want the volume to start blaring in the middle of the night!!  Doesn’t sound like there is a very good fix for this nagging long-standing problem with Sonos equipment (at least for some of us)?

It depends on what is causing the issue. Submit the diagnostic, call Sonos. They’ll suggest either a fix or no fix, depending on which issue it turns out to be. 

In my opinion you should be careful what you wish for. In my area the cable box will update in the middle of the night and then turn ON. At this point the TV will assume that the viewer wants to watch TV and it will turn ON and pass audio through to the soundbar. This is not what I want and I must make a point of setting the soundbar’s volume to zero as I end each viewing session — else the next session, planned or not, might come through with an inappropriate Volume level. I would appreciate this ‘auto zero’ function.

@buzz

Are you serious??? Who’s your cable provider. I want to make sure I don’t use their service. 😂😂😂

 Comcast/Xfinity. This characteristic could be different in different areas.

Thanks for the feedback!  For sure I don’t want the volume to start blaring in the middle of the night!!  Doesn’t sound like there is a very good fix for this nagging long-standing problem with Sonos equipment (at least for some of us)?

There is a communication path in HDMI cables, known as CEC (Consumer Electronics Control). It’s slow (417 bits per second) and crude. It’s basically an announcement, such as “I just turned ON”. The other components will decide what they will do with this notice. You can insert a “CEC Blocker” in a unit’s HDMI connection to prevent these transmissions. In your case you could block CEC to the soundbar. You would then need to switch to IR Volume commands for the soundbar. Since most hand held remotes support this and the SONOS soundbars can be trained to accept IR Volume commands, most users will not notice the change.

Userlevel 7

In my opinion you should be careful what you wish for. In my area the cable box will update in the middle of the night and then turn ON. At this point the TV will assume that the viewer wants to watch TV and it will turn ON and pass audio through to the soundbar. This is not what I want and I must make a point of setting the soundbar’s volume to zero as I end each viewing session — else the next session, planned or not, might come through with an inappropriate Volume level. I would appreciate this ‘auto zero’ function.

@buzz

Are you serious??? Who’s your cable provider. I want to make sure I don’t use their service. 😂😂😂

 Comcast/Xfinity. This characteristic could be different in different areas.

It must be. I have the same service and it’s not occurring on my TV. 🤔 

Does it occur on just one TV or others in your home as well? I ask because I had a similar issue that I resolved and it only occurred one TV. However, I didn’t attribute the issue to Comcast/Xfinity.

This could also be a characteristic of a particular cable box model. Anyway, there is only one TV and we dumped Comcast.

Reply