Answered

Feature request: disable wifi on Era 300s

  • 27 April 2023
  • 3 replies
  • 270 views

Userlevel 3
Badge +1

I bought two of the ethernet to usb-c dongles in the hopes of returning my setup off wifi. I’m using the Eras 300s as rears in connection with an Arc and Sub Gen 3.

I can see that the dongles are working, but the era 300s are also still connecting over wifi. When I disable the wifi on the Arc/sub the Eras switch to WM:1 and the audio immediately gets choppy and stays that way (whether connected via ethernet or not). 

As a test, I temporarily renamed my wifi to see if the Eras would fall back to the ethernet connection, but instead they just drop out entirely. Is there anyway to force them to just use ethernet? My previous One SLs worked flawlessly as ethernet surrounds.

 

I want the ability disable the wireless for at least two reasons:

Living in Brooklyn there’s already a ton of wireless interference so cutting down on unnecessary (particularly stationary) wireless is always nice.

When I leave wireless enabled on the Arc, the Ones, which I relocated to my bedroom prioritize connecting to it via sonosnet instead of my wireless router. The Arc is further away than my router and there are many more objects and walls in between that make it particularly less ideal for wireless signal, so the ones regularly disconnect and their status lights flash on and off for a few minutes until they re-establish connection. Not really the bedroom aesthetic either me or my girlfriend are going for.

 

 

 

 

 

icon

Best answer by Corry P 1 May 2023, 17:45

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +22

When I disable the wifi on the Arc/sub the Eras switch to WM:1

You are another person bitten by the mislabeled Sonos option, that does not turn off the WiFi in your Arc, it turns off the radio. So yes, no WiFi but also no SonosNet and no surround 5GHz link.

The Ones are acting as expected, if you have a wired Sonos device they will connect to it instead of WiFi. You could wire one or add a Sonos Boost located where it could be wired and provide them a better signal than the Arc.

Don’t know much about the Eras but there has been some discussion of them and networking here if you go digging for it.

Userlevel 3
Badge +1

When I disable the wifi on the Arc/sub the Eras switch to WM:1

You are another person bitten by the mislabeled Sonos option, that does not turn off the WiFi in your Arc, it turns off the radio. So yes, no WiFi but also no SonosNet and no surround 5GHz link.

Thanks for the response but not bitten at all! Totally understand how the setting works and am happy with it. Turning off the radio would most definitely also turn off wifi. I don’t find it to be mislabeled. (Unless you meant to say that it disconnects from wifi but leaves the radios on? but that also does not seem to be the case)

I just want the same option for the Eras (or even better if it was automatic as some here and on reddit have suggested, but that does not appear to be true per my test.)

 

I’m aware the Ones are working as expected, that’s part of what I’m trying to circumvent by disabling wifi/radio on the arc/sub.

Userlevel 7
Badge +18

Hi @eatzaylove 

Thanks for your post!

Era speakers should utilise ethernet if connected to it, regardless of anything else happening with the Arc (or any other ethernet-wired devices). 

Moreover, Era speakers will automatically disable their WiFi cards as soon as they are connected via ethernet.

So, while I am not entirely sure what’s happening with your own system - and I recommend you contact our technical support team as a result of that - there’s no need for you to request the feature to disable WiFi on Era models as it already happens automatically.

Note that for your surrounds to be ethernet-wired and work, the Home Theatre primary device (the Arc) must be wired to ethernet too.

I hope this helps.