Answered

Beam Gen2 connectivity issue with LG C3 TV

  • 17 November 2023
  • 4 replies
  • 2299 views

Hi everyone,

I have a problem with my Beam Gen2. I just got it 2 days ago and I’ve been trying to set it up with my LG TV but there is always some issue. It is connected through eArc HDMI port. This is present situation:

PHONE: If I play music on Youtube music or Spotify (both premium versions for what it’s worth) through Sonos app it is ok.

PHONE: If I use Youtube or Spotify app directly it won’t find speaker so it is not ok - sound is only on my phone.

TV: If I play music through Spotify or Youtube TV app there is no sound at all. Actually there is sometimes intermittent sound for splits of second which comes and goes. So music video is there playing on my TV but sound is not there.

Netflix is working fine except there is every now and then some short glitch in sound. I could live with this last thing cause I cannot be sure whether it is due to speaker or TV or Netflix or my internet connection, but the problem with TV is killing me.

I’ve tried to reset (by holding that infinity button behind) and reconnect Beam, to switch off and on several times, to use my wife’s phone but I am out of ideas now.

I’d appreciate if someone can be of assistance here.

 

 

icon

Best answer by GuitarSuperstar 17 November 2023, 17:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the Beam and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect any other devices to the TV.

And set the TV to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

Just an update. I tried to switch OFF e-Arc support on my TV and everything suddenly works fine. Tried to revert few more times just to confirm, eArc ON - same problems, e-Arc OFF -works fine.

Try this:

Disconnect everything from the TV and unplug the Beam and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect any other devices to the TV.

And set the TV to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

I’ ve tried your procedure but without success. Btw, I do not have anything alse connected to my TV.

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the Beam and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Beam to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Beam has been successfully connected, connect any other devices to the TV.

And set the TV to these settings:

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC Support: On

I’ ve tried your procedure but without success. Btw, I do not have anything alse connected to my TV.

If you have nothing else connected to the TV, you can keep the eARC setting disabled.