Answered

Arc + 2 One SL Surround w/ only 1 surround with WiFi enabled (bug?)

  • 23 December 2020
  • 7 replies
  • 189 views

I seem to have encountered a bug/limitation... I have ethernet to my surround setup (Arc, Sub, 2xSL) with the exception of one surround. By disabling wifi on the wired items, the single surround that remains on wifi will not play audio. 

The fix was to re-enable wifi on the Arc, that fixes the issue. 

Since I have ethernet wired to the Arc, I would prefer to disable wifi. Is this a known issue?

icon

Best answer by John B 23 December 2020, 23:10

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Since the Arc (and all Sonos soundbars) is designed to communicate with bonded speakers (surrounds and a sub) via wifi, you might be stretching the design by turning off WiFi on the Arc. To my knowledge, it’s an unsupported configuration, although I’m open to correction. 

That would be fine. But wouldn’t the Sonos app alert me, or not allow me to disable WiFi on the Arc then? I mean it took me over an hour of fiddling around to determine this was the case.

I honestly don’t know, and would agree that such a warning would make good sense. In fact, I’d be happy if Sonos took away that option completely on soundbars, but there may be professional install reasons that I’m not aware of to cause them not to. 

Just as an addendum, the signal between the soundbar (your Arc, in this case) and the bonded speakers is on a 5Ghz and hidden channel, created by the soundbar. While the bonded speakers do receive IP addresses from your router, they don’t connect to the router’s WiFi signal.

Not a bug but user error, although understandable. You have turned the wireless radios off on the Arc, Sub and one of the surrounds.  The remaining speaker has no means to connect as a result. Surrounds connect by direct routing not WiFi and you have removed its ability to so that. 

The Disable WiFi setting is very badly labelled. This is  Sonos' fault. 

Btw, it's not a good idea to wire surrounds and Sub.

Btw, it's not a good idea to wire surrounds and Sub.

Why is that? I’ve observed the high amount of data transferred through each speaker - which creates a lot of wifi network traffic. I’ve had 5 of my 7 Sonos speakers wired on ethernet with WiFi toggled OFF in Sonos settings and everything works perfectly (better than before) and my Wifi is no longer congested. 

Just this one issue with the lone SL without ethernet. 

Btw, it's not a good idea to wire surrounds and Sub.

Why is that? I’ve observed the high amount of data transferred through each speaker - which creates a lot of wifi network traffic. I’ve had 5 of my 7 Sonos speakers wired on ethernet with WiFi toggled OFF in Sonos settings and everything works perfectly (better than before) and my Wifi is no longer congested. 

Just this one issue with the lone SL without ethernet. 

This is also my experience. If all are on ethernet, it’s ok to disable Wifi on all. But if one is not on ethernet, the Arc must also keep Wifi open.