Volume + Mute Control With 2021 Apple TV Remote


Userlevel 3
Badge +1

So Apple TV has a new remote, which now thankfully contains a Mute button. But, while the Sonos remote setup (in the Sonos iOS app) recognizes Volume Up and Volume Down, it still does not receive or recognize the Mute button on the new remote. Hopefully a software update can resolve this issue?


16 replies

Userlevel 6
Badge +17

Hi @bstahl 

Thanks for your post!

How does your Sonos product connect to your TV? Via optical or HDMI?

If it’s via optical link, you should find our Use an Apple TV remote with Sonos home theatre products help page useful.

If it’s via HDMI, I recommend unplugging all 3 devices from power for 30 seconds.

You may also find this thread useful:

I hope this helps.

Userlevel 3
Badge +1

Thanks Corry, but the links you sent are outdated. The point is the Apple TV remote now DOES have a Mute button, but the Sonos software doesn’t recognize it. I assume because it has not yet been updated for the new remote with Mute button, just as the setup help web page has not been updated yet. It states:

We don’t recommend using the Apple TV remote when setting up a Sonos home theater product since Sonos may need to learn and receive a mute command, which is not an available button on the Apple TV remote.

Which again, is now incorrect.

Userlevel 2
Badge

@bstahl  

I just got my new 2021 release Apple TV 4K remote with the mute button and my issue was that I would press mute and it would pause Sonos Playbar’s sound for about ½ second but then keep going.   Holding the mute button for a couple seconds worked but brought up an accessibility menu on my Samsung TV for both unmute/mute which was annoying.

My wife told me to try a double tap of the mute button and what do you know...it does successfully mute and unmute my Playbar.  Obviously I’d prefer if a single tap worked but at least the red has gone out of my eyes.    Sounds like yours is behaving differently / have you tried the ol’ double tap?

 

Userlevel 7

So Apple TV has a new remote, which now thankfully contains a Mute button. But, while the Sonos remote setup (in the Sonos iOS app) recognizes Volume Up and Volume Down, it still does not receive or recognize the Mute button on the new remote. Hopefully a software update can resolve this issue?

I too have the newly released  AppleTV 4K and my Sonos Arc recognizes the mute button. It even shows and on-screen mute icon (LG OLED 2019).

Userlevel 7

@danull 

I too have the newly released  AppleTV 4K and my Sonos Arc recognizes the mute button...no double tap required.  It even shows and on-screen mute icon (LG OLED 2019).

Userlevel 3
Badge +1

Hmm, I’ve got a Playbase and the ATV Mute button does nothing, nor will the Sonos remote setup recognize it. But as I said, the Volume Up and Down in the same remote work fine. Is Playbase incapable of using mute somehow?

Userlevel 6
Badge +17

Hi @bstahl 

When the Apple TV remote is put into IR mode (which you’ll need to do for use with a Sonos product utilising an optical connection to the TV) it copies the IR codes for the brand of TV that you are using. So while @AjTrek1 will get Samsung IR codes from their Apple TV remote, you will get different IR codes from the same remote that match your brand of TV.

Therefore, we are unable to add mute codes for the Apple remote to our list of known commands, as there aren’t any. If you’re able to program your Playbase to use the TV’s remote and mute then works, it follows that to get your Apple TV remote working, you’d need to get Apple to update their codes for your TV brand specifically.

You may find these instructions for the Apple TV remote helpful first, however:

 

 

Userlevel 2
Badge

Just in case somebody sees the same thing I did with the mute button turning on and then off with with one push on the Apple TV 2021 remote, solution to my problem was based on Corry P’s answer, more specifically go into the Apple TV volume control menu and then do the Learn and use the Samsung remote to program it, holding down the volume up/down button on Samsung remote for the mute part.

Hi,

Has anyone figured out how to have the new Siri remote learn the Mute command, for a Playbar?

I have an LG CX OLED TV (2020), I have it now control my Playbar. Only issue is, when I try to hold down the Mute button on the LG Magic Remote, it launches accessibility options, and thus would not complete Siri “learning” the mute IR Code.

 

Thanks.

Userlevel 7

Hi

Since it’s the LG remote that nixes the mute command that means its a programming issue with the remote and/or the LG. I suggest you you search for a software/firmware update for the LG in settings and/or call LG tech support.

Hi

Since it’s the LG remote that nixes the mute command that means its a programming issue with the remote and/or the LG. I suggest you you search for a software/firmware update for the LG in settings and/or call LG tech support.

I do have the latest firmware and software. 
The LG’s mute button on the magic remote works fine. I just can’t hold down on it for longer than a second since it invokes a shortcut command for accessibility. 
 

Thank you. Looking forward to someone figuring this out.  

Userlevel 6
Badge +17

Hi @thejose 

Sorry - I don’t understand. Why do you need to hold the mute button instead of just press it?

Hi @Corry P 

I need to hold it for more than a second otherwise the remote device learning step on the Apple TV will not be completed. 
I can do it with volume up and down no problem. It’s just the mute command step that’s giving issues due to what I mentioned above. 
 

thanks. 

Userlevel 6
Badge +17

Hi @thejose 

Ah ok - I understand now, thanks.

I can only recommend you get in touch with Apple or LGsupport about this, though someone in the Community here may know a fix?

Thanks @Corry P 

Only other solution I could think of is set the code for the Sonos Playbar (audio) on another universal remote, and use the mute button on it. Haven’t tried it yet, but I think I got an extra universal remote lying around somewhere. 
 

Userlevel 6
Badge +17

Hi @thejose 

Thanks @Corry P 

Only other solution I could think of is set the code for the Sonos Playbar (audio) on another universal remote, and use the mute button on it. Haven’t tried it yet, but I think I got an extra universal remote lying around somewhere. 
 

Excellent out-of-the-box thinking! I don’t see why that won’t work. Good luck!

Reply