Answered

Unable to add Sonos SL to Arc as surrounds

  • 12 December 2020
  • 9 replies
  • 277 views

Hello, I am getting the following error when I try to add my Sonos One SL I purchased today to my ARC + Sub Gen 3. “There was a problem adding your surrounds”.

 

My network is Ubiquiti (router is UDM Pro, the APs are FlexHD). All my devices are in the same VLAN.

I have reseted the SL speakers and adding them to my account again, adding as surround multiple times, restated all my network devices, restarted my ARC and Sub.  Nothing has worked at all when I am trying to add them to my ARC.

The One SL did join the WIFI and I can stream music to them individually (using AirPlay for example).

My ARC and SUB gen 3 are connected by Ethernet. Both of the Sonos One SL are setup wireless. Also, after trying to join both speakers and getting that error, it does list them as surround but it doesn’t really work.

 

Here is my diagnostic confirmation number: 1540609632

 

I grabbed the diagnostic right after the failure.

icon

Best answer by Luigi408 12 December 2020, 05:05

I got it to work. I read another thread that somehow the latest firmware broke wired + wireless setup. My ARC and Sub gen 3 are wired and my One SL were wireless.

I enabled WIFI on the ARC and SUB Gen 3 again (it was disabled since they were wired). After doing this I was able to add the surrounds to my ARC finally.

 

Will this issue be fixed?

View original

9 replies

I got it to work. I read another thread that somehow the latest firmware broke wired + wireless setup. My ARC and Sub gen 3 are wired and my One SL were wireless.

I enabled WIFI on the ARC and SUB Gen 3 again (it was disabled since they were wired). After doing this I was able to add the surrounds to my ARC finally.

 

Will this issue be fixed?

Userlevel 5
Badge +16

Hi @Luigi408.

Thanks for reaching out, let me check it for you.

I see on the diagnostic report that the surround speakers were successfully bonded on the Arc, however, the Arc and Sub’s WiFi interface are still ‘disabled’ and that is not a recommended configuration on a home theater setup. It’s not suggested to wire the Sub and the surround speakers as they are satellite speakers bonded to the home theater master (Arc), they need to communicate with the Arc’s wireless signal. You can keep the Arc wired though, but its WiFi interface must be ‘enabled’.

This article will guide you on How to disable or enable WiFi on your Sonos players.

 

If you are still experiencing an issue, please submit a new diagnostic report from your Sonos app when it happens and reply back with your confirmation number, so I can review your system further.

 

Keep me posted.

Thanks to Luigi408!

I had the exact same issue trying to add 2 Sonos One SL to my Beam as surround speakers. The Beam was wired to my Lan  whilst the One were WiFi connected. I activated wireless connection for the Beam too and everything worked.

That should be fixed by Sonos though, or at least users should be warned by the app to enable wireless Wi-Fi on the Beam before trying to add surround speakers.

Hi @Luigi408.

Thanks for reaching out, let me check it for you.

I see on the diagnostic report that the surround speakers were successfully bonded on the Arc, however, the Arc and Sub’s WiFi interface are still ‘disabled’ and that is not a recommended configuration on a home theater setup. It’s not suggested to wire the Sub and the surround speakers as they are satellite speakers bonded to the home theater master (Arc), they need to communicate with the Arc’s wireless signal. You can keep the Arc wired though, but its WiFi interface must be ‘enabled’.

This article will guide you on How to disable or enable WiFi on your Sonos players.

 

If you are still experiencing an issue, please submit a new diagnostic report from your Sonos app when it happens and reply back with your confirmation number, so I can review your system further.

 

Keep me posted.

Thank you for your response. I agree with RicFr (glad it worked for you too) that there should be a warning within the app itself if you’re adding surrounds. The usual thinking is that any device in the same network, regardless of how it is connected, should be able to communicate with each other. That’s why I though I didn’t need the wifi enabled on my devices that were plugged with Ethernet cable. As long as the devices are in the same network it would work.

 

Please pass this feedback along to the developers to add some kind of warning or to automatically detect and turn wifi back on the ARC and other devices that use support surround speakers when setting up the surrounds. Thanks.

Userlevel 5
Badge +16

Hi @RicFr and @Luigi408.

Thank you for posting and sharing your experience with us. We highly appreciate your feedback.

It’s good to know that it was figured out and the issue was now resolved by enabling the WiFi interface and I see your point on getting a prior warning would be helpful. Rest assured that we will log this request and it’ll be passed along with the team. The development team is monitoring this community and listening to your feedback. 

 

Feel free to let us know of any other feature requests you may have, we’d be glad to send them up for you.

All the best!

Badge +1

@Luigi408 What version of Firmware were you running and what did you change to resolve your problem?
I am having the same issue adding my Surround speakers. I hope you can help! Thanks! :)

I struggled with this too. Oddly I got my surrounds to work with a Beam that was WiFi disabled, but no luck with the Arc. After about 3 hours of endless resets, 8 enabled WiFi on the Arc and the surrounds connected.

 

Is there any point in leaving the network cable plugged into the back of the Arc if I have had to leave WiFi enabled?

I struggled with this too. Oddly I got my surrounds to work with a Beam that was WiFi disabled, but no luck with the Arc. After about 3 hours of endless resets, 8 enabled WiFi on the Arc and the surrounds connected.

 

Is there any point in leaving the network cable plugged into the back of the Arc if I have had to leave WiFi enabled?

YES.  Disabling the WiFi was a user error that prevents the surrounds connecting because the Arc's wireless radio has been disabled. Whether it is enabled or disabled the Arc itself will use the wired connection. 

Thank you!

Reply