sonos surround sound not playing with samsung apps (HBO, Netflix, Amazon, etc.)

  • 30 August 2017
  • 14 replies
  • 1712 views

I currently own a Samsung UN75MU8000F and have my Playbar, Connect:Amp, and two Play:1s set up in my family room. The Playbar + Play:1's are set up as a "surround sound" set up on sonos system. When playing normal TV, my surround sound works perfectly (aka all three speakers play sound). However, the moment I turn on one of my TV Apps from the smart TV's menu (i.e., Netflix, HBO, Amazon), no sound whatsoever comes out of any of my sonos speakers. At the moment the only way I can watch those apps with sound is to switch to using my actual "tv speakers" rather than the Audio Out / Optical option (i.e., the output that plays my sonos speakers).

Any idea what would cause this issue specifically when switching to using my TV apps / how to fix is? Worth noting that before I installed the Play:1's and set up "surround sound" I had no issues with any of this...my plabar worked just fine no matter if I was watching regular TV or using HBO / Netflix / Amazon, etc.

Any help would be great. Thanks!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

14 replies

Is this a recent occurrence, i.e. starting with the release of 7.4 software/firmware update? If so, you probably want to post a diagnostic here:

https://en.community.sonos.com/troubleshooting-228999/no-sound-on-certain-channels-after-system-update-today-6789926/index20.html#post16141046

however, if that's not the case, I'm wondering if there's a possibility that each of these "apps" has its own audio settings. It sounds (no pun intended, honestly) to me as if they're all sending something other than Dolby Digital out to the Playbar. While you should check your TV's audio settings to make sure it's locked to DD, you might want to see if there are individual audio settings for each of those apps, and if so, lock them down as well.
Exact same issue here. When I hit pause/play on Netflix, the show resumes without sound until I hit volume up or down on the TV remote. Changing the volume on the app has no effect.
You may want to post your issue in this thread, instead:

https://en.community.sonos.com/troubleshooting-228999/no-sound-on-certain-channels-after-system-update-today-6789926
I am having the exact same problem. Sonos sound works when watching everything but HBO series from the Amazon app. It worked fine until I paused it last night and then no sound. I had to revert to the TV speakers to hear the show. I switched to other shows, not HBO, and the sound worked.
Please read the post before yours.
I did read them but still don't understand what the solution is.
Userlevel 7
Badge +21
I did read them but still don't understand what the solution is.

Post your issue in the linked thread together with a diagnostic number.

https://en.community.sonos.com/troubleshooting-228999/no-sound-on-certain-channels-after-system-update-today-6789926
I will not have a diagnostic number till later but will post there.
The thing is i don't know if I have had an app update to the TV
Userlevel 7
Badge +21
I will not have a diagnostic number till later but will post there.

Please post in the thread linked above
Here is the diagnosis code 7863242
When watching TV my back play 5 speakers are cutting out
Bob P, posting in this thread won't get you the beta that might fix your issue. Posting in the thread that Stuart_W linked above will.
Badge +1
When watching TV my back play 5 speakers are cutting out

Hi Bob, we noticed that you posted in the other thread and someone will be able to review the diagnostic there. For now, we'll close the topic here.