Question

Sonos S2 App stopped recognizing my eARC connection from LG OLED --> Sonos Arc after 12.01 update


I updated this week to the 12.01 S2 patch and things went to hell.  TV sound only works  sometimes.  Neither LG remote nor AppleTV remote can control the TV volume anymore - previously both worked fine.  

Sonos S2 app tells me it can’t find the ARC connection between Arc and TV, but it’s there and I can hear sound, and yet app keeps telling me to connect it and enable ARC output of TV lol.  Music is totally normal.  Everything was fine until I updated the latest version of the software yesterday. 

Further Sonos’ instructions to setting up LG remote and AppleTV remotes are both outdated and reflect neither (1) 2020 CX line of LG OLED nor (2) S2 App workflow.

 


13 replies

I think I might have the same issue, was working it's about 15 days old didn't sure it thru the tv for awhile cause I was studying and then today being the 27th of June I noticed it wasn't working through the tv and that the arc seems to have something to do with it. If you find a fix let me know.

*Edit* after remembering it came with an optical adaptor and connecting it.. it's seemed to work.

Why did you use an optical adapter?  If using eARC between TV and Sonos Arc (Arc vs ARC is so confusing and annoying) you should be using an HDMI cable - this is my setup and situation I have, where it is definitely plugged in (bc I can physically observe it AND I’m getting sound via the Arc soundbar lol), but S2 app doesn’t see it / tells me it isn’t.  

I think I might have the same issue, was working it's about 15 days old didn't sure it thru the tv for awhile cause I was studying and then today being the 27th of June I noticed it wasn't working through the tv and that the arc seems to have something to do with it. If you find a fix let me know.

*Edit* after remembering it came with an optical adaptor and connecting it.. it's seemed to work.

You should never connect your ARC via Optical when you have the possibility to connect it via HDMI. The whole ARC doesn't make a lot of sense without Atmos / DD+ or TrueHD. 

I think I might have the same issue, was working it's about 15 days old didn't sure it thru the tv for awhile cause I was studying and then today being the 27th of June I noticed it wasn't working through the tv and that the arc seems to have something to do with it. If you find a fix let me know.

*Edit* after remembering it came with an optical adaptor and connecting it.. it's seemed to work.

You should never connect your ARC via Optical when you have the possibility to connect it via HDMI. The whole ARC doesn't make a lot of sense without Atmos / DD+ or TrueHD. 

I am clearly having issues with the ARC, personally I would rather it just work of course i would wont the best sound but using the optical adaptor thru the htmi seems like my only option… so yea it seems to make sense. If you have a fix @SpiDey1500 I would love to hear it otherwise your just adding 2 cents for nothing. I was tired as well @rparkernyc and must of not read that you still had sound sorry for jumping on your tread. 

Userlevel 5
Badge +15

Hi @rparkernyc, @SpiDey1500  and @keith_3200, Thanks for reaching out and welcome to the community. Thanks for bringing this up and we understand where you're coming from. Sorry for the delayed response. Regarding your concerns about the Sonos Arc that doesn’t detect the HDMI EArc status after the update on the Sonos App. I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue.

Let us know how you get on with the advice above.

We're here to answer any further questions you have.
 

Hi, similar issue here. Just bought Sonos Arc, followed intructions in S2 app but altough it’s properly plugged to HDMI ARC port in my LG oled tv, app still shows an error that the connection has failed. Tried it like 10 times, restarted both tv and app, made a brand new setup using iPad or iPhone, but still the same bad result:(

Can anyone help? Otherwise I’m must return it..

thanks.

Userlevel 5
Badge +15

Hi @hydronaut, Thank you for reaching out and welcome to the community. Thanks for bringing this up and we understand where you're coming from. About the same concern with your Sonos Arc, I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. So we can check the status fo the Sonos Arc connected to the TV.

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

Hi @hydronaut, Thank you for reaching out and welcome to the community. Thanks for bringing this up and we understand where you're coming from. About the same concern with your Sonos Arc, I’ll ask you to submit a diagnostic report for us to investigate further what could be causing this issue. You may reply to the thread with the confirmation number to assist you with this issue. So we can check the status fo the Sonos Arc connected to the TV.

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

Helo Simon,

 

the diagnostic report sent - nr. 2038507686


Thanks for your help.

Userlevel 5
Badge +15

Hi @hydronaut, thanks for the update. I appreciate you taking the time to submit the diagnostic report. Upon checking the diagnostic report, It only shows a controller diagnostic. which means I’m not able to see the status of the whole Sonos system. Kindly make sure that you’re connected to the correct Wifi name on your mobile phone controller and re-run the diagnostic report. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

Hi @hydronaut, thanks for the update. I appreciate you taking the time to submit the diagnostic report. Upon checking the diagnostic report, It only shows a controller diagnostic. which means I’m not able to see the status of the whole Sonos system. Kindly make sure that you’re connected to the correct Wifi name on your mobile phone controller and re-run the diagnostic report. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

 

Hi, new report sent - 1662041824

Thanks.

Userlevel 5
Badge +15

hi @hydronaut, thanks for the update. I appreciate you taking the time to submit the diagnostic report. Upon checking on the diagnostic information. It shows that the Arc status is disabled. Kindly check the CEC settings on the TV and enable it. Also, try to unplug the HDMi Arc cable from the Sonos Arc and from the TV for 1-2 minutes and replug it back in. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

hi @hydronaut, thanks for the update. I appreciate you taking the time to submit the diagnostic report. Upon checking on the diagnostic information. It shows that the Arc status is disabled. Kindly check the CEC settings on the TV and enable it. Also, try to unplug the HDMi Arc cable from the Sonos Arc and from the TV for 1-2 minutes and replug it back in. 

Let us know how you get on with the advice above.

We're here to answer any further questions you have.

 

Mystery solved:)

 

Thank you!

Userlevel 5
Badge +15

Hi @hydronaut, thanks for the update. I’m glad it worked for you about enabling the CEC on your TV and unplugging and replugging the HDMI Arc cable. 

If there is anything else I can do for you, please, don’t hesitate to let me know.

The Sonos community is always here to help.

Reply