Answered

Sonos Arc Samsung Frame TV eARC not working



Show first post

616 replies

Userlevel 1
Badge

Common problems (sounds dropping every 2 seconds, or no sound at all in built in Netflix app) with Sonos Arc and pair of Sonos One SLs as surrounds and the Frame 55 2020…

I emailed Sonos’ CEO a week ago stating that I know about the patch discussed in this thread, Emily from Support replied to my email (she was absolutely helpful and understanding), we exchanged a couple of emails where she asked me to submit diagnostics etc. and finally she sent me the patch today.

So far so good! Fingers crossed the problem is solved.

I think you’ll be fine. Believe they’ve resolved the issue with this patch. 

Has anyone tried the new firmware update from Samsung that was released on Feb 24?  The new firmware is 1462.1

 

I just noticed it in the Samsung website.  I have the 2020 Frame 55 inch tv.  I will also give it a try tonight.

Has anyone tried the new firmware update from Samsung that was released on Feb 24?  The new firmware is 1462.1

 

I just noticed it in the Samsung website.  I have the 2020 Frame 55 inch tv.  I will also give it a try tonight.

FYI This is a USB only firmware update.

Userlevel 1
Badge +1

Has anyone tried the new firmware update from Samsung that was released on Feb 24?  The new firmware is 1462.1

 

I just noticed it in the Samsung website.  I have the 2020 Frame 55 inch tv.  I will also give it a try tonight.

This is only released in the US so far. Not in EMEA as far as I can see. So not sure if this has anything to do with “the update”.

Has anyone tried the new firmware update from Samsung that was released on Feb 24?  The new firmware is 1462.1

 

I just noticed it in the Samsung website.  I have the 2020 Frame 55 inch tv.  I will also give it a try tonight.

This is only released in the US so far. Not in EMEA as far as I can see. So not sure if this has anything to do with “the update”.

I Live in Canada and applied the new update from Samsung via Usb then started watching Wandavision. Sound still cuts out. I have been trying to reach Sonos to get this new patch everyone has been talking about but I have not been able to reach them.

I will follow up once I get the patch from Sonos and will advise if I am getting atmos.

Userlevel 1
Badge +1

1462.1 is still only minor bug fixes as far as im aware. On a avs forum someone posted that he was in touch with a Samsung Engineer who said there is a bigger release in March which fixes most issues.

Has anyone tried the new firmware update from Samsung that was released on Feb 24?  The new firmware is 1462.1

 

I just noticed it in the Samsung website.  I have the 2020 Frame 55 inch tv.  I will also give it a try tonight.

This is only released in the US so far. Not in EMEA as far as I can see. So not sure if this has anything to do with “the update”.

I Live in Canada and applied the new update from Samsung via Usb then started watching Wandavision. Sound still cuts out. I have been trying to reach Sonos to get this new patch everyone has been talking about but I have not been able to reach them.

Same issue came back even after the Samsung firmware update.  SMH

So I just set up the Sonos Arc soundbar that supports eARC. It works with my 2020 65" Frame TV until I change the eARC setting on the Frame TV to Auto. The sound mutes and I can't get it to play until I turn eARC off. Anyone else have this issue? I’ve messed around with this for a few hours to no avail. 

In my case what it worked was following solution, as elsewhere mentioned: Use only one HDMI cable. My problem started when I connected another HDMI cable to the Oneconnect box (in my case for the Wii). But for me the issue is clear: Samsung must fix this problem with an update in order to be able to use more than one input.

 
Userlevel 3
Badge

OK, can someone please give me some advice on how to actually get support to apply the patch?

 

I just went through the chat system since phone isn’t available on weekends, they got me to submit diagnostics, then started asking me about rebooting it, changing HDMI cables, updating the Samsung firmware (ALREADY DONE), “does it work now?” without changing anything… in the end my browser refreshed and the chat system didn’t pick up where it was, so I lost the chat window with no way back.

 

It’s astonishing how bad the Sonos support is (like the guy coming into this thread saying “who wants to try out this version?” then disappearing) for such an expensive product.  This hasn’t worked for me since day 1.  I know they’re blaming Samsung, but THEY HAVE A PATCH THAT FIXES IT.  Why won’t they let us apply it?

OK, can someone please give me some advice on how to actually get support to apply the patch?

 

This is what I did. I emailed ceo@sonos.com stating that I have the Sonos Arc and a 2020 Samsung Frame TV with the sound dropping every couple of seconds. I also stated that I know about a patch that solves the problem and included a link to this thread.

Couple of days later sonos support replied to my email. We exchanged 2-3 emails until they finally sent me the patch.

So far so good.

Sonos needs to make this patch generally available. 

I’ve recently returned a Samsung Q95T because of this exact issue.  I loved the image but could literally not put up with having to restart one of the devices to get sound back every time I swapped a source or used an app. 

I’m holding off for the 2021 models now and would like this in advance of getting one when they are out in fear of the same thing happening! 

Userlevel 1
Badge +1

Version 1497.0 is out now in EMEA. I’ll get it installed and will give feedback later on.
Anyone else tried this update ?

Version 1497.0 is out now in EMEA. I’ll get it installed and will give feedback later on.
Anyone else tried this update ?

The critical question is if anyone with the patch tried the update. I have the patch, the Arc works like a charm...I’m not willing to update and risk losing the patch’s solution. 

Userlevel 1
Badge +1

EDIT: I tested the firmware for about 5 minutes and everything seemed fine, with eARC NOT cutting the sound. I will continue testing further tonight around 7pm CET.

Userlevel 2

Just spoke to Sonos support

Confirmed known issue, said they worked with Samsung.

Sonos patch being rolled out tomorrow publicly.

Also said I should update my Samsung Firmware at the same time.

Will do that now, via USB (I'm in the UK) and then check for update on my Sonos tomorrow.

Fingers crossed!

Userlevel 1
Badge +1

Version 1497.0 is out now in EMEA. I’ll get it installed and will give feedback later on.
Anyone else tried this update ?

The critical question is if anyone with the patch tried the update. I have the patch, the Arc works like a charm...I’m not willing to update and risk losing the patch’s solution. 

I don’t have the patch installed. I wanted to wait for the Samsung Fix and used the HDMI-to-Optical cable meanwhile. I always felt that the Sonos patch would be a compromise to some other things.

Userlevel 1
Badge +1

My further testing was short :( As soon as I started the TV, the cutting sound was back :(

I guess the reason why it was fine before, was because I switched the cable back into the eARC channel. The similar way that some people had to restart the Sonos for it to work. 

I just got off the phone with support and we appeared to resolve the issue that might be helpful. When running the diagnosis there was a lot of wifi interference with my new Netgear Orbi router because the channel was set to “AUTO”. You need to log into your router and change the router channel to either 1,6 or 11. That appears to have solved it...for now. 

Userlevel 3
Badge

My further testing was short :( As soon as I started the TV, the cutting sound was back :(

I guess the reason why it was fine before, was because I switched the cable back into the eARC channel. The similar way that some people had to restart the Sonos for it to work. 

 

Hmmm that is not good!  I just got this from Sonos support FWIW:

 

On the other hand, I am glad to tell you that tomorrow we'll launch a firmware update that will apply the patch to Samsung TVs, so please make sure to run the update tomorrow and let me know your experience.
 

Userlevel 1
Badge +1

Alright so I've updated to the newest Sonos version (it now says Version 13.0 in the app under System → About my system). I’ve updated my “The Frame” Samsung TV to 1497.0 (in EMEA). I’ve done testing all evening. Turned off the TV several times now.
This version seems to be working WITHOUT any cutting sound now.

The only issue I have is that Netflix doesn't understand that I want use “Atmos” and not 5.1 watching it on my AppleTV4K. AppleTV+ works fine with Atmos, so it can output Atmos without any cutting sound.

Anyone else seeing this as well ? I wonder if this is part of some feedback compromise, Samsung and Sonos made in joint ?

Sonos app version 13.0 downloaded yesterday.

Tv updated to 1497.0

No sound problems. 

What I really like about the new app is that you can easily see the sound output of your system. Previously you could only see Dolby atmos. 

(I know you could also see the same info in system/about my system, but it's much easier - "cleaner" now)

 

Userlevel 1
Badge +1

Current problem I am having, is that on Dolby Atmos, the sounds cut like once every 10 minutes for a few seconds. Seems like this still haven't been fully fixed yet.

Current problem I am having, is that on Dolby Atmos, the sounds cut like once every 10 minutes for a few seconds. Seems like this still haven't been fully fixed yet.


Same issue.  Updated Sonos app and TV last night.  Watched Greenland, sound cuts out every 10-15 mins for a couple of seconds.  Don’t think this was the fix we were all looking for.

Updated Sonos app last night, same issue.  Sound cuts out every 10-15 mins for a couple of seconds.

Reply