Answered

Sonos Arc not working in eARC with LGCX Faulty??


Badge

Hi guys I have an issue and am wondering if anyone could please help.

I just purchased the Sonos Arc and I cannot get eARC to work.

ARC works fine but when I go to – All settings – Sounds – Additional settings and scroll down to eARC and activate it,
My screen Text (volume – settings etc) and the sound and image flickers terribly.

I've also tried changing Digital Sound Out to PCM – Auto – Pass Through.

I'm lost and cant get it to work..
Is my tv Faulty or is there a setting I'm missing?

Thank you in Advance

icon

Best answer by Ken_Griffiths 14 July 2022, 00:02

View original

14 replies

Userlevel 7

Try this:

Make sure the TV has the latest software update installed. Disconnect all of your devices from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug them back in but keep everything disconnected. Make sure Simplink is enabled on the TV. Run TV Setup in the Sonos app and follow the instructions. When the app instructs you, connect the Arc to the TV's HDMI eARC port using the Sonos-supplied HDMI cable. When the Arc has been successfully connected, connect any other device to the TV.

Badge

Try this:

Make sure the TV has the latest software update installed. Disconnect all of your devices from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug them back in but keep everything disconnected. Make sure Simplink is enabled on the TV. Run TV Setup in the Sonos app and follow the instructions. When the app instructs you, connect the Arc to the TV's HDMI eARC port using the Sonos-supplied HDMI cable. When the Arc has been successfully connected, connect any other device to the TV.

Ok thanks but how do i run the set up again if its already been run? Do i have to delete the previous set up or something? Cheers

Userlevel 7

Try this:

Make sure the TV has the latest software update installed. Disconnect all of your devices from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug them back in but keep everything disconnected. Make sure Simplink is enabled on the TV. Run TV Setup in the Sonos app and follow the instructions. When the app instructs you, connect the Arc to the TV's HDMI eARC port using the Sonos-supplied HDMI cable. When the Arc has been successfully connected, connect any other device to the TV.

Ok thanks but how do i run the set up again if its already been run? Do i have to delete the previous set up or something? Cheers

Just go under the Arc’s settings in the Sonos app and run “TV Setup”.

Badge

Try this:

Make sure the TV has the latest software update installed. Disconnect all of your devices from the TV including the Arc. Unplug the TV and Arc from power for a couple of minutes. Plug them back in but keep everything disconnected. Make sure Simplink is enabled on the TV. Run TV Setup in the Sonos app and follow the instructions. When the app instructs you, connect the Arc to the TV's HDMI eARC port using the Sonos-supplied HDMI cable. When the Arc has been successfully connected, connect any other device to the TV.

Ok thanks but how do i run the set up again if its already been run? Do i have to delete the previous set up or something? Cheers

Just go under the Arc’s settings in the Sonos app and run “TV Setup”.

Ok thank you!

Badge

I power cycled everything disconnected the leads et and it was stable for a good few hours. I turned the TV off (for the 10th time) came back to watch some netflix and the issue is back again.. Im now wondering if my sound bart is faulty..

Userlevel 7
Badge +18

Hi @riffbear 

Thanks for your post!

Do you have any other devices connected to your TV? If so, please try turning off any CEC-related functions in their settings. These are usually related to power.

Given that the image is affected too, you may also want to check your HDMI cables and their connections.

I hope this helps.

Badge

Hi @riffbear 

Thanks for your post!

Do you have any other devices connected to your TV? If so, please try turning off any CEC-related functions in their settings. These are usually related to power.

Given that the image is affected too, you may also want to check your HDMI cables and their connections.

I hope this helps.

Hi Corry and thank you.

How would I turn off CEC from a PS5 and a Xbox series X?

I didnt see those options in the consoles. However i did disconnect every console and still had the same issue.

 

More so, i ended up returning the Arc for an LG dolby atmos 9.1 surround and faced the exact same issues. LG are now organising a technician to come and check the TV. I tried a few 2.1 cables to no avail so it is looking like my eArc is faulty. But ive also come across many others who have had or are having similar issues with LG tv’s and Sonos Arc’s.

 

I did prefer the sonos arc quality and sound over the LGQ950S and am now looking at getting it again, just hoping LG will fix the issue I have with my eArc being extremely unstable.

Userlevel 7
Badge +18

Hi @riffbear 

How would I turn off CEC from a PS5 and a Xbox series X?

I didn’t see those options in the consoles. However i did disconnect every console and still had the same issue.

I don’t know, but if you had the same issues with them disconnected, then it’s irrelevant.

Hopefully, LG will find a solution, though it sounds like it will be a replacement of the TV. Hope it goes well for you.

But ive also come across many others who have had or are having similar issues with LG tv’s and Sonos Arc’s.

Have you? We haven’t - especially concerning the image being affected too. With millions of Arcs and millions of LG TVs out there, if there was a compatibility issue we’d be hearing all about it. I think the majority of these were probably resolved by changing settings, or software updates. We are not currently tracking any issues with LG TVs and Sonos working together.

I did prefer the sonos arc quality and sound over the LGQ950S and am now looking at getting it again, just hoping LG will fix the issue I have with my eArc being extremely unstable.

Good to hear! (pun intended 😄)

I’ve not seen any similar issues with LG TV’s reported in the community here either, but if the issue persists with the other TV devices (PS5 etc.) all unplugged, then it sounds like a fault with the TV in this instance. Admittedly, I thought this was going to turn out to be CEC issue too, with CEC enabled on the connected devices, but I guess there’s no getting around a fault with the TV itself.

Hope you get it fixed soon @riffbear.👍

Badge

I’ve not seen any similar issues with LG TV’s reported in the community here either, but if the issue persists with the other TV devices (PS5 etc.) all unplugged, then it sounds like a fault with the TV in this instance. Admittedly, I thought this was going to turn out to be CEC issue too, with CEC enabled on the connected devices, but I guess there’s no getting around a fault with the TV itself.

Hope you get it fixed soon @riffbear.👍

Thanks mate im hoping it gets sorted too! 

Sorry i should have been clearer with others experiencing the same issues. LGCX’s are known for having faulty HDMi boards since launching the CX Lots of users on reddit having flicker issues. (old threads now)

 

Badge

Got another Sonus ARC package today. Im stoked.. Just waiting on LG now.

 

I had a salesperson ask me if i had tried to hard reset the TV. Only information i can find is resetting the settings.

 

I wonder if thats what he meant?

Got another Sonus ARC package today. Im stoked.. Just waiting on LG now.

 

I had a salesperson ask me if i had tried to hard reset the TV. Only information i can find is resetting the settings.

 

I wonder if thats what he meant?

On LG TV’s a ‘factory reset’ to initial settings is usually available from the bottom of the ‘Settings/General’ menu. It will wipe everything. Normally an A/V reset is often the easier option, and likely accessible by pressing the mute button 3 times on the Magic Remote.

Badge

I did a factory reset and it worked but soon as i turned the TV off and back on the flickering came back and sound cut off.

I did a factory reset and it worked but soon as i turned the TV off and back on the flickering came back and sound cut off.

I guess it’s over to the LG Engineer to fix this one for you. Let us know how it goes after (s)he has been out and worked her/his magic.🪄

Reply