Answered

playbar works but surround play 3 speakers don't

  • 29 September 2013
  • 223 replies
  • 13130 views

my sonos play bar and surround sound play 3's work perfectly when i play music or apple tv but when on tv nothing comes out of surround sound speakers. all my components are connected into the tv and then the playbar has optical out. so it clearly works as music and apple tv work but normal tv channels only play through the bar. please help
icon

Best answer by Ryan S 23 December 2013, 20:53

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

223 replies

Userlevel 7
Badge +20
I have the same problems. I have the playbar and 2 play 3s. Not words coming from the play 3s only play bar...
Diagnostics number 7013019
Thanks


Hi priyesh30,

Your PLAYBAR is reporting that it's receiving a 5.1 signal so the surround audio should be working. Some media has fairly quiet rear sounds though. Please try playing a few different things and see if you can head the rear speaker audio. It may also help to increase the surround volume in the settings menu under room settings for your PLAYBAR.
Same issue. Mine worked at first for weeks and then just stopped. Only in tv mode, playing music and ists fine. Diagnosis is 7023119.
Diagnostic confirmation # is 7052820.

Playbar is connected to the TV (optic cable) and works along with the sub when i watch TV, but my two Play 1s will not work with the TV. They do, however, work with TuneIn radio and music.
Userlevel 7
Badge +20
Hi fabailey and zwinkler142,

Your PLAYBARs are showing that they are receiving stereo signals from the optical connection. Please check your TV's settings to ensure that they are set to send surround audio out the optical port. It may help to head over to [url=https://en.community.sonos.com/home-theater-228993/home-theater-and-television-recommendation-megathread-6735001this discussion[/url] for advice on setting up your TVs,
I'm having the same issue.

My diagnostic test report number is 7163027
Userlevel 7
Badge +20
I'm having the same issue.

My diagnostic test report number is 7163027


Hi custodemusic,

Your diagnostic report shows that the PLAYBAR is only receiving a stereo signal from the optical input. What type of TV do you have? Is your PLAYBAR wired directly into your TV via the optical cable?

Can you try bypassing your TV and wiring the PLAYBAR directly into your cable box?
I have a playbar with 2 play1. I don´t know if sonos really think about the surround config. I have a XBOX One with Dolby 5.1 in the output. In the surround config and i watch TV it´s only the Background sounds what i hear and this sounds are to quiet. Ok Sonos wright it is possible to make the sound louder in the config, but this is not right effect and if that sense is right. When i hear music the sound is optimal and the config from each point is good. So when i hear music i can config what i want. The config for watching tv is totally failed. It must be the same configs how about the music config. So to get the effect i must create 3 boxes and merge this in one group and about the volume i can control the right sound for the room. But now when i will control the volume about IR only the playbar check the volume and not the merged group. this is shit and not optimal. From sonos with this high Quality Products i expect something else.
Best Olli
I am having the same problem with Playbar and two Play 3s plus Sub. Surround sound works with movies & PS4, but Play 3s and Sub don't produce sound for just TV. My diagnostic confirm is 7348083
Update on problem: Strangely the Play 3s occasionally work and the Sub occasionally works with just the TV, then stop working and only the Playbar works. All still work all the time when using PS 4/DVDs.
bopar, that would indicate to me that the Playbar is not always receiving a full surround (Dolby Digital) signal from the TV, but it is when using your PS4 and DVDs. One way to check that is while you're watching something that doesn't have the SUB or surrounds working, pull up the app and look at Settings> About My Sonos System. The listing for the Playbar would show you what kind of signal the Playbar is getting (and interpreting). Might be worth checking the data source (cable box, or whatever?) and checking the audio settings on that device is set to Dolby Digital. But that's an outside shot, since you seem to be suggesting that sometimes it works, and others it doesn't. Note, too, that different shows have varying levels of use of not only Dolby Digital signals, but even surround sound. I've found that the most effective thing to listen for those things on my TV are either movies, or sports (American Football and Baseball tend to be excellent for pushing sound to the rears). Your mileage, of course, may vary.

If it wasn't working sometimes with the PS4 and DVDs, I'd say you had some wifi interference in the 5Ghz range causing problems. But apparently no 🙂
Hi - I've just submitted diagnostic 7797449. New house and new cable provider TWC - now play 3 surrounds don't work. Please help.
Hi bfrea, apologies for the late response. Thanks for submitting the diagnostic. The report is showing the home theater system is only receiving a stereo signal. The rear speakers are dependent on a Dolby Digital 5.1 broadcast to take advantage of the rear channels. Can you test your system with a 5.1 broadcast and see if you can hear audio?
My diagnostic number is 7892781. I am having the same problem. Many thanks
hey everyone - same problem. music works on surround sound on my 3's, TV surround sound, only the Player works. Conducted a diagnosis: 7986028 Need a patch? if so, how do I fix it from there?
Having similar issues.. Playbar and Sub work with TV and everything connected to it, but play 3 speakers only work when streaming music. Any help woukd be greatly appreciated! Your confirmation number is: 8035100
8288329 Diagnostic Submission. Play bar connected to Sony Bravia Smart TV through an optic cable. The sound works on the Play bar but not the x2 Play 3. I have switched on the surrounds settings: re-configured and re-set the application and Sonos devices with no avail. Receding other posts could you please send through the software update. Having spent 40mins on the phone with no answer I have averted to the community forum.
Same problem with my Sonos one rear speaker do not work during TV diagnostic 8322649
Userlevel 7
Badge +19
ingo72: Thanks for the diagnostic report. Are you still having a problem with the rear Sonos Ones cutting out? If so, would you mind submitting another diagnostic report and reply with the confirmation number it gives at the end. I'll be happy to take a closer look at what's going on.
My two play 1’s are supposed to be surround sound with my playbar connected to my tv. But when i turn the tv on i cannot hear the surround sound speakers on the two play 1’s. It only works when i remove the surround option and play my music. My diagnostic number is 1817434449. Please assist.
Userlevel 7
Badge +20
My two play 1’s are supposed to be surround sound with my playbar connected to my tv. But when i turn the tv on i cannot hear the surround sound speakers on the two play 1’s. It only works when i remove the surround option and play my music. My diagnostic number is 1817434449. Please assist.

Hi Koosgroup,

Thanks for sending in the diagnostic report. I can see that your PLAYBAR is receiving a 5.1 signal from your TV. The communication between your PLAYBAR and rear speakers looks good, too. Can you try a few different stations to make sure the program you're watching has surround audio?
Userlevel 5
Badge +12
It seems to me that implementing full channel stereo for TV stereo audio as well would eliminate tons of comments like this.
Thank you for the help! It seems to work now all of a sudden