Answered

No audio from my Beam when watching TV thru our cablebox

  • 16 August 2020
  • 6 replies
  • 88 views

Hello,

This is my first question to the community.  Hoping to get some answers and that it’s a simple solve.

I recently purchased a Beam and connected it to my new Samsung TV.  Took me a few tries but realized that connecting the Bean to the HDMI (ARC) port was the way to go.  The Beam worked great for streaming services (Movies & Audio) and I was extremely pleased with the quality of sound.

The problem arose when I connected my Optimum Cablebox to the TV (using HDMI) and there was no audio coming from the Beam while watching TV through the Cablebox.  Picture and everything else works fine.

I checked audio settings on the cable box - Double checked settings on the TV and still nothing.

My guess is that there is something simple that I’m missing here…

  • Cable is connected to the TV via HDMI.
  • Beam is connected to the HDMI (ARC) port on the TV.

Any thoughts?

 

Thanks!

 

icon

Best answer by Airgetlam 16 August 2020, 22:06

As a guess, this cable box isn’t HDMI CEC compliant, so it’s not sending the appropriate type of audio to the TV, which then passes that to the Sonos, which can’t interpret it. I’d take a Audio settings on the cable box and make sure you’ve got it locked down to Dolby Digital only. 
 

It is always possible that one or both of your HDMI cables are too old to carry the data back and forth properly. The one from Sonos would be fine, but I’d be tempted to try a different cable between the cable box and the TV, if you have spares lying around. But that’s a remote chance, not a guaranty. 

View original

6 replies

As a guess, this cable box isn’t HDMI CEC compliant, so it’s not sending the appropriate type of audio to the TV, which then passes that to the Sonos, which can’t interpret it. I’d take a Audio settings on the cable box and make sure you’ve got it locked down to Dolby Digital only. 
 

It is always possible that one or both of your HDMI cables are too old to carry the data back and forth properly. The one from Sonos would be fine, but I’d be tempted to try a different cable between the cable box and the TV, if you have spares lying around. But that’s a remote chance, not a guaranty. 

Userlevel 6
Badge +15

I’d agree with Bruce that it’s probably a setting on your cable box that’s causing this - Dolby Digital (not Dolby Digital +) is the way to go. If this doesn’t help check your TV for any settings concerning audio.

Not completely sure if it’s HDMI-CEC compliance that’s causing this, because CEC to me is more about controlling devices, not sound. I could be wrong though.

HDMI CEC Hub (TV) would be responsible for getting the device type and allowed codecs from the client (Sonos), and then passing that back to the source (cable box), which, if it were compliant, would recognize the request and modify what it is sending back to the hub (TV), to pass on back to the client device (Sonos). 

Thanks for the responses!

I’ve checked the setting on the Cable Box and it is set to “Dolby Digital”.

My guess is the cable box is not compatible.  I’m going to try Optimum Support as well.

I’ll keep you posted!

:sunglasses:

Userlevel 7

Hi @MrCooz 

Make sure the setting on the cable box isn’t Dolby Digital Plus sometimes denoted as Dolby Digital +. Folks often confuse Dolby Digital + as being the same as Dolby Digital. The Beam cannot interpret Dolby Digital +.

Cheers!

Hi Folks,

After many tries with adjusting the settings on the TV and the cable-box with no luck - I finally just connected the cable-box to the TV with an HDMI and an optical cable which did the trick.

Thanks to everyone who responded.

 

AC

Reply