Answered

Loud buzz through Playbar when adjusting volume on Samsung TV

  • 29 October 2023
  • 6 replies
  • 52 views

When I adjust the volume on my Samsung TV, I get a loud buzzing through the Playbar for a few seconds, which then prompts the TV's Soundcare pop-up. How do I fix this? 

 

icon

Best answer by Corry P 2 November 2023, 14:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

How are you controlling Volume? Which model TV?

If you are using the TV remote to control Volume, you should set the remote to control Volume on an imaginary A/V receiver, then configure PLAYBAR to accept these IR commands.

Thanks, I found a solution - Digital audio output form was set to Auto, when I switched it to PCM, it solved the issue. 

Userlevel 7
Badge +18

Hi @Dchamann 

Setting your TV’s output to PCM means you will only ever get stereo sound - making your surrounds unused.

Instead - and if you have the option - please set that same setting to Dolby Digital.

It’s also possible that rebooting the TV by unplugging it from power for a minute will fix things.

I hope this helps.

Hi Corry, 

Thanks, yes I realized the issue wasn't fixed after all... My only options for sound are PCM or Auto. 

I'm at a loss now of what I can do to fix this. TV model is QN65Q80TAF. I control the volume with the TV remote, which I've set up through the Sonos app. Also have tried the simple unplugging the at to no avail. 

Userlevel 7
Badge +18

Hi @Dchamann 

To be honest, it simply shouldn’t be happening. I don’t recall hearing of this issue before.

Please check your TV for software updates - if there are any, please install. If not, I recommend you get in touch with our technical support team who will be able to look at the logs to see if anything unusual is happening (my guess is that the TV’s output stream is momentarily out of sync with it’s own frames, making the Playbar interpret the stream incorrectly and play it as noise). You would likely then need to contact Samsung with that information, as the Playbar just plays what it is given - my suspicion is that the TV is at fault.

If you don’t mind the extra effort, I see you have another TV with an Arc - testing the Playbar with that second TV would be a good way to illustrate where the fault lies, though I appreciate that doing this will be awkward at the very least.

Something else worth testing is whether the behaviour changes according to the TV input or TV app being used at the time, but this information is likely only useful to Samsung (and you, for avoidance in the meantime).

I hope this helps.

Thanks I'll try to see if there's a software update for the TV. That would make sense that it's something to do with the signal being sent from the tv, hence the troubleshooting pop up that always appears.

 

The buzz sound has been different before, for a while it was gone, then came back as more of a brief, louder squeal that wouldn't trigger the Device Care pop up, but it's been back to this noise for atleast a year now, perhaps with changes in software versions. (I know, I've procrastinated looking into the problem long enough).