If you're experiencing audio delay issues, read this



Show first post

360 replies

I have the same problem - lipsync is hosed on my LG OLED with audio connected to Play Base via optical audio. But I've had the set up for a while (since just after Christmas) and haven't noticed this problem till just now. AND my setup has been disconnected for about 3-4 weeks (renovations). Could something have happened since say the middle of February? Some auto update of Sonos or LG? My Sonos did update today when I hooked it up again and turned it on for the first time in weeks. Don't know if OLED TV updated. SOMETHING has changed... (and thanks for all this info: I'll watch for solution...)
Userlevel 1
Badge
I just spoke to the LG VIP support representative She indicated that the firmware update to resolve the lip sync issue is scheduled to be released this Friday ( it may take a few weeks to be available to all consumers )- a hopeful development -
Woohoo! Thank you! I will wait with worms on my tongue!
Please keep us posted on this. I am getting audio delay with my PS4 Pro on my full 5.1 Sonos system with my LG OLED B7A. Funny thing is that all other devices are perfect. No audio delay with Apple TV or 4K Blu-ray Player.
Just had my playbase and LG Oled TV installed. Experiencing lip sync delay. It is not consistent. Sometimes it appears synced and others times not especially when I first start watching. It seems to work well when playing Netflix.
Experiencing this issue as well. Just throwing my info in if its helpful. I get lip sync issues with this combo:

- Playbase and 2 PLAY:1s
- Sony XBR55X900E
- Xbox One X

The xbox is connected to the TV via HDMI, the TV to the Playbase via Optical

I have no lip sync issues when using one of these instead of the xbox one:
- Apple TV
- PS4
- Nintendo Switch
This issue is all over the internet. It seems like people give up.

I’m using a playbase, LG C7 oled, and Xbox one S. There’s a delay when the Xbox is set to bitstream surround, but not uncompressed stereo.

The way I mitigated the audio delay was by running my optical directly to the playbase, from the Xbox one s. Not ideal because you give up the TVs switch capability. but it works.

The problems everyone seems to be having originates at the hdmi to tv/ tv optical out to playbar playbase pass through.

The sonos app has an audio delay, but it doesn't seem to have any effect. Super frustrating.
Hey Bigmanibids. You mentioned 5 days ago there would be an update to resolve this unbelievable unacceptable sync problem. Still no update. $700 for a soundbar and it can’t do its main job correct. We are all idiots. I own 17 Sonos products and up until this I’ve had no real complaint. I bought a cheap $99 soundbar to compare and it worked flawlessly. Hope that it comes out soon or the playbar is going on eBay. What a joke.
Userlevel 1
Badge
Hi

LG VIP customer service told me today that the new firmware release due last Friday was pulled back. They did not give me a new ETA
I just spoke with a Sonos rep. The gentleman I spoke to had no idea win an update would be becoming out and alluded to the fact that the update would be to the firmware on the television and I have (LG OLED) not to the Sonos play bar. Can you imagine all the people that will be selling their play bars on various sites if they don’t figure this out. While their at it they could update the playbar for Atmos too. I’m giving it another month and I’m out. Their are plenty of great sounding soundbars out there. What a bummer. Thanks for the update.
Either one of them, whether it be LG or Sonos should/ could step up. The common denominator is Sonos- difference is thier av sync function is not robust.. other sound bar manufacturers offer much more flexibility in regards to this feature.

I have seen on threads this problem with different brands of tvs and sound bars, but the combo most of the people posting here has a Sonos playbar/ playbase, and in turn seems to be one of the most common generally speaking.

It would be nice to have a combo of remedies to mitigate the problem.
Wow. My spelling was/is atrocious.
i have a particular problem with Amazon.
I thought I was going out of my mind until I saw this thread. Just bought a Sony xe93 & a Playbase. It's as if you need the delay slider to go the other way? Mines very close but now I have seen it I'm allways looking. Don't want to put optic from Sat box to playbase as it leaves sound on when tv switched off.
TV, Sat box & Sonos all set to 0. I'm not sure it's a Tv issue as there appears to be differing makes/models. Think Sonos need to work on this.
Wow. I was about to drop 2500 dollars in SONOS for whole home setup with vinyl integration and connection to LG C7. Going to stick to TV. May have to wait out or find another solution for home theater. Little disappointed in SONOS delay in newer codec integration and no ATMOS. If a wired system is necessary so be it.
Userlevel 5
Badge +2
Did this LG problem start about 4 months ago? Which followed a Sonos update.
Maybe coincidental or maybe unintended consequences...

At this time the severe problem of sound drop outs disappeared (my Samsung, and many others, TV). Sonos blamed Samsung but there was NO update to my Samsung gear or Sky box. Therefore Sonos fixed the problem.
Experiencing this issue as well. Just throwing my info in if its helpful. I get lip sync issues with this combo:

- Playbase and 2 PLAY:1s
- Sony XBR55X900E
- Xbox One X

The xbox is connected to the TV via HDMI, the TV to the Playbase via Optical

I have no lip sync issues when using one of these instead of the xbox one:
- Apple TV
- PS4
- Nintendo Switch


Just following up that I contacted Sony about this. They said it will be passed on to the relevant tech team. I'd encourage anyone else with a SONY or LG TV experiencing this issue to contact their TV manufacturer to help it move up in priority.
I'm experiencing this issue as well.
- Playbar and 2 PLAY:1s
- Sony XBR65X930E, software version PKG6.2858.0082NAA
- Xbox One X

The xbox is connected to the TV via HDMI, the TV to the Playbase via Optical

I have no lip sync issues when using one of these instead of the xbox one:
- Built in Netflix/Hulu/HBO
- Nintendo Switch
- Standard broadcast television

I was chatting with Sony support tonight and they claimed to have already fixed this issue and that I have the latest software. The only place the lag showed up was when trying to watch a Blu-Ray on my One X.

Xbox to Playbar directly showed no lag and Xbox to tv directly without the soundbar showed no lag.
Badge
Just noticed this... Have my audio sync set up - 5 but still delays:@
Badge
I have a 2016 LG OLED and Xbox One X play bar and to play 5 surround sound setup
Userlevel 3
Badge +3
I have the same audio sync issue on my Philips 55POS9002 OLED TV. The issue is intermittent. Sometimes lips are in sync. Usually when my devices are rebooted. My setup is: Sonos Playbase with 2x Play 1 as surround and Apple TV 4K connected to my TV with HDMI.
I have the same slight delay with dolby 5.1 through HDMI bitstream (switching to Linear PCM 'stereo' is fine, but obviously clearly lower quality) using ps3 and a Sony TV. very annoying, seems to be no setting on the TV to deal with it, and the SONOS controller audio delay only works with audio that's ahead of the picture, not behind. i noticed it on a Dolby TrueHD blu ray (The Godfather trilogy), don't know if that has any effect as opposed to standard Dolby 5.1?
Userlevel 3
Badge +3
As a side note to my previous post. The picture in my case is also ahead of the sound.
turning off 'Reality Creation' in the sony TV picture options seemed to help.
I have the same slight delay with dolby 5.1 through HDMI bitstream (switching to Linear PCM 'stereo' is fine, but obviously clearly lower quality) using ps3 and a Sony TV. very annoying, seems to be no setting on the TV to deal with it, and the SONOS controller audio delay only works with audio that's ahead of the picture, not behind. i noticed it on a Dolby TrueHD blu ray (The Godfather trilogy), don't know if that has any effect as opposed to standard Dolby 5.1?

Any chance you tried Game Mode on the input the PS3 is connected to?

Reply