Answered

Playbase Lip-Sync Problem


Userlevel 1
I have a new LG OLED tv and the new Sonos Playbase and I can't get the lip-sync adjusted to be in sync. I have the TV speakers off, but still no go. Driving me crazy! Any ideas?
icon

Best answer by Keith N 3 April 2018, 23:31

Hello everyone. If you are currently working with a Sony XBR or LG Oled TV, be sure to keep an eye on this topic which outlines a known issue with specific TV audio delay on Sonos.

If you do not have either of those types of TV's and are still having lip sync issues, please feel free to reach out to us by posting a small description of your Home Theater layout. Thanks!

View original

45 replies

Userlevel 7
Badge +21
In the advanced settings for the PlayBase in the app/controller there is a lip sync slider where you can delay the audio

There may also be audio sync settings in the TV or video source to investigate
Userlevel 1
Thanks, I have tried both, going form -5 to plus 6 and none seem to get them to sync
Userlevel 7
Badge +25
Is the PLAYBASE ahead of the TV video or behind it? How is the PLAYBASE connected to your TV or theater setup?

What sources are you using here and have you tried multiple sources?
The Sonos adds some audio delay (about 30 ms I think) so if your TV is also adding audio delay to offset its inherent video delay your lipsync problem may be too much audio delay. That's the opposite to the normal lipsync problem where excess video delay allows audio to arriver first and you normally need to add audio delay to cancel it.

If you are starting with too much audio delay adding more will only make matters worse.

Check your TV's audio menu for a delay setting and set it to zero if you can. I don't know if LG allows that (setting the delay to zero) or not. Some TV's from Sony and Panasonic don't allow the user to turn off the audio delay they add but Samsung, Vizio, etc do so usually when the audio delay is off and you have your TV's inherent video delay (50 to 80ms on most) the delay added by Sonos will help cancel it and you may be able to add a little delay back to get it more in sync.

If your LG doesn't allow you to set the delay to zero you can take audio directly to the Sonos bypassing the TV so the audio won't be delayed. You can still use HDMI for video just route the s/pdif audio (more often optical) to your sound system.

Because lip-sync error changes - potentially between every source and every program - the "ideal" solution is to turn all audio delays off so you have your display's video delay available and then use one of the lip-sync correction products from Alchemy2, Felston, Primare, etc. They are all remote controlled digital audio delays that allow you to add audio delay while watching the lip movement to get it perfect. I use the Felston DD740 but feel sure the others probably work as well.

It's important to turn all other audio delays off. In addition to the TV there might be audio delays available in set top boxes, AV receivers, DVR's, even BluRay players so check to be sure they are all OFF.

That way you start out with your TV's inherent video delay - say 60 ms video delay for example - and the first 60 ms of audio delay cancels it. Additional audio delay will cancel any additional video delay in the arriving signals which is usually the case. If you find perfect lipsync at 120 ms (this example) it means the arriving signal had 60 ms video delay. (60 for TV delay and 60 in the signal)

In cases where you find perfect lip-sync below 60 - for example at 40 ms in this example - it would mean you had 20 ms audio delay in the arriving signal. Arriving audio delay is not common but does happen.
If an Android TV box is part of your setup, sync issues can be rectified in Kodi settings if the playbase and TV have been eliminated as causes.
Userlevel 1
Thank you all. I have a LG OLED55C7P. I have Direct TV. Sonos playbase and 2 sonos 1 speakers set up. I also have apple TV. I am hooked up via optical cord. Would HDMI be better overall? When I play The Crown on Netflix, no sync issues. just tv shows. will keep trying to adjust. have turned tv sound off and put on bypass and have adjusted various settings.
Userlevel 1
I've seen the same thing. Ugh. Has anyone contacted LG about this?

I'm seeing a bunch of conflicting things when trying various sources (G1 chromecast, roku ultra, internal apps) and comparing internal speakers vs Playbar via optical out on the LG to things like youtube audio sync videos and netflix tv & movies. I also came across some posts on avsforum about the fact that LG tv's introduce significant delay for DD 5.1 vs no delay for PCM sources on the optical output. I'm about to return this TV as well - deep blacks just aren't worth it for an overall shitty experience.

If anyone has had any luck, I'd love to know of a workaround!
Wow, I was thinking of getting an LG C7 Oled and a playbase but this forum is making me reconsider.
Userlevel 3
Badge
Has their been any update on this? I just bought an OLED65B7V today and the lip sync delay is a very unwelcome surprise. I usually research large purchases like this very carefully, so kicking myself for missing this!
I did hear that there is brand new firmware that is supposed to solve the problem. Can anyone confirm this?
Userlevel 3
Badge
I'm in the UK and the firmware on my TV is 03.60.09 The on-line update tells me no update is available but there seems to be a different version (03.60.15) available on the LG UK website. I'm holding off on updating pending a reply from LG support.

I have been able to mostly eliminate the lip sync issue using the audio settings on the TV. There is an ability to both advance and retard the audio sync in the settings. There is also a bypass option. I need to spend more time tinkering with the adjustments but it seems manageable.
Userlevel 1
Badge
I have an LG OLED65C7P (2017 Model) and a PLAYBAR and have been suffering a while with audio sync issues with normal TV (OTA broadcasts via a Tivo Roamio). My Tivo is connected to the C7 via HDMI and the C7 is connected to the PLAYBAR via optical.

I'm a little hesitant to say the sync issue is fixed just yet but I think it might be .... try these settings on your TV:

1. Download the latest LG firmware for your TV. Mine is now version 04.70.07.
2. Change the AV Sync settings in your TV. AV Sync = on, Bypass = on.
3. Optical Settings: I also have SIMPLINK (HDMI-CEC) set to on and Digital Output set to Auto.
Userlevel 1
Badge
Sorry...forgot to mention my hypothesis behind why the settings above likely work for fixing the sync issue. In my case, the audio always seemed a little behind the video.

Essentially each device needs processing time for the signal it is handling. That includes the LG TV and the Sonos as well. So, when the input device (the Tivo in my case) sends the signal via HDMI to the LG, the LG begins processing the video signal and it delays the audio signal a bit with the regular settings in order to compensate for it's video processing time. With the AV Sync setting on, you're telling the LG that you want to handle the delay a different way than it's default method. With the Bypass setting on, you're telling the LG to send the audio signal via the optical port to the Sonos device without adding any delay compensation for the video processing. Consequently, the PLAYBAR essentially receives the audio at the same time as the LG. Usually video processing takes longer than audio processing so theoretically you should now hear the audio before you see the video...which is opposite of what I was detecting before (see above)....but, it seems the Sonos processing time adds enough delay (likely due to the time it needs to send the signal to the sub and surrounds via WiFi and ensure they're in sync with the PLAYBAR) that it's about the same amount of time the LG needs to process the video signal. Thus it seems the video and audio are now in sync. That's my hypothesis anyway...but we'll see as time usually tells with these things.
I’ve just got my LG B7 and have noticed the same issue with the Dolby Digital delay on external devices. I’ve contacted LG about it because from the troubleshooting I’ve done it seems like the TV is adding the delay.

On my TV the Audio Delay and bypass setting has no perceived effect on improving the issue. The only thing that does resolve it is connecting the optical cable direct from my Xbox One X or Apple TV to the Playbar.

I’ve read comments on YouTube and AV Forums that suggest that LG are aware of the issue and are looking into fixing it with a software update.
Userlevel 1
Badge
iAmCiaran wrote:

I’ve just got my LG B7 and have noticed the same issue with the Dolby Digital delay on external devices. I’ve contacted LG about it because from the troubleshooting I’ve done it seems like the TV is adding the delay.

On my TV the Audio Delay and bypass setting has no perceived effect on improving the issue. The only thing that does resolve it is connecting the optical cable direct from my Xbox One X or Apple TV to the Playbar.

I’ve read comments on YouTube and AV Forums that suggest that LG are aware of the issue and are looking into fixing it with a software update.



Glad to hear that LG is working on the issue! You may want to ensure you have the latest LG software (04.70.07) and the latest PLAYBAR software (8.2.1). For me the Bypass option didn't work until I updated and rebooted (power cycled) on both. Then try these settings:

1. Download the latest LG firmware for your TV. Mine is now version 04.70.07.
2. Change the AV Sync settings in your TV. AV Sync = on, Bypass = on.
3. Optical Settings: I also have SIMPLINK (HDMI-CEC) set to on and Digital Output set to Auto.

In addition, make sure all other delays in any equipment you're using are set to 0 or off.
Thanks for the suggestions, ronj. I ran the 04.70.10 update from LG’s support pages and tried the above steps and still encounter the audio delay. I’ve checked bypass is set to on and power cycled the TV and Playbar.

The only workaround I’ve found is setting my Xbox One X or Apple TV to output in Stereo. There is then no perceivable delay on audio output from the Playbar.

I’ll hold out for an update from LG.
Userlevel 1
Badge
iAmCiaran wrote:

Thanks for the suggestions, ronj. I ran the 04.70.10 update from LG’s support pages and tried the above steps and still encounter the audio delay. I’ve checked bypass is set to on and power cycled the TV and Playbar.

The only workaround I’ve found is setting my Xbox One X or Apple TV to output in Stereo. There is then no perceivable delay on audio output from the Playbar.

I’ll hold out for an update from LG.



Sorry to hear that it didn't work.... I didn't realize they were up to .10 (unless that's not a USA release)....I hope that build doesn't have a regression...excuse me why I run and try to turn off auto-updates on my LG 🙂. And I also hope that LG is able to fix it.... have you tried to call their support line and ask why the bypass option isn't working for you? If it is working and all of your delays are set to 0, then the issue is certainly with the Sonos software.
Yeah I am having this same issue with the Playbase and the LG C7 55" TV. The TV seems to be adding some delay to the optical audio, even with "bypass" set or setting it to -5. In fact, -5 to 0 doesn't seem to do anything at all and moving it above 0 makes the delay worse. I had no issues using the Playbase with my Panasonic 55" GT50 before, so it seems like it's an LG problem. I really hope they fix it because I cannot fix it because I cannot connect the soundbar directly to my AppleTV 4K (no optical output).
Userlevel 1
Badge
masterkaj wrote:

Yeah I am having this same issue with the Playbase and the LG C7 55" TV. The TV seems to be adding some delay to the optical audio, even with "bypass" set or setting it to -5. In fact, -5 to 0 doesn't seem to do anything at all and moving it above 0 makes the delay worse. I had no issues using the Playbase with my Panasonic 55" GT50 before, so it seems like it's an LG problem. I really hope they fix it because I cannot fix it because I cannot connect the soundbar directly to my AppleTV 4K (no optical output).



What LG software version do you have? The bypass option didn’t work for me until I received the 04.70.07 update.
Just an update on my end. I've not received a response from LG email support so I gave them a call today. Advisor spoke to a technical advisor who has heard about the issue before. LG is aware of the issue but they were unable to provide any other information. If it is a software issue there may be a fix in the works but the advisor unable to confirm this is the case.

I've managed to make the delay with the Apple TV 4K less extreme by doing one of the following steps:
- AV reset on my TV (press mute button 5 times, then select AV Reset).
- Enabling AV Sync and Bypass, then power cycling all devices.
- Updated Apple TV to beta software and enabling the new video settings to match framerate and match dynamic range.

The delay is still there but appears to be around 10ms out of sync with the video rather than ~40ms as it was previously. The issue still persists with my Xbox One but I suspect the Gaming calibration settings may be making the audio delay more noticeable as the input lag on the TV's video processing is lower in this mode.

Connecting my Xbox One directly to the Playbar via optical improves things but it's not ideal for my setup.
I've a John Lewis 55JL9100 which is basically a rebranded LG UF770V, connected via optical to a playbar, I get the lip sync issue when watching blu-rays on my xbox one (connected via hdmi to the tv) the video is ahead of the sound. Adjusting the delay to plus or minus on the tv and trying the bypass option didn't help (although I might give it another go with some power cycling).
Pausing or stopping/skipping the blu ray seemed to make a difference but only temporarily, but I noticed another thread on here where someone said they fixed the issue by zeroing the volume level using the remote they had programmed the playbar to work with, but then using the app to raise the volume to a normal level, which sounds implausible but I tried it and it appeared to work, haven't had a chance to test it very much but wanted to mention this just in case it helps someone else.
Ive just bought setup my LG OLED 55C7V with my playbase yesterday. Experiencing lip sync issues too. I’ve got my playbase connected to TV via optical cable and then a Sky Q box plugged into TV. No problems with sync via built in apps on tv such as iPlayer Netflix etc. But have issues from sky q box. Tried updating the software (which I had to do via usb as when trying direct on tv wouldn’t find the latest release) and messed around with audio settings on tv sonos app and sky audio settings. Sometimes it seems ok but then another channel seems way out. Very frustrating. Will keep a close eye on this thread and hope LG sort it soon!

Does anyone know of any links to setup advice with my devices, ie LG OLED C7, Playbase, Sky Q. Also have Apple TV and an Xbox One but might not try to over complicate things until sync issues sorted.
I just got my Sonos playbase and had the same problem. I had not yet updated my LG software for my C7 OLED. I just updated the LG software and the sync problem is resolved. The software version Is 04.70.36
BG2020, Do you have a sky box? Or did you have a sync issue with apps built into the tv?
I have xfinity cable box.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings