Answered

Disabled WiFi on Sonos Arc - surrounds disconnected

  • 13 August 2020
  • 10 replies
  • 1623 views

Hi,

I've just plugged my ethernet cable into the Arc and disabled the WiFi on the Arc. It has now bumped my Sub and 2 One Sl's from the grouping. 

It is having problems reconnecting. 

My question is - is it not possible to run the Arc on Ethernet whilst the rest of the grouping runs on WiFi?

Thanks in advance.

icon

Best answer by sjw 13 August 2020, 17:39

No.  Just re-enable the ‘wifi' option on the controller and allow the sub and rears to bond using the intended method.

Keep the ethernet connected.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 7
Badge +15

How would you expect the sub etc. to bond with the Arc if its WiFi is disabled?

Is there a reason you disabled it?

I disabled the Arc WiFi because I am running an ethernet cable into it. One would assume they would all talk to each other through the router? I could be very mistaken!

I disabled the Arc WiFi because I am running an ethernet cable into it. One would assume they would all talk to each other through the router? I could be very mistaken!

No, the Arc is going to communicate with the sub and surrounds via it’s own private network, not your routers WiFi network.  Perhaps you could wire everything and turn off the WiFi, not sure on that.  Be assured that your Arc will get streaming content and communicate with other Sonos rooms via the wired connection.  Really, the only reason to turn off WiFi is if you don’t want any WiFi radio signals in your home for some reason.  It’s not meant to be a switch to tell it to use the wired connection, that happens automatically.

Userlevel 7
Badge +15

No, they need to bond to the Arc.  Besides that though, have you told the system your WiFi password?

No, they need to bond to the Arc.  Besides that though, have you told the system your WiFi password?

For the avoidance of doubt, do not run the Arc on Ethernet (with radios disabled) and the satellites on the router’s WiFi. The bond will fail due to excess latency.

This is yet another case of the confusing “disable WiFi” terminology in the Sonos controller. It does no such thing; it disables SonosNet. The communication between Sonos units isn’t WiFi.

Userlevel 7
Badge +15

Exactly where I was going ratty.  Was making sure the OP wasn't expecting to either ‘magically' connect the other units  or end up with a mixed mode system.

It would be so simple to rename the option to ‘Disable Sonosnet' or something similar.

Thanks for all of your responses and advice. So in that case is the Arc ethernet port only used when you are running just the arc on its own or your whole system through ethernet? Therefore you can't mix and match it. 

Based on how I've interpretated the advice, I need to disconnect the ethernet cable and enable WiFi again which will allow me to regroup my speakers and sub.

 

Userlevel 7
Badge +15

No.  Just re-enable the ‘wifi' option on the controller and allow the sub and rears to bond using the intended method.

Keep the ethernet connected.

The Arc connects to the router by Ethernet.  But by selecting ‘Disable WiFi’ you are preventing other speakers from connecting wirelessly to the Arc.  Specifically you are preventing the Sub and Surrounds from connecting wirelessly to the Arc, which they need to do.

Please just do what everyone on here has said you should do - they know what they are talking about!

The Arc connects to the router by Ethernet.  But by selecting ‘Disable WiFi’ you are preventing other speakers from connecting wirelessly to the Arc.  Specifically you are preventing the Sub and Surrounds from connecting wirelessly to the Arc, which they need to do.

Please just do what everyone on here has said you should do - they know what they are talking about!

For sure. I have done and it is all back up and running fine. I was just trying to understand how it works and why what I was doing was wrong.

Thanks to everyone for your advice.