Answered

Connect Samsung QLED remote to Sonos


How to connect samsung remote for sonos?
75 Qe75Q7f
icon

Best answer by jjfleurat 8 December 2018, 23:41

I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q9F 65" (2018 model, QE65Q9FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on tv, hdmi 1 Nintendo switch HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Props to the guy who found this and I am sharing for.
View original

14 replies

I have no knowledge of the Samsung TV, but perhaps see if this link helps...

Configure Sonos PLAYBAR/PLAYBASE with Samsung One Remote
Badge
I am having the same problem. Odd that Sonos took down the fix and didn't bother to replace it with a solution.
The link in Ken_Griffiths post works for me. Why do you say Sonos took it down?
Badge
Yes the link worked. I’ve followed the instructions and even gotten the sonos app to recognize the remote but I still get no volume in the Beam through either he hdmi or the optical inputs. Seems to be recognized everywhere (except in the sonos app under settings the audio in for the living room is still blank with no words.
I would infer from that line being blank that the Beam isn’t receiving any information at all...although I’m no expert here. I’d try a couple of things, starting with unplugging the TV from power, ( not just turning it off, you want a full reset of the HDMI handshake, which doesn’t occur unless the TV is powered off physically). Then if it doesn’t come back up, I’d go through the install process again, which might force another handshake event (not sure), and fianally, I’d double check the audio settings for the TV and all devices connected to it to be sure that they are set to a max of Dolby Digital. The HDMI ARC / CEC handshake is supposed to do this, but it doesn’t hurt to try this extra step.

You’re sure you have it connected to the ARC HDMI connection on your TV, right?
Userlevel 7
Badge +21
If the Sonos app is showing nothing for the Audio In, the two things I would check are both on the TV side of the equation...

1. Make sure your Beam is connected to the HDMI-ARC port. There is one specific HDMI port on your TV for ARC connections, and Beam needs to be connected to that port. You might need to move another device if something is already plugged into the ARC port.
2. Make sure AnyNet+ (what Samsung calls their HDMI-CEC implementation) is enabled. In your TV settings, go to General > External Device Manager > AnyNet+ and make sure it's on.
Badge
Mike,
Thanks for the reply.

#1 - yes i am sure. it is clearly marked on the Samsung HDMI port
#2 - yes I have enabled that. When I enable it that is when all sound stops working. I have to turn this Anynet setting off in order to get the TV to play any sound.
Userlevel 7
Badge +21
Ok... turn AnyNet+ back on, play a movie or watch TV (should be without sound, since AnyNet+ should be directing the sound to come through Beam), then in the Sonos app submit a diagnostic. Come back here and post the confirmation number and a Sonos employee will review it to see what might be going on.
Badge
Thank-you for the help.

Diagnostic submitted. Number: 320656010
DGIANNETT0,

Could it be you may have a faulty HDMI cable? Just wondering if you have another ARC compatible HDMI cable you could try ?
Userlevel 2
Badge
I got the Sonos Playbar fully working to be controlled by the One Remote with my Samsung Q9F 65" (2018 model, QE65Q9FNA).
My One Connect box is inside a closed cabinet and the Sonos Playbar receives the IR commands directly from the One Control.

It is working for me at every input, tested on tv, hdmi 1 Nintendo switch HDMI2 (PlayStation 4) and Apps (Netflix, Amazon Prime, etc).

Instructions on Samsung TV:
Go to Settings -> Universal Remote -> New Device
Select Device Type: Home Theatre System
Select Brand: Samsung
Select Home Cinema Configuration: Optical
Start "Power Test" and always hit "No" (unsuccessful) until the 4th power test, there select Yes (home theatre system turned on/off).

After this the Sonos Playbar can understand the IR commands emitted by the One Remote, without the One Connect box needing to be in line-of-sight.

Change remote on Sonos Playbar:
Start the Sonos App
Go to More -> Settings -> Room Settings-> Room with TV/Playbar -> TV -> Remote control setup

Follow on-screen instructions, you will have to learn Volume Up/Down and Mute.

Congrats, you will have now a flawless working Samsung One Remote + Sonos Playbar setup.

At least it works at me perfectly.

None of the other "workarounds" that I found by other users worked for me.

Props to the guy who found this and I am sharing for.
Thanks jjfleurat - worked perfectly!
Just wanted to mention that jjfleurat's post worked for me as well (2017 Samsung Q8 with One remote). Over a year without functional volume controls unless I used a phone/tablet and this fixed it in five minutes. This post comes up as the #1 item on Google when searching for Sonos and Samsung Q series with One remote. Great post.
Thanks jjfleurat - worked perfectly also for me!! 😃

Reply