Beam will not play audio from TV after you shut the TV off

  • 16 August 2021
  • 5 replies
  • 66 views

i have 2 solution if your beam stops every time you turned your tv off an on

1)

YOU NEED TO TURN ON THE TV AFTER SONOS THEN TURN OTHER DEVICES ON

In my case i always turning on the tv after i turned on my tv box (humax). i didn’t change the priority for some time then decided to give the tv priority and problem solved. 

so

turning on order;

1-sonos

2-tv (wait until tv completely booted)

then turn on whatever you connected to your tv through hdmi. you can buy usb on off switch for any usb device that you want to control when to turn on. (google: usb on off switch)

I have a roku and a humax tv box also connected through hdmi to My Panasonic tv. Humax tv box was causing the problem. now my beam is on all the time because it doen’t have a on off switch and takes some time to boot so i turn on my tv first, wait for few seconds to see a blank screen after it shows panasonic logo and then i turn on my tv box and voila, i have my beam works flawlessly. roku does not create an interference.

2)

unplug any non essential USB TV WIFI DONGLES. I didn’t test it enough as the above solution worked and didn’t want to potentially mess up the working setup but it can be beneficial if you remove your tv’s own branded wifi adapter. i didn’t need keep that dongle connected all the time as i was getting my tv smart with roku rather than that panasonic wifi dongle.


5 replies

You’re not supposed to “turn your Beam off” if what you mean is turn it off at the wall. Sonos is, like other network gear, designed to be left powered 24/7. It drops into a lower power state when idle.

Indeed, regularly powering it off and on again is a great way to reduce its life span.

 

the thing is i do not switch off the sonos beam. what i wanted to say (but failed) in the message was all other devices must be turned on after 1) sonos and 2) tv is turned on to avoid sonos establishing a proper communication with tv. you are saying sonosh supposed not to be turned off which i aggree but imagine if you go away for weekend, holiday etc. and you don’t want any electronics on standby. or any other scenarios that made you switched off the sonos (power failure and etc.) and you ended up ifacing this weird problem.

so in summary it’s like this.

turn on your sonos or never turn it off at first place but make sure no other devices connected to your tv is on if sonos is off

in other way, if you have this problem and figure it out, you need to keep in mind that the sonos has the priority to turn on among all devices that connected to your tv (including the tv itself)

examples for situations where the sonos didn’t work in my home.

the sonos turned on (or was on already), tv box turned on, tv turned on = sonos beam didn’t work

the sonos turned on(or was on already), tv turned on, tv box turned on at the same time = sonos again didn’t work (it supposed to work)

the sonos turned on (or was on already), tv turned on (and waited until tv showed a channel name or anything on screen) and then turned on the tv box = sonos worked

I mentioned in my initial post that my sonos is on all the time. my post aims anyone who can’t figure out why their sonos device strangely can’t establish communication with their tvs. or they need to set it up from scracth everytime they turned on their devices. this means me and other people has something in common. culprit is not sonos but other devices that interrupt the sonos’s signal.

you may have a setup like sonos + tv + hdmi amazon firestick/roku/chromecast + hdmi / vga pc stick + hdmi / scart dvd/blu ray player + hdmi / scart / coaxial satellite box and you may experience this problem.

  1. sonos has to be on and other devices is off
  2. tv is second to be turned on and you need to wait until tv booted to show you a chanel name or showing anything following the TV logo splash screen
  3. then turn on the other devices if they causing a problem. in my case it was the tv box but i have a roku device and it doesn’t cause interruption. it may be roku in someone’s case
Userlevel 7

Hi @iddqd 

Sorry, what you posted (with all the colorful lettering) just doesn't make sense. Doesn’t appear that you have your Sonos setup properly.  There’s some weird JuJu going on with your setup. 

Besides I’ve never read a post in the community with the issues you are describing??? :thinking: Then again I can’t begin to read every post. :upside_down:

Hi AJTrek1.

I followed only the official setup guide but nothing else to setup my sonos and above solution worked for me. all i do now is to make sure sonos works all the time, turn the tv on and wait for few seconds and then turn the tv box on and all works fine. if i accidentally or intentionally switch the sonos off then i turn the sonos on and wait patiently until it boots to a ready to use state then tv and then tv box. and all is good. but if i rush turning tv and tv box on then i have my sonos not working. i remember seeing posts similar to my issue and people were telling “i have to factory reset the sonos every time” in there.

i don’t know maybe my tv or tv box is old or interfering.

Hi AJTrek1.

I followed only the official setup guide but nothing else to setup my sonos and above solution worked for me. all i do now is to make sure sonos works all the time, turn the tv on and wait for few seconds and then turn the tv box on and all works fine. if i accidentally or intentionally switch the sonos off then i turn the sonos on and wait patiently until it boots to a ready to use state then tv and then tv box. and all is good. but if i rush turning tv and tv box on then i have my sonos not working. i remember seeing posts similar to my issue and people were telling “i have to factory reset the sonos every time” in there.

i don’t know maybe my tv or tv box is old or interfering.

The age of the TV/TV Box is unlikely related to your issue - the simple fact is for the Sonos TV Autoplay feature to work the Sonos HT device needs to be powered on. Just leave all in standby. As @ratty mentioned in the first post of this thread… You’re not supposed to turn your Beam off.

Reply