Answered

Beam: Keeps switching back to Arc from Bluetooth - how to stop?



Show first post

151 replies

I'm yet another with the same issue: LG CX65 with a Beam+Sub and Sony WH-1000XM4 Bluetooth headphones. I try to listen with headphones at night to avoid the sub waking up everyone within 50 miles, and the sound just switches back to the Beam immediately. Switching off CEC/Simplink is a stupid workaround, made even stupider by the fact that it switches itself back on the instant I do actually want to use the soundbar. 

As it looks like other soundbar makes do not have this issue with LG TVs, and Sonos soundbars with multiple TV brands do; it is surely down to Sonos. To those saying that it is a 'feature' of CEC, do you honestly think that the CEC standard states 'compliant devices must hijack audio output contrary to direct user choice'?

 

Sonos please sort this out.

I am struggling to know if this is a Sonos or a TV problem ( I have an LG too which seems to be very common in this thread). 
 

until 3 days ago I could quite happily hear everything through the Sonos from the TV. I then noticed the tv switching from hdmi arc to internal speakers….. I would then flip it back to hdmi arc only to get no sound. I have had no sound on Hdmi arc now for a few days but unless I unplug the beam the tv auto selects arc and I get no sound. 
 

beam works fine for all normal streaming - question is whether what’s tripping the arc to auto flip is coming from the beam or the tv - and with no way to tell which it is how can you get support in this mixed environment.

 

fwiw I will factory reset my tv and my beam later today and not run any updates on either…see how it goes.. but this is busting my nut

I am struggling to know if this is a Sonos or a TV problem ( I have an LG too which seems to be very common in this thread). 
 

until 3 days ago I could quite happily hear everything through the Sonos from the TV. I then noticed the tv switching from hdmi arc to internal speakers….. I would then flip it back to hdmi arc only to get no sound. I have had no sound on Hdmi arc now for a few days but unless I unplug the beam the tv auto selects arc and I get no sound. 
 

beam works fine for all normal streaming - question is whether what’s tripping the arc to auto flip is coming from the beam or the tv - and with no way to tell which it is how can you get support in this mixed environment.

 

fwiw I will factory reset my tv and my beam later today and not run any updates on either…see how it goes.. but this is busting my nut

My initial thoughts are that the ‘flipping/tripping’ is being caused neither by the Beam, nor the TV, but more likely by another HDMI device connected to the TV that has HDMI-CEC enabled and is attempting to ‘steal’ away the focus from your Beam.

To try to find the ‘culprit’, if you have more than one device connected with HDMI-CEC enabled, is  to disconnect these ‘other’ devices and first ensure the ‘flipping’ stops altogether. Next, add the devices back one at a time and see which one causes the issue. If that’s established, then disable CEC on that one device, or alternatively insert a cec-less adapter into its connection as shown in the link below. All being well, these things should solve your issue.

https://www.lindy.co.uk/cables-adapters-c1/audio-video-c107/hdmi-cec-less-adapter-female-to-male-p7299

Userlevel 2
Badge +2

I have the same issue with my LG E8  but it doesn't bother me as I rarely use Headphones at night now and just turn switch over to night time listening mode and turn on speech enhancement. 

It would be good if I could just switch on the Sennheiser's and not have this issue.

Hello All,

 

as there are more and more users facing same issue, can each of you open a support ticket with Sonos ? This is the only way we can push Sonos to finally fix this annoying bug in their software.

 

Kind regards,

Greg

Hi All,

Same issue here for me - recently purchase a brand new LG G1 65’ with a Sonos ARC + Sub Gen 3. 

Trying to set the G1 to use a pair of wireless headphones using Bluetooth whilst the ARC is connected using eARC.

The ARC keeps forcing the audio out connection back to itself. The Bluetooth connection to the headphones disconnects after about 1-2 seconds when it reverts back to the Sonos ARC as the audio output device.

I understand that this is how HMDI-CEC is meant to work but have tried everything to stop this behaviour, even setting the TV to optical out but the ARC just keeps taking over.

Things I’ve tried:

1. Disable QuickStart+
2. Disable eArc Support
3. Change Audio Output to Optical
4. Disable HDMI-CEC (reverts back to Simplink On after a few seconds)

Basically no way to connect headphones whilst power is on to the ARC and connected to the TV over eARC. Really annoying problem….

I reached out/logged a ticket via Online chat this morning but was also advised that there isnt a solution to this problem and to try contact LG. I have opened a case with LG but I dare say this is a problem with Sonos looking through this thread.

Please fix this :( its not unrealistic for people to want to watch TV with headphones at night…...

I have the same issue with Sonos Beam connected to a Samsung TV model The Frame 2019.  
I can’t use Bluetooth headphones, unless I disable HDMI-CEC. 
Sonos, please fix this issue 🙏

Badge

SAME PROBLEM.

Samsung 2021 Smart TV.  Sonos won’t allow the bluetooth to stay active … it just steals it right back.  The only solution is to turn off the sonos.  Once I disable the sonos HDMI, then the TV reverts back to TV sound and I can once again swap between sound modes without problem.

 

This is a SONOS problem, as I’ve tried multiple configurations between HDMI, Bluetooth, Optical, and TV … and the only time this happens is with Sonos Beam.

 

This needs to be fixed or I’m going to start linking every Sonos and TV review I can find to this thread so people are aware of losing their access to bluetooth if they opt for a Beam.  Sorry for sounding frustrated, but this has taken hours of my life trying to fix it and it looks like it has been a problem for years, based on this thread.

STOP telling people to open tickets with LG, Samsung, Sony. ETC. The common product is Sonos

I tested and can confirm the BOSE Sound Touch 300 works perfectly with my Samsung Q80 75in and Samsung buds. Then I swap back to Sonos ARC and it fails. Same cable, same TV same Buds same port.  

Sonos, you are a premium product. Why does Bose work? 

Same issue here: LG GX TV, Sonos Arc, Airpods Max. When connecting the Airpods Max via bluetooth to the GX TV, I get 2 secs of sound then the HDMI ARC connection takes over. The temporary solution I found was to toggle HDMI eARC off and then on in the TV sound settings.

Same here, Samsung TV, no issue with a bose bar, problem is sonos which keeps reconnecting itself... Really annoying not to see any fix after all this time 

All TV’s work with BOSE’ and not Sonos. That hurts. 

Case closed. You have a clear choice now. 

 

Sonos sells well 2nd hand on ebay. 

Thanks  only thing which makes me think is that Bose as far as I know doesn't have amplifiers and I have a bunch of external speakers. Without this I would have switched long ago

Well first... it's not switching from Bluetooth. The Beam is not a Bluetooth speaker, but I digress.

Chances are your TV or Cable box is still playing and the Beam is set to auto-play. So turn them off when listening to other audio, or check the Beam's room settings and disable auto-play.

 


Sorry you didn’t understand what I wrote.

I know the Beam isn’t a Bluetooth device, I didn’t say it was. I said I’m trying to play my TV audio via Bluetooth to my Bluetooth headphones. I can’t turn the TV off, because I’m using it with my Bluetooth headphones.

Perhaps I should just start again...

My TV is connected to the Beam via Arc. I’m trying to use my Bluetooth headphone with the TV (late at night, so I don’t disturb the household). When I go into the the TV’s menu and chose Bluetooth as the audio output it plays audio via the headphones for 2 seconds before it automatically switches back to the Beam. This is because the Beam is ‘always on’ (unlike other amps I have used).

What I am asking is - is there any other solution other then pulling the power or HDMI cable out of the Beam? (I know one solution is to change to optical, but I want to stick with Arc is possible).

 

I bought a smart plug and use it to shut off my Sonos Arc when I don’t want to use it.

I have a hearing  aid transmitter connected to Optical output on the TV and had the same problem you had.  Could not switch settings on Sound to TV speakers and Optical because it would continually switch back to HDMI/ARC after a couple of seconds.  

Turning off the Sonos Arc soundbar with the smart switch, the LG automatically switches back.   You can navigate back if needed to your Bluetooth option.

 

It’s a ‘feature’ of the HDMI-CEC spec. Connect your Beam via optical, or your headphones, and there won’t be that conflict. 

Optical option you will lose many other features of HDMI Arc including the Dolby Atmos feed (for Sonos Arc)

 

My solution

I bought a smart plug and use it to shut off my Sonos Arc when I don’t want to use it.  I control the smart switch via Apple Home but could be Alexa or Google controlled too.

I have a hearing  aid transmitter connected to Optical output on the TV and had the same problem you had.  I could not switch settings on Sound to TV speakers and Optical while the Sonos Arc was powered because it would continually switch back to HDMI/ARC after a couple of seconds.  

Turning off the Sonos Arc soundbar with the smart switch, the LG automatically switches back.   You can navigate back if needed to your Bluetooth option.

My solution

I bought a smart plug and use it to shut off my Sonos Arc when I don’t want to use it.  I control the smart switch via Apple Home but could be Alexa or Google controlled too.

I have a hearing  aid transmitter connected to Optical output on the TV and had the same problem you had.  I could not switch settings on Sound to TV speakers and Optical while the Sonos Arc was powered because it would continually switch back to HDMI/ARC after a couple of seconds.  

Turning off the Sonos Arc soundbar with the smart switch, the LG automatically switches back.   You can navigate back if needed to your Bluetooth option.

Why not choose to just switch off Simplink on the LG TV, rather than powering off/on your Arc? Would that not have been easier, particularly as you have to goto the TV settings anyway to switch to Bluetooth or TV/Optical audio-out.

My solution

I bought a smart plug and use it to shut off my Sonos Arc when I don’t want to use it.  I control the smart switch via Apple Home but could be Alexa or Google controlled too.

I have a hearing  aid transmitter connected to Optical output on the TV and had the same problem you had.  I could not switch settings on Sound to TV speakers and Optical while the Sonos Arc was powered because it would continually switch back to HDMI/ARC after a couple of seconds.  

Turning off the Sonos Arc soundbar with the smart switch, the LG automatically switches back.   You can navigate back if needed to your Bluetooth option.

Why not choose to just switch off Simplink on the LG TV, rather than powering off/on your Arc? Would that not have been easier, particularly as you have to goto the TV settings anyway to switch to Bluetooth or TV/Optical audio-out.

Normally I don't need to do anything - the LG keeps my Optical output operating - Optical to my small Bluetooth transmitter

Turning On my smart switch brings back the Sonos Arc and the Optical/Arc switches automatically 

Gong through all the steps to turn off SIMPLINK more involved and a PITA

almost 2 years ago came across this problem ( LG 65 inch OLED + beam + airpods)

no resolution since then?

Unacceptable. 

Bad Sonos, bad.

 

 

almost 2 years ago came across this problem ( LG 65 inch OLED + beam + airpods)

no resolution since then?

Unacceptable. 

Bad Sonos, bad.

Whether you were to switch off CEC control on Sonos, or deactivate ‘Simplink’ on the LG TV - it’s still means a user will have to interact with either the App, or the LG Settings to switch to Bluetooth audio output - As the LG TV already supports switching off ‘Simplink’, arguably, there isn’t anything that Sonos needs to fix here.

If I switch off Simplink, the TV seems to re-enable it anyway, so even that isn’t a solution for me. I need to unplug the Arc altogether.

 

I like the smart plug idea further up the thread - thanks for that. That’s at least a semi-nice solution. 

If I switch off Simplink, the TV seems to re-enable it anyway, so even that isn’t a solution for me. I need to unplug the Arc altogether.

 

I like the smart plug idea further up the thread - thanks for that. That’s at least a semi-nice solution. 

That’s strange, I have two LG TV’s here and if I toggle off Simplink to use Bluetooth - it stays off with either a Beam or the Arc attached?

If I switch off Simplink, the TV seems to re-enable it anyway, so even that isn’t a solution for me. I need to unplug the Arc altogether.

 

I like the smart plug idea further up the thread - thanks for that. That’s at least a semi-nice solution. 

That’s strange, I have two LG TV’s here and if I toggle off Simplink to use Bluetooth - it stays off with either a Beam or the Arc attached?

I just double checked. Definitely re-activates for me, after a couple of seconds.

This is on an Xbox Series X → LG C1 → Sonos Arc. 

 

I just double checked. Definitely re-activates for me, after a couple of seconds.

This is on an Xbox Series X → LG C1 → Sonos Arc. 

 

The Xbox is not relevant. This is the first time I’ve ever come across s TV where the HDMI-CEC protocol can’t be switched off - the LG C9 and B9 models both work fine - and once ‘off’ it should also disable ‘auto-power-sync’ and the user can then go to the sound out menu and select the sound out options - internal TV speaker, Optical, WiSA soeakers, Bluetooth etc.. I accept those outputs can’t be selected until CEC is off, but never seen a TV that re-enabled CEC by itself - that sounds like a faulty TV to me. 

Think I understand the issue now. I was disabling HDMI Simplink, but I still had eARC enabled in the sound settings - it evidently re-activates it if eARC support is enabled.

With eARC disabled, Simplink stays off. 

 

Reply