Question

Audio delayed on Sonos ARC from native LG C9 TV apps


Badge

I’m experiencing an audio delay on my Sonos Arc whenever I use native apps like Youtube and Netflix through my LG C9 TV. All the settings I’ve found deal with delaying the audio further, but none let you do the reverse (i.e. delay the video signal or pull the audio signal forward). It’s a delay of somewhere between 100 - 200ms using this a/v sync test video, and it’s just about noticeable to be infuriating: https://www.youtube.com/watch?v=TjAa0wOe5k4

This delay seems much shorter when I watch the video through my Shield device, but I’d like to stick to the native LG apps because of better Atmos support. 

Any thoughts on why this might be happening and how to fix? I’ve looked at a couple of posts here and here but I don’t see a negative value for the audio delay on my TV sound settings. Here are my current settings:

C9 sound settings: Sound out set to HDMI ARC; Digital sound out set to Passthrough; e-ARC on; AV sync adjustment set to Off

Arc: TV dialog delay set to zero.


14 replies

Userlevel 7
Badge +21

You need to switch to optical from HDMI. Many LG models add unnecessary delay in DD 5.1 pass through over HDMI, for reasons unknown.

Badge

That’s unfortunate - but if that’s true, how is there a difference between the delay on an internal app vs. an external HDMI source?

Switching to optical would beat the point of using a soundbar that I purchased specifically for its Atmos capabilities. 

Userlevel 7
Badge +21

That’s unfortunate - but if that’s true, how is there a difference between the delay on an internal app vs. an external HDMI source?

 

Because some at LG messed up, I would imagine. Different hardware and software paths for those signals.

Badge

Many LG models add unnecessary delay in DD 5.1 pass through 

Was thinking about this as well - Youtube doesn’t do DD 5.1, so how is there still a delay when I use this video to do an audio sync test?

Badge

Bumping this up to see if there are other ideas.

Userlevel 7
Badge +21

Bumping this up to see if there are other ideas.


I already posted the workaround: switch to optical. Apart form LG fixing their firmware, I’m not sure what other idea you are looking for.

Badge

Many LG models add unnecessary delay in DD 5.1 pass through 

Was thinking about this as well - Youtube doesn’t do DD 5.1, so how is there still a delay when I use this video to do an audio sync test?

@controlav Do you know why this happens?

Userlevel 7
Badge +21

Many LG models add unnecessary delay in DD 5.1 pass through 

Was thinking about this as well - Youtube doesn’t do DD 5.1, so how is there still a delay when I use this video to do an audio sync test?

@controlav Do you know why this happens?


I’m a software guy, not a hardware guy, so I would imagine that someone messed up. Generally speaking audio/video stuff is complicated, but I fail to see why any device would have to do any processing on a pass-through audio signal via HDMI when it doesn’t have to do any with the same signal sent over optical.

Userlevel 1
Badge

I have the c9 and the arc.

What firmware is the c9?

Unplug the arc. Go into the sound settings when in a internal LG app playing audio. Turn ai audio off. Turn any sound adders off. Turn to passthrough and earc on. Turn off the LG using the power button (hold for ten seconds) unplug the tv, plug it back on and turn on.  Plug in the arc. Go back into the LG app and play audio. Go into audio settings again and make sure the sound is standard, make sure dolby is greyed out and on. Ai sound is greyed and off. Sound out to HDMI arc. Go into additional settings and set HDMI input audio to  bitstream.

I have no delay on my c9 with newest firmware 4.80.03 as long as all sources are bit stream and not Lpcm 

Badge

I have the c9 and the arc.

What firmware is the c9?

Unplug the arc. Go into the sound settings when in a internal LG app playing audio. Turn ai audio off. Turn any sound adders off. Turn to passthrough and earc on. Turn off the LG using the power button (hold for ten seconds) unplug the tv, plug it back on and turn on.  Plug in the arc. Go back into the LG app and play audio. Go into audio settings again and make sure the sound is standard, make sure dolby is greyed out and on. Ai sound is greyed and off. Sound out to HDMI arc. Go into additional settings and set HDMI input audio to  bitstream.

I have no delay on my c9 with newest firmware 4.80.03 as long as all sources are bit stream and not Lpcm 

I'm on 4.80.03 as well. I tried all the steps you outlined and did find a couple of things in my settings that needed cleaning up (my sound mode was set to “Clear Voice”, for example). Fixed all that but I’m still seeing and hearing the delay. All my HDMI sources are already set to bitstream as well, although I’m not sure why there isn’t a similar setting for internal apps. 

Here’s a video I took on my phone of the delay happening on this audio sync test from YouTube: 

You can see if you slow the video playback speed down that it hits after 200ms - maybe the phone capture added a few ms but it seems a tad longer than what I thought I saw on the TV, which seems to be closer to 100ms. Are you seeing better results on your setup?

Userlevel 1
Badge

I have taken a video using the same av test. It does not appear that my c9 and Arc have any noticeable or measurable audio lag. I will try to make my clip public and link it below.  

https://drive.google.com/file/d/1VgJNwQzdoe6rvtCm4-Ll4JznvjYM6Ldw/view?usp=sharing

Badge

I have taken a video using the same av test. It does not appear that my c9 and Arc have any noticeable or measurable audio lag. I will try to make my clip public and link it below.  

https://drive.google.com/file/d/1VgJNwQzdoe6rvtCm4-Ll4JznvjYM6Ldw/view?usp=sharing

Thanks for doing that, I appreciate the ability to compare your results with mine. To be honest, I’m seeing about a 300ms delay on your recording as well. It’s apparent if you change the playback speed to 0.5x or 0.25x. It could just be because of variability in how our cell phones record, but it’s still there.

I took a recording of the same video playing on my desktop where to my eyes and ears there is virtually no delay, and you can see how even through the cell phone recording the audio hits with a delay of under 50ms:

 

And here’s the recording from my C9 again for quick reference:

 

Userlevel 1
Badge

I have taken a video using the same av test. It does not appear that my c9 and Arc have any noticeable or measurable audio lag. I will try to make my clip public and link it below.  

https://drive.google.com/file/d/1VgJNwQzdoe6rvtCm4-Ll4JznvjYM6Ldw/view?usp=sharing

Thanks for doing that, I appreciate the ability to compare your results with mine. To be honest, I’m seeing about a 300ms delay on your recording as well. It’s apparent if you change the playback speed to 0.5x or 0.25x. It could just be because of variability in how our cell phones record, but it’s still there.

I took a recording of the same video playing on my desktop where to my eyes and ears there is virtually no delay, and you can see how even through the cell phone recording the audio hits with a delay of under 50ms:

 

And here’s the recording from my C9 again for quick reference:

 

You and I are seeing two different results then. I slowed my footage down to .10 speed using VLC, KMplayer and 5kplayer, each with ever so slightly different results but the best showed the sound is right on near 50ms mark. That is noting the exact moment you first hear the beep, not its echo trail.  So it depends on what video player you are using. We should also be recording at 120fps using 120fps test footage. 30fps videos might in themselves introduce a small delay / fall out of sync when we are slowing down the frames to count.  In my experience some playback players do out of sync when you go below half video speed. 

My set up (once set to the correct audio settings) has not shown any real world audio lag in any content. Built in apps, bluray player, pc4, NSwitch.  

Badge

That’s really weird - because I downloaded your video file and tried on VLC to double-check and the first beep (not echo trail) is still hitting a few notches shy of the 300ms mark Whereas when I playback the recording I did from my desktop on the same conditions (VLC, desktop, wired speakers) the delay is a notch or two at most over 0ms. (Curious to see if others viewing this thread might venture a try and post their results). 

Back to my C9, though, I barely notice a delay when I play the same video from my 2017 Nvidia Shield, so this problem seems to be isolated to LG’s inbuilt apps. I’m going to try and disconnect all HDMI sources and go through your steps again to see if that changes anything. Thanks again for helping me troubleshoot this.

Reply