Arc connection works for a few weeks then stops

  • 19 December 2020
  • 1 reply

I bought an arc thought I’d get next lvl atmos sound… but have had nothing but headaches..

it will work for a week then mid show not even pushing any buttons will just stop emitting sound until it’s hooked back up threw optical..

this is beyond frustrating and no where is it made apparent if you own a Samsung tv this product won’t work... 

this is a big chunk of the market have they not solved this problem yet? Should I be looking for a new sound system that works..

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @Scott Lesko

Thank you for reaching out to the Sonos community and for letting us know about your concern. Allow me to share some information about Sonos Arc audio input. 

The Sonos Arc can play Dolby Atmos audio. ARC and eARC are protocols responsible for sending audio over an HDMI cable to home theater sound systems like Sonos Arc. Sonos Arc must be connected to HDMI ARC or HDMI eARC to play any Dolby Atmos content. Not all TVs have HDMI ARC or HDMI eARC. 

Let me suggest the next troubleshooting and see if it works for your Sonos Arc.

  1. Reboot your Sonos Arc and Samsung TV
    • Unplug the HDMI cable from the Sonos Arc and the Samsung TV. 
    • Unplug the power cable from your TV, the Sonos Arc, and any connected audio source (such as a cable box or video game console). Wait 30 seconds before you plug them back in.
    • Reconnect the HDMI cable directly to your Samsung TV and the Sonos Arc. Inspect the HDMI cable to ensure it’s not bent or kinked and check to see that it’s fully inserted into both devices.
  2. Check for your Samsung TV software update (if available).
  3. Adjust the group audio delay - Settings > System > Tap your Sonos Beam > Group Audio Delay and then choose a delay option.
  4. Check for Sonos update - Settings > System > Check for updates.
  5. Enable HDMI-CEC on your SamsungTV
    • Home> Settings> System> Expert settings> Anynet + (HDMI-CEC)
    • If you run into an issue enabling HDMI-CEC, please check your TV manual
  6. Check if autoplay is enabled in the Sonos app
    • Settings > System > [Home Theater Room] > TV Autoplay.

Let us know how you get on with the advice above and run a diagnostic report. Kindly include the confirmation number in your response for us to check. If you have any questions about this. We and the community are always here to help.