Answered

Unable to play music using Google Assistant on Sonos


I have a Beam for about a year. Before, I was able to play music on my Beam normally by asking Google Assistant to play it from Spotify on the Beam. Recently I purchased couple of One gen 2 speakers and set them as surround. After that I’m unable to ask Google Assistant to play music on the Sonos. I also noticed that my Sonos is no longer listed as speaker on the “Media” menu in Google Home app. Now the app only detects my google nest speakers, but no sonos speaker.

I can still play music using Sonos app or airplay, and all Google Assistant commands work perfectly. I have tried to reboot my Sonos and make them as single speakers, but still Google doesn’t detect the speakers in “Media” menu. Is there any bug that cause this or any change on Google policy that no longer allows non-Google speakers to play music using the google assistant?

icon

Best answer by Corry P 26 July 2021, 15:06

Hi @drewray 

Welcome to the Sonos Community!

If you’re still having this problem, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports about the situation.

View original

8 replies

When Sonos One speakers are ‘bonded’ as surrounds to the Sonos Beam you can only put the Google Assistant onto the Beam only …and only one Sonos device/room should show in your Google App.

To rescan for devices goto the ‘works with Google’ section of the Google Home App and either unlink/relink the Sonos Action, or choose the option to "check for new devices" and add them to your Home and chosen Room. (See attached screenshot). The sharing agreement needs to be setup between your Goggle and Sonos Accounts during this account linking process.

Note too that the Spotify Music service needs to be their premium subscription service (not the free service) and both the Google Spotify music service and the Sonos Spotify Music service need to be signed into the same account.

 

Yes I have been through all the steps and relinked the Sonos and Google Account. My Spotify account is premium, and the same account is used on both Google Home and Sonos. Every time I asked Google to play music, I always got response: “Sure, music from Spotify, playing on living room.” (Seconds later) “sorry that mode isn’t available for the living room.”

 

In the google home app, my sonos is listed in the room devices, but not listed in the “media” speakers under “Listen on”.

 

My thoughts next are to maybe see if a reboot of your router might fix the issue.

Hi, I’ve done a reboot of my router, but it is still not working.

Hi, I’ve done a reboot of my router, but it is still not working.

Do you have another music service you can set as your ‘default’ music service? If not, then perhaps try signing out of the Spotify music service both in your Google Home Account and the Sonos App.. then re-add Spotify back to both Apps ensuring Spotify is set as the default service in the Home and then try again.
 

By the way, are there any other ‘people’ or ‘Homes’ linked to your Google Home Account?
 

Can you also check only one language is installed for use with your Google ‘Assistant’ App and also check your Country setting in your Sonos profile (https://www.sonos.com/myaccount/user/profile/) is set to the same country as the language shown in the Google Assistant App.

I found a thread with similar issue. This might be what I have been experiencing. 

 

I found a thread with similar issue. This might be what I have been experiencing. 

That’s a thread from a year ago? - you could just temporarily try another Google ‘Home’, or ‘Account’, just to be sure. It’s still all working here for my Google Account and Sonos.

Userlevel 7
Badge +17

Hi @drewray 

Welcome to the Sonos Community!

If you’re still having this problem, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports about the situation.

Reply