"Sorry, there was a glitch. Please try again in few seconds."

  • 13 December 2021
  • 8 replies
  • 236 views

I’m using 2x Sonos One and Beam 2. All of them are using Wi-Fi 5GHz via the Unify AP. The apartment is small (<50 sqm) and the network is usually stable. All the devices are updated to their latest firmware versions.

However, couple times a day when I say “Ok Google” or “Hey Google” the Sonos speakers immediately answer with “Sorry, there was a glitch”. Then if I repeat myself, assistant is able to process the query.

What can I do to help you diagnose the problem? I’ve already submitted the diagnostic information via the app. Is there anything else I can do?


8 replies

Are you perhaps able to cable the Beam direct to the main Unify AP, that might improve things for you and is worth a try.

Are you perhaps able to cable the Beam direct to the main Unify AP, that might improve things for you and is worth a try.

I don’t have any problems with playback so far. Would connecting Ethernet to Sonos device help with how the Google Assistant works on them? Would connecting the Ethernet cable to Sonos One work the same as connecting to Beam?

Are you perhaps able to cable the Beam direct to the main Unify AP, that might improve things for you and is worth a try.

I don’t have any problems with playback so far. Would connecting Ethernet to Sonos device help with how the Google Assistant works on them? Would connecting the Ethernet cable to Sonos One work the same as connecting to Beam?

No, not if the Sonos One is a ‘bonded’ surround to your Beam - don’t cable that as it won’t assist.

My own thoughts were that your Sonos HT setup, in general, would benefit if it were wired rather than having its connection over wireless, which may ‘perhaps’ be seeing some intermittent interference.

I connected the Beam over the ethernet to my router (UDM Pro) and removed the wifi network from the Sonos settings. I selected channel 6 for the Sonos Net. Now the Sonos Beam works more or less fine, but Sonos Ones fail almost always after 10-15 min of standby. The subsequent calls are usually fine.

In my new apartment I may be able to connect all the speakers via wire, but right now I would prefer all to be set via wi-fi, alternatively just Beam via wire. However, it seems that the problem is with the Sonos Net, not with my wi-fi connection (which is based on U6 Lite Access Point).

I connected the Beam over the ethernet to my router (UDM Pro) and removed the wifi network from the Sonos settings. I selected channel 6 for the Sonos Net. Now the Sonos Beam works more or less fine, but Sonos Ones fail almost always after 10-15 min of standby. The subsequent calls are usually fine.

In my new apartment I may be able to connect all the speakers via wire, but right now I would prefer all to be set via wi-fi, alternatively just Beam via wire. However, it seems that the problem is with the Sonos Net, not with my wi-fi connection (which is based on U6 Lite Access Point).

I thought that your Sonos Ones were ‘bonded’ to your Beam as ‘surrounds’? If that is the case, they are not using your router WiFi signal in either type of setup, as they just communicate with your Beam ‘direct’ over a 5Ghz ad-hoc wireless connection. So is it a case that they are not ‘bonded’ to your Beam as surrounds?

Also, I appreciate you say you set the SonosNet option to channel to 6, but do you have more speakers besides, the Beam and the two bonded Ones, which would be just the one Sonos Room only🤔? …I didn’t think the option to set a SonosNet channel was available in the case where there is just the one Sonos room, but perhaps I’m mistaken about that?

What is your routers 2.4Ghz channel set to anyway?

Another thing, as you mention a UniFi setup... can you check if this may perhaps apply in your case (suggested in another post here on the forum):

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

 

I am having the exact same issue here.

I actually have 2 Sonos systems.

When is the arc in the living room and the Sonos beam in a bedroom.

Both units have a pair of Sonos One SL surrounds and their subs

Everytime I issue a Google command it will always respond back with "there was a glitch try again in a few seconds. " Immediately issue another command it will work fine. After about 15 to 20 minutes of no command it will glitch again.

Have the Arc set to mute so there are no interference but it doesn't help. There are no other Google units in the room and the Sonos surround speakers do not have a mic built-in.

I am using Google WiFi mesh. It runs on both 2.4 and 5Ghz

@ultramoo 
Perhaps first see this link about the Google WiFi mesh setup with Sonos:

Sonos on WiFi Mesh

I would perhaps see if following the suggestions in that thread will improve the connectivity issues you are seeing. It means running your setup in wired SonosNet mode, where one Sonos product (not a surround or Sub) is wired to the router and not a Google Satellite Hub. I would just see if that will perhaps sort the problems you mention.🤞

Reply