Answered

Sonos showing up under 'Airplay and Bluetooth' instead of alongside Google home speakers

  • 3 September 2023
  • 1 reply
  • 87 views

Help!

If I go to cast music from my phone and tap that cast icon, my soundbar+sub doesn't show up in the list of devices, but rather, only if I further tap the 'Airplay and Bluetooth devices'. You might be thinking, well yeah, you didn't set it up in Google Home. Yet, I did, and when I go directly into the Google Home app, I can see it listed there among my other speaker devices.

It seems like I have to choose between soundbar+sub (via 'Airplay and Bluetooth devices') or my other speakers (Google Home devices). How do I get the soundbar+sub to show up alongside my other google home devices when I go to choose which devices to cast to?

Is it possible that Airplay somehow claimed ‘ownership’ and I need to disable the Airplay connection and reestablish the connection only via Google Home (somehow?). I’m grasping at straws here.

Please and thank you,
Keven

 

icon

Best answer by Corry P 5 September 2023, 10:26

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Ballripper 

Welcome to the Sonos Community!

If I understand you correctly, the problem is that Sonos does not support the Chromecast protocol, and never has. For this reason, Sonos rooms are not going to show in your list of devices to cast to.

You can, however, connect your compatible Sonos devices to AirPlay or Bluetooth, as you have already discovered.

Sonos cannot play in sync with smart speakers from other manufacturers (unless they are also playing AirPlay). 

I hope this helps.