Sonos Products dont connect to Google Assistant

  • 4 January 2024
  • 4 replies

  • Contributor I
  • 0 replies

I am trying to setup google assistant on my Living Room setup (Beam +2xOne) and my move and always get the same Error message in the Sonos App: “There was a problem adding Google Assistant”. 

Initially it was working in the living room, but in the process of figuring out where the problem is I destroyed the link somehow. I did remove the sonos devices from google home and tried again, i restarted the systems… just dont know what else i can try. 



Best answer by Airgetlam 4 January 2024, 20:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

I would call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.


Is this issue sorted for you now?

I have been in contact with Sonos support to solve the issue for 4,5 hours. There was no sign of a solution!

Please list a solution Sonos!!

Same here, I bought a brand new Beam Gen 2 today. I contacted Sonos Support today but the agent was not really helpful. He played the problem down and suggested that it might be Googles fault. Not the customer experience I expect when purchasing a 500 $ Soundbar!