Sonos playing music when I speak to Google Assistant in another room

  • 29 April 2021
  • 6 replies
  • 48 views

My Sonos Roam is on a shelf in my office. If I'm in another room in the presence of a Google device (Home or Home Mini) and ask it to play music, the Google device answers me but the Roam, in another room, plays the music.  The Roam isn't responding to the query directly, but somehow it ends up playing the music anyway. How do I stop it doing that, so the music will come out of the speaker that's responding to me? This didn't happen before I had the Roam (eg the two Home devices didn't steal audio from each other).

 

I had considered turning the Roam off as a workaround, by holding the power down for 5 seconds, but after a while it always turns back on again by itself so that's not a solution.

 

Any ideas gratefully received!


6 replies

Userlevel 5
Badge +14

Hi @TrickyJoe, welcome to the Sonos Community!

Does this occur when you specify the device name in your command? i.e. “Hey Google, play David Bowie in the Kitchen" - does the Roam still steal the audio?

It may also be worth checking if the Roam has been set as the preferred speaker in the Google Home app.

If this doesn’t help, would it be possible to remove and then re-add Google Assistant to the Roam? (Sonos > Settings > Services > Google Assistant > Remove)

Let us know how you get on :)

Thanks for the reply. It doesn't seem to happen when a device is named, no. I noticed earlier that the Roam isn't exactly intercepting the particular music request - instead it wakes up and continues playing what it was playing before it was turned off (not necessarily the music that was asked for).

It isn't set as the default device for Assistant.

I'll try removing and readding soon. In the meantime, is there a way to turn the device off properly so it can't wake up? (As I mentioned, holding down the power button for 5 seconds seems to do it but then it goes back to standby later.)

Userlevel 5
Badge +14

Hi @TrickyJoe, understood - let us know if there’s any change after removing and re-adding.

Regarding powering the Roam off, holding the power button for 5 seconds as you have been doing should be preventing the Roam from waking up - it may be an idea to take a system diagnostic the next time you experience the Roam turning on by itself and take a note of the confirmation number, and then get in touch with the Support Team via live chat or phone call to take a look :)

Thanks, I’ll speak to support about the power and reply back here when I get a chance to fiddle with the app.

Another quick update: my wife just told the shower room speaker to “play” with no other details (because it had temporarily stopped playing, claiming a network interruption) and the Sonos Roam in another room woke up and started playing.

Userlevel 5
Badge +14

Understood, thanks for keeping us updated!

Certainly sounds like there’s some confusion going on with the Google Assistant integration in your system. One thing that may help is a setting in the Google Home app;

If you tap the profile icon at the top right, and then choose Assistant Settings > Devices, for each speaker you can set the Default media output - setting that to the same speaker should cause Google Assistant to always play the requested song or album on the speaker that heard the command.

Let me know if this helps :)

Reply