Sonos and Google Online Storage

  • 19 November 2019
  • 14 replies
  • 473 views

I have found a way round this issue. Firstly as you have Google Play Music I presume you also have Google Drive ( free online storage). In this drive create a folder called music, then in this folder create a folder for each artist, say Adele. then in this folder upload mp3 songs of hers you own. You cannot just upload the album it must just be the mp3s.

Then in the Amazon Alexa app go to the skills and enable Personal Jukebox, this will ask you to choose the online storage for Google. Enter user name and password and accept. Job done. Then on Sonos say ‘Alexa Tell Personal Jukebox to play Adele’ (or which ever artist folder you have created). The only issue is that Personal Jukebox shuffles the songs in the folder, but hey at least you can use you cloud storage!


14 replies

https://www.mypodapp.com/

This is not aomething I need myself, but I can see it being useful for some users. Thanks for sharing.

I'll probably have a go anyway just because I'm a geek. Will personal jukebox only handle mp3 format, do you know?

https://www.mypodapp.com/


You only have one playlist and 128mb for free, you have to pay $3.99 per month for unlimited. Google Drive (15gb) and Personal Jukebox is free.

OK now it may be just that I haven’t experimented enough with this yet, but it seems that Personal Jukebox will play to the Alexa device that receives the command.  That may be fine if you have a One or a Beam, but not so good if you are using Echo Dots and non-Alexa-enabled Sonos speakers.  The audio comes from the Dot, not the ‘preferred’ Sonos speakers linked to it.

There may be a way round this - I haven’t really tried yet.

OK now it may be just that I haven’t experimented enough with this yet, but it seems that Personal Jukebox will play to the Alexa device that receives the command.  That may be fine if you have a One or a Beam, but not so good if you are using Echo Dots and non-Alexa-enabled Sonos speakers.  The audio comes from the Dot, not the ‘preferred’ Sonos speakers linked to it.

There may be a way round this - I haven’t really tried yet.


Yes i was referring to Sonos One and Alexa as the Personal Jukebos is in the Skills list.

I have my produced music in mp3 files in Google Drive and have not been able to access it through Sonos One. Does anyone know if the approach described works for Google Assistant as well?

Personal Jukebox no longer plays mp3 files from Google Drive. However it does play mp3 files from Dropbox. So create a free Dropbox account, create a folder called Music and in that create a folder for each artist. As Personal Jukebox shuffles files what I do is merge my music files from a single album to create one mp3 file. I use a free tool called mp3merge, (https://mp3merge.software.informer.com/), very easy and quick to use. Then when enabling skill Personal Jukebox in Alexa direct it to Dropbox.

Thanks for using our skill, Personal Jukebox.  We really wanted to continue supporting Google Drive but changes in their API squashed that dream.  Anyway - wanted to let folks know that if they say “Alexa Shuffle Off” when Personal Jukebox is running - it will then play songs in order by Artist, Album, Song.  So for example if you told Personal Jukebox to play “Dark Side of the Moon” it would randomly pick songs - but if you instead say “Alexa Shuffle Off” after it starts playing you’ll get it in track order.   We’ve played with the idea of making this an “option” - always play in Artist, Album, Song order if you request Personal Jukebox to remember your choice, etc.

techdad24

Hi. I using Dropbox and have tried saying “Alexa Shuffle Off” after it starts playing music, but all I get is Alexa saying ‘Sorry I am having trouble accessing your cloud drive right now’ and the music just carries on playing in random order. Any ideas?

techdad24

Hi. I using Dropbox and have tried saying “Alexa Shuffle Off” after it starts playing music, but all I get is Alexa saying ‘Sorry I am having trouble accessing your cloud drive right now’ and the music just carries on playing in random order. Any ideas?

Are you using the 'My Pod', or 'Personal Jukebox, Skill with Alexa here? .. if so, you may ‘perhaps’ need to address the skill in the Alexa instruction, if either of those skills support that feature?

Just as an example… “Alexa, ask MyPod to set shuffle off”.

Note, I don’t use either of these particular skills, so this is just a bit of a guess on my part.

 

Thanks for using our skill, Personal Jukebox.  We really wanted to continue supporting Google Drive but changes in their API squashed that dream.  Anyway - wanted to let folks know that if they say “Alexa Shuffle Off” when Personal Jukebox is running - it will then play songs in order by Artist, Album, Song.  So for example if you told Personal Jukebox to play “Dark Side of the Moon” it would randomly pick songs - but if you instead say “Alexa Shuffle Off” after it starts playing you’ll get it in track order.   We’ve played with the idea of making this an “option” - always play in Artist, Album, Song order if you request Personal Jukebox to remember your choice, etc.

I am using Personal Jukebox not MyPod, the above solution does not work.

Thanks for using our skill, Personal Jukebox.  We really wanted to continue supporting Google Drive but changes in their API squashed that dream.  Anyway - wanted to let folks know that if they say “Alexa Shuffle Off” when Personal Jukebox is running - it will then play songs in order by Artist, Album, Song.  So for example if you told Personal Jukebox to play “Dark Side of the Moon” it would randomly pick songs - but if you instead say “Alexa Shuffle Off” after it starts playing you’ll get it in track order.   We’ve played with the idea of making this an “option” - always play in Artist, Album, Song order if you request Personal Jukebox to remember your choice, etc.

I am using Personal Jukebox not MyPod, the above solution does not work.

Perhaps try this then, but see my note below…

"Alexa, turn off shuffle"

Oddly the option is only available when music is playing. If you try to turn shuffle on or off without music playing Alexa will explain that she can't do that.

Nope tried that with music playing and when not, still will not turn off shuffle.

We use Dropbox for our primary testing ground with around 300 songs - just tried the Alexa Shuffle Off while listening to music and it came back with the expected response.   There may be something else causing the skill to return the “unable to access cloud” message.  You could try disabling/re-enabling the skill.  This will cause it to re-index and hopefully clear up any connection issues.  Thank you again for using our skill.

Reply