Answered

ok google & youtube music

  • 7 December 2020
  • 6 replies
  • 85 views

I’ve seen many questions to the below but not found an answer so I will add my penny worth

I have new sonos beam and all integration with sonos app and youtube music is fine apart from the truncation list issue. ie I can play youtube music from the sonos app

 

OK Google questions like weather and what is my diary work fine

But when i ask google to play a track eg ok google play artist trackname  i get the following reply

 

“Ok playing trackname on YouTube music. Sorry I can't find what you're asked for”

I have the basic youtube music. All the various combinations of asking to play a track/artist fail with the message above.

 I have a  google home speaker and all the commands for youtube music WORK on this.

Any ideas please

icon

Best answer by IButts 16 December 2020, 09:53

Hi Rowena,

Yes seems to be working now after google outage complications.

Just for you info, did as you said removed assistant from app, went into assistant app, didn’t have to do anything.

Then when I added assistant back in app the process was different. For example DIDN’T have to authorise with the code.

Strange.

 

Anyways many thanks for your help

 

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 5
Badge +16

HI @IButts,

Welcome to the Sonos community and thanks for reaching out to us. I’m sorry to hear about this issue with your Sonos devices to your Google Assistant.

I would like to ask some questions to better understand what is going on and for me to know how to proceed.

  • When did it start happening?
  • Do you experience the same issue with your other music services?
  • Are there any changes made to the settings of the Google Assistant before this issue occurred?
  • Have you tried to remove and readd the Google Assistant on the Sonos App, not directly removing the Google Assistant App? You may check this article on Removing Voice Services on Sonos for reference.
  • Can you submit a diagnostic so we can check what is going on?

 

The more information you provide will help us check further on what could be causing this issue. Keep us posted on how it goes and we're here to answer any further questions you have.

answers below

When did it start happening?
day 1 out of the box 28/1½


Do you experience the same issue with your other music services?
don't use any other services


Are there any changes made to the settings of the Google Assistant before this issue occurred?
no. as I said google home speaker works fine


Have you tried to remove and readd the Google Assistant on the Sonos App, not directly removing the Google Assistant App? You may check this article on Removing Voice Services on Sonos for reference.
several times


Can you submit a diagnostic so we can check what is going on?
number is 968682743

Thanks

1st answer date should be 28/11/2020 when I purchased it

Userlevel 5
Badge +16

Hi @IButts

Thanks for your response and for answering the questions. Upon checking the diagnostic, there are no issues found in your Sonos system. Let me share some information about this issue.

It appears to be a Google account-specific issue. We have seen this behavior before with Google Assistant and it's usually being resolved by using a different or new Google Account. Do you have another Google Account? Can you create one to test and perform the below steps?

1. Remove Google Assistant from all Sonos voice-enabled speakers.

2. In the Google Assistant app, go to Settings by tapping the user picture in the top right corner, then select the Devices option and ensure all Sonos devices have been removed.

3. Re-add Google Assistant to Sonos via the Sonos app to the desired speaker.

Let us know how you get on with the advice above. If you have any questions about this, feel free to reach out. We and the community are always here to help.

Hi Rowena,

Yes seems to be working now after google outage complications.

Just for you info, did as you said removed assistant from app, went into assistant app, didn’t have to do anything.

Then when I added assistant back in app the process was different. For example DIDN’T have to authorise with the code.

Strange.

 

Anyways many thanks for your help

 

Userlevel 5
Badge +16

Hi @IButts, thanks for your response and for updating us. I’m glad that you’re Sonos system now with Goog Assistant. If you have questions in the future or need help with your Sonos device, please feel free to reach out. We’ll always happy to assist you.