Answered

My Google Assistant account will not connect to my Sonos One

  • 10 January 2021
  • 8 replies
  • 72 views

I am trying to add Google Assistant to Sonos. Each time I try to do so, the Google Assistant app says that no devices are found. I've reset my router factory reset my Sonos one with no luck. 

icon

Best answer by Simon B 12 January 2021, 19:12

Hi @Jwieland16, thanks for the update. another device controller means other devices or another phone which you have the Sonos App on. and check if you’ll be able to set up the Google Assistant that way? I’m also thinking if you’re using the same Google account on the other location where you were able to set up the Google Assistant might be causing the issue. Have you tried setting it up using another google account?

Let us know how it goes and we're here to answer any further questions you have. 

View original

8 replies

Userlevel 6
Badge +15

Hi there @Jwieland16, Thanks for reaching out, and welcome to the community. Sorry to know about your issue setting up Google Assistant on your Sonos system. I’ll ask you if have you tried it on another device controller if the same thing will happen during the setup. and If there are multiple Google accounts logged in to the device. Kindly signout from the other accounts and have the desired account the only remaining one when you do the setup. 

Keep us posted on how it goes and we're here to answer any further questions you have.

Thank you, Simon.

What exactly do you mean by "device controller"?

In a separate home than the one in which the Sonos One is located, I own a Sonos Beam which I've successfully set up with Google Assistant. To be sure, the Sonos Beam is associated with a different google account and sonos account than the Sonos One. 

 

I have two Google accounts on my phone. I use one account for the home in which the Sonos one is located in one account for the home in which the Sonos Beam is located. 

I experimented with Alexa on the Sonos one and had no issues connecting to Alexa.

 

Userlevel 6
Badge +15

Hi @Jwieland16, thanks for the update. another device controller means other devices or another phone which you have the Sonos App on. and check if you’ll be able to set up the Google Assistant that way? I’m also thinking if you’re using the same Google account on the other location where you were able to set up the Google Assistant might be causing the issue. Have you tried setting it up using another google account?

Let us know how it goes and we're here to answer any further questions you have. 

Thank you for the clarification, Simon. I will try to connect Google Assistant to my Sonos using a different device controller such as my iPad. I've been using my phone after this point.

With respect to your second point, I am using a different Google account on the Sonos Beam. As such, I would presume there wouldn't be any interference or conflict. So to answer your question, I am using a different Google account than the one I am using on the senos Beam to try to set up the Sonos one.

 

I will try a different device controller and see if that resolves the issue.

Userlevel 6
Badge +15

Hi @Jwieland16, thanks for the update. Keep me posted on how it goes, If you have any questions or run into any other issues, please do not hesitate to contact us. We are always happy to assist you. Thanks.

Userlevel 4
Badge +7

Sometimes this just happens - setup of Google Assistant on Sonos won’t work for a couple of days. I’ve seen it 3 or 4 times since GA on Sonos was introduced. In such cases you just have to wait until whatever is wrong gets fixed. So if you’re sure you are following the instructions correctly, don’t spend too much time trying to fix it until you have given it a few days to see if the problem resolves itself.

Thanks, Doug. Unfortunately this has been going on for months. I wish it was just a few days.

 

That said, Simon's advice above to use a different device controller (e.g. phone, ipad) to connect resolved the issue. For some reason my Pixel 3a did not want to connect to the Sonos one. I went through the same process using the Sonos app and Google home app on my iPad and was able to get Google Assistant setup. Go figure.

Thank you Simon B for your help!

 

 

Userlevel 6
Badge +15

Hi @Jwieland16, thanks for the update and I’m glad it worked. If you have any questions or run into any other issues, please do not hesitate to contact us. We are always happy to assist you.

Reply