Household in an odd state (requires a device with ethernet connection) - otherwise some devices undiscoverable and voice does not work for some voice capable devices

  • 17 April 2021
  • 1 reply
  • 20 views

About 6-8(?) weeks ago my a few of my devices dropped out of my household.  I don’t know the trigger for that.  Most of my voice capable devices suddently kept on “I can’t connect to the internet...” - the only exception was my Sonos Move.  There are also some devices that was in the household that are not discoverable (does not appear in the list if devices).  In the Voice section of my iOS app, when I go into the device list, it showed the Move and all the other devices that had been configured with voice was not shown (and when I try and add, it says all device already configured with voice).  I went to my sonos.com profile and look at my system and a lot if them was showing “offline” even though they are up and has valid IPs.  The voice capable devices had their mic enabled but I kept on getting the “can’t connect to internet error” when the wakeword is triggered.  Those devices that are showing as offline in my sonos.com:profile:system cannot playback Spotify but can play local library (as if the connection to some Sonos backend is broken).

 

To get around it, I need to wire an ethernet to a device (I used a Sonos One for it).

 

I submitted this diag back in Feb 12th 2021: 1280925114.

I am submitting my diag again now (single device with ethernet connected): 87699878


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Badge +17

Hi @WowAndFlutter, welcome to the community.

 

I’ve taken a look at both diagnostics and to be completely honest, both look completely normal. When a device shows as offline on your profile on the website, that means the device hasn’t established a connection to the Sonos cloud server. However, I’m able to see all of your devices in both diagnostics, and they all have active cloud connections. Since I can also see you have an Asus router, have you disabled a setting named Airtime Fairness on both 2.4 and 5GHz bands? This setting can often cause issues in fully wireless setups and needs to be disabled.