Answered

Google Home can't find Roam


I have a Beam in the lounge with two One SL’s as surrounds. Google Assistant works fine on this setup.

 

I have just bought the Roam and when trying to add the Google Assistant, it simply does not find the device. I have now tried it several times, both through Google Home and also starting within the Sonos app.

 

I removed Google Assistant from my Beam and tried again in Google Home, it found the beam instantly … but not the Roam. Ugh.

 

The Roam is on my network, I can play Spotify through it, I can add it to other speakers to play the same music concurrently (speaker groups?) … but I can’t add Google Assistant … as Google Home just cant find it! Frustrating to say the least. 

icon

Best answer by Corry P 5 May 2021, 13:25

Hi @premiump 

Thanks for trying those steps.

At this point, it’s difficult to proceed without getting some information from the speakers themselves.

I recommend you make sure both Sonos and Google Home/Assistant apps are fully up-to-date and try rebooting your phone/tablet or try using another device, if you have one available. It may also be worth trying again with the RBW30 turned off, though this is a long-shot.

Failing that, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

View original

10 replies

Userlevel 6
Badge +16

Hi @premiump 

Welcome to the Sonos Community!

That sure sounds annoying! With things working well on the Beam, I would have to assume that the issue lies with networking (although I realise with everything else working well it may not seem that way to you). Which model of router do you have, and have you tried a reboot of it?

Which model of router do you have, and have you tried a reboot of it?

Hi Corry,

I have the Netgear Orbi RBR40 with satellite RBW30. I have now rebooted both at your suggestion and the issue remains. I have now tried from both my mobile and my tablet with the same result.

I would appreciate some further suggestion on what do next.

 

EDIT: I have now also removed the Roam completely from my Sonos system and re-added it. The issue remains. 

Userlevel 6
Badge +16

Hi @premiump 

Thanks for trying those steps.

At this point, it’s difficult to proceed without getting some information from the speakers themselves.

I recommend you make sure both Sonos and Google Home/Assistant apps are fully up-to-date and try rebooting your phone/tablet or try using another device, if you have one available. It may also be worth trying again with the RBW30 turned off, though this is a long-shot.

Failing that, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

Failing that, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I think that’s what I’ll have to do. All apps are up-to-date, two different devices have the S2 app on them and have been used, router has been rebooted, RBW30 satellite has been turned on and off several times.

Premium product with a premium price-tag to match … it should not be this hard. Disappointed.

 

EDIT: Estimated time to speak to an advisor … 20 minutes! Are you having a laugh? More disappointed.

Userlevel 6
Badge +16

Hi @premiump 

Please try again later - sometimes there are random busy periods for no discernible reason.

If you get a successful resolution, can you please post it here? I am having the same problem - identical even down to using Orbi router and satellites….

Userlevel 6
Badge +16

Hi @premiump & @CWE 

Please try adjusting the following settings on your routers:

  • Disable Parental Controls for the Sonos device via Circle or Standard Parental Controls.
    • Orbi app main screen or web interface → Parental Controls 
  • Disable Access Controls for the Sonos device. 
    • Orbi web interface → ADVANCED > Security > Access Control.
  • Confirm that the Sonos device is not paused within the Orbi app.
    • Orbi app main screen → Device List

If either of you have AT&T, I recommend you get in touch with our technical support team.

 

 

  • Disable Parental Controls for the Sonos device via Circle or Standard Parental Controls.
    • Orbi app main screen or web interface → Parental Controls 
  • Disable Access Controls for the Sonos device. 
    • Orbi web interface → ADVANCED > Security > Access Control.
  • Confirm that the Sonos device is not paused within the Orbi app.
    • Orbi app main screen → Device List

 

Parental Controls - Not enabled, never have been.

Access Controls - High hopes for this … sadly, turning off Access Controls (you have to turn it off for every device) does not help.

Orbi App Paused - No device is paused, I even renamed the Roam to ensure I was looking at the correct device.

 

Thank you for the continued suggestions Corry, but I still have a Roam that Google Home can not find (despite me playing music on it right now in a group with my Beam that DOES have GA successfully installed). Phew! :(

Userlevel 6
Badge +16

Hi @premiump & @CWE 

Sorry - I should have mentioned to reboot your router and Sonos devices after altering network management settings.

If this still doesn’t help, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

@premiump - any luck getting yours working? I’ve tried the steps in this thread with no relief whatsoever. I haven’t had time to connect with technical support yet….

Reply