Answered

google broadcast/ announcement problem

  • 10 July 2019
  • 6 replies
  • 557 views

Badge
I keep getting the message “looks like there aren’t any other speakers connected on your home network so I can’t broadcast your message.” I am able to group and play on my play one speakers with the the sonos app and I can also use Spotify direct control so I know they are on the network. I am also able to see the speakers in the google home app. Anyone have any ideas on how to resolve this? From the home app I try to broadcast and it says broadcasting now but nothing is broadcasted. TIA -Tom
icon

Best answer by Hackersmovie 10 July 2019, 23:48

Go to (For each room):

Settings>Room Settings>Voice Services>Assistant Settings and be sure the default audio is selected for each room.
View original

6 replies

Userlevel 1
Badge +1
Go to (For each room):

Settings>Room Settings>Voice Services>Assistant Settings and be sure the default audio is selected for each room.
Badge
I did notice that in the google home app that I did not have default music players assigned so I tried assigning for each as mentioned above. This did allow me to broadcast from the google assistant app and not the home app and not from the actual sonos. So I continued to poke around and I noticed I did not have an address entered for my house. Once I input my street address things started working. HTH anyone having trouble. Thanks to hackersmovie for the quick response.
Hmm I have the same issue!
I can broadcast from google assistant to both sonos one and google minis.
If i broadcast from a mini, all minis responds.

if i broadcast from sonos one i get “No speakers....” error.

when i look in room settings on google home app on the iphone i do not see “default speaker”.
Badge
same here, no clue if this is a network or a google integration issue
Just a followup. On a Google mini I can set its default speaker, which i tried to set to the sonos one.
So now when a google mini broadcasts the sonos does annouce it as it is the default speaker of a mini, but still no luck in broadcasting from sonos.

I'm considering the older sonos play:1 and then pair it with a mini.

Someone else mentioned something about address, but even though that seems coincidential I checked, and I do hav address set for the home.

So still trying to get it to work!
Badge
Just to be complete
Address is also set
rebooted router
rebooted all google home mini s
rebooted sonos system
factory reset of a One and re connected to sonos

still the same broadcast only working from the google home mini s

Reply