Google Assistant will not play Spotify on Sonos Speakers

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

Userlevel 2
This question definitely wasn’t “answered.”

It sill doesn't work. Is there even a fix for this? 

i have tried:

-delete connections on both spotify and sonos

-change languages

-reset to factory default settings



nothing works.

I was getting this issue on my iphone "Sorry it looks like you haven't setup spotify premium on your sonos app.  To play from spotify premium link the same account on both sonos and google assistant".


I worked on  it for a few hours, nothing seemed to fix it so I ran the sonos app on an android phone and it resolved the issue.  I only needed the android phone to set the music service used by sonos.  

  1. Install the sonos, google home and google assistant apps
  2. Run the sonos app, login and select your default music service

This worked for me.. maybe it will help someone else.