Answered

Google Assistant Redirects to App Store


When I try and link Google Assistant to my Sonos One(s) I get as far as the page that says ‘Go to your Google Assistant App’, however when I click it it redirects me to the App Store despite the Google Assistant App being installed on my phone.



I have have tried uninstalling both apps, hard resetting my phone and resetting the Sonos system countless times, but every time I still get misdirected.



Has anyone else seen encountered the same problem?
icon

Best answer by Breezer23 7 July 2019, 20:15

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Yes. Leaves a “404” tab in Safari.
Same issue. Frustrating - just bought the Nest Home Hub..



UPDATE: Per the SONOS status page, Google Assistant services are degraded at the moment
Stranger still, I'm able to set things up fine using the SONOS app on my iPad. Still have the redirection issue when using my iPhone.

Still experiencing this on the One I just got today. I get stuck going from the Sonos app to safari and then to the App Store Google Assistant screen. I never make it to the Google assistant app.

I’m having this issue as well. Did anyone ever figure it out?

Having this same issue.  Can’t setup speakers with google.  When trying keeps launching App Store instead of assistant app. 

That’s an issue for me as well. Does not seem to be Sonos fault, at first. Google assistant URL that does not detect that the app is installed and redirects to the app store

I fixed it. I had to change the URL a little bit and it worked like a charm.

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

Userlevel 1

@everton this worked !!! You are amazing!

@everton this worked !!! You are amazing!


Same here. Worked perfectly!

This also worked for me, you are a star Robert.Hunter! Happy Christmas. 

I fixed it. I had to change the URL a little bit and it worked like a charm.

Copy the URL from safari and edit it somewhere else.

If you have it like this:

https://assistant.app.goo.gl/?ibi=com.google.OPA&isi=YYYYYYYYY&ius=googleassistant&efr=1&link=https%3A%2F%2Fassistant.google.com%2Fdevice%2Fhelp%3Fprovider%3Dsonos-XXXXXXX%26unlink%3Dsonos-XXXXXX%26music%3Dtrue%26return_url%3Dhttps%3A%2F%2Fwww.sonos.com%2Fapp%2Fpartners%2Fgoogle%2Fservices%2Fvoice%2Fsetupcomplete

 

Change it to: 

googleassistant://device/help?provider=sonos-XXXXXXXX&unlink=sonos-XXXXXXXX&music=true&return_url=https://www.sonos.com/app/partners/google/services/voice/setupcomplete

 

Replace XXXXX with whatever the numbers/letters you have on your end.

@everton - thank you so much for this, this fix worked perfectly for me.

It took a couple tries but @everton‘s fix worked for me. It’s pretty disappointing that this isn’t working out the box.