Google assistant on Sonos one not responding


Userlevel 2
Just set up new Sonos One with Google assistant.
The Sonos controller works and I can stream radio/music through the Sonos One.
If I speak to the Sonos, the music goes quiet so the microphone hears me saying 'ok google', however I get no response from Google.
If I speak with my Google Assistant mobile device active, then Google response does come from the Sonos.
Any ideas Guys?
Thanks
DD

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

104 replies

Just purchased a Sonos One specifically to replace our Google Home Mini only to find that Google Assistant will not respond.

 

Having read this thread I'm amazed that this issue has been know for over a year and is still to be resolved.

 

Sort it out Sonos or one of your loyal users will be jumping ship to a better provider.

Hi all,

 

During Black Friday I bought 2 Sonos ones. Which I have setup as a stereo pair. During installation I have setup the Google Assistant. At first my setup responded to my questions. For example: “Ok Google, turn on the lights in the bedroom”. But after a couple of hours it the voice assistant completely ignores everything after “Hey Google” of “Ok Google”. I tried to reset both my Sonos devices, I have disabled my voice assistant web and app activity. I have tried to rephrase my questions.. I also tried to remove and re-setup my rooms.. But nothing works. 

I noticed as well. When I plug out the Sonos and plug it in again. The assistant replies to me it has no connection to the internet. And this happens only the first time..

I’m thinking about swapping my Ones to the SL variant and set it up with my previous google mini. But I don’t want to do that. I would expect, if you buy something with a google assistant it should behave like one.. 

Does anyone has another tip I can try to solve the issues I have with my setup?

 
 
Userlevel 1

Hi all,

 

During Black Friday I bought 2 Sonos ones. Which I have setup as a stereo pair. During installation I have setup the Google Assistant. At first my setup responded to my questions. For example: “Ok Google, turn on the lights in the bedroom”. But after a couple of hours it the voice assistant completely ignores everything after “Hey Google” of “Ok Google”. I tried to reset both my Sonos devices, I have disabled my voice assistant web and app activity. I have tried to rephrase my questions.. I also tried to remove and re-setup my rooms.. But nothing works. 

I noticed as well. When I plug out the Sonos and plug it in again. The assistant replies to me it has no connection to the internet. And this happens only the first time..

I’m thinking about swapping my Ones to the SL variant and set it up with my previous google mini. But I don’t want to do that. I would expect, if you buy something with a google assistant it should behave like one.. 

Does anyone has another tip I can try to solve the issues I have with my setup?

 
 

I found if I turned on the bleep for the initiation phrase of OK Google, then waited until after the bleep to issue the command, I had far better results. Also consider moving the Sonos One away from walls to the left or right.

Disconnect Spotify from Sonos and connect it again! It worked for me