Question

Google Assistant Issues

  • 29 December 2019
  • 12 replies
  • 868 views

I have the Google assistant app loaded and it recognizes the Sonos One speaker and the microphone is activated but The Google assistant does not respond to commands. 
Is it possible the Sonos is defective or is it just user error?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Userlevel 7
Badge +20

I have the Google assistant app loaded and it recognizes the Sonos One speaker and the microphone is activated but The Google assistant does not respond to commands. 
Is it possible the Sonos is defective or is it just user error?


When you say the Mic is active, is the small round white light showing near the Mic Symbol?  Just touch the mic symbol to toggle the mic on and off.

Yes the small white light is on and when touched the speaker says that the mic is muted. But the speaker does not respond to Google commands such as what is the current temperature. 

I'm having similar issues, GA responds for music playback but no other functions. Hope there is a fix for these bugs, they've become a very expensive speaker otherwise. 

Userlevel 7
Badge +20

Can you try ‘Hey Goggle, what is the time’?  Also, can you check what the volume is set too in the Sonos App?

Userlevel 7
Badge +20

I'm having similar issues, GA responds for music playback but no other functions. Hope there is a fix for these bugs, they've become a very expensive speaker otherwise. 


That’s strange, can you give an example of the commands that are failing?

Hi, thanks for the response. Hey Google stop, when playing music never works. What's the weather rarely works, what's the news rarely works. I tried what's the time and that worked fine. The most annoying thing is the stop function than never works. 

Userlevel 7
Badge +20

Strange I’ve never experienced that problem. Have you contacted Google as those commands don’t go near the Sonos cloud as far as I’m aware?

I could do alright, but the other two GA devices I have set up in my home work flawlessly. The only response issues I'm having is with the sonos. In fact the home mini that it directly replaced in the same location was also faultless. So three devices working perfectly and the sonos not, I would imagine the issue is with sonos and not Google. 

As for having not experiencing those problems yourself, if you scroll down through the questions here, you can see a lot of people are having similar issues with Google assistant integration. Whilst also having GA enabled devices with no issues. 

Sorry, that may have come across as a bit smart (not my intention) to be honest I don't know where the fault lies. They're just expensive enough and I would like if it worked as well as the cheaper GA enabled devices I have. Thanks for the input though. 

Userlevel 7
Badge +20

Sorry, that may have come across as a bit smart (not my intention) to be honest I don't know where the fault lies. They're just expensive enough and I would like if it worked as well as the cheaper GA enabled devices I have. Thanks for the input though. 


No problem at all, it’s frustrating when these things don’t work.  My assumption that this is a Google function is not based upon any fact but just the thought process that Sonos won’t have written their own AI.  It could well be a microphone related issue.  If you open Google Home App and select your account in the top right corner and then select ‘My Activity’ does it show that GA is hearing you correctly?

I had checked that alright and no, it's not registering that I have said anything. 

I also have this issue and it’s frustrating to the point that I'm thinking of returning my speakers.

The speaker (Sonos One) lights up and makes the noise when I say “Hey Google”, it then listens to the command but does nothing. Commands such as “Hey Google, Stop” or “Hey Google, play X song/radio” “Turn it Up/Down” are so hit and miss if they work or not. Turning the mic off an on again seems to improve it’s success rate but then becomes rubbish again straight away.

It’s in the exact same spot as my google home mini was but the assistant on the Sonos is so poor in comparison. I checked the activity log as instructed in a post above and it is mostly registering as “Unknown voice command”. Sometimes it registers correctly but still doesn’t complete the command.

A final point is that on the google home mini, if I request for a song to play on spotify, it not only plays the song but also starts spotify radio, playing a playlist of similar songs. once it has finished. On the Sonos, it just plays the one song and then stops which is a shame as this was a really nice feature on the google mini.