Question

Google Assistant Commands/Problem w/ Spotify


Hey guys,

 

I’ve noticed kind of a weird problem that happens with my Sonos speakers and using google voice commands to play music via Spotify. I was curious whether anyone else noticed the same problems.

 

Normally, when asking Google assistant to play music (again through Spotify,) everything works as expected. However, I’ve noticed that, if I use the Sonos app to select/play something w/ my phone, and then later try using a google voice command to play music, Google assistant will acknowledge that the song will be played, but nothing happens. If I repeat myself and ask a second time, it will play properly, but I’ve notice that every time I try doing a voice command to play music after having used the sonos app to play music earlier, I always have to say the command twice before it’ll play properly. 

 

Does this happen to anyone else using Spotify w/ Google assistant?

 

Thanks. 


11 replies

Userlevel 4
Badge +12

Hi @jlwachter83, thank you for reaching out.

I would like to take a look at the Sonos system with a diagnostic. Setting > Help & Tips > Submit Diagnostic and reply with the confirmation.

This could be wireless interference; I would need to double-check the system.

Did you use the Google Assistant account on another automation system besides your home system?

The explanation is that voice services only allow one household per account. If it’s used somewhere else Google Assistant will have system conflicts.

If that’s the case, creating another Google Assistant account for each is recommended.

If not, the diagnostic will show us the errors.

If you have other concerns, feel free to reach out.

Please follow up on this post if the issue is resolved. There are numerous posts about the need to ask Google twice before playing the content, exactly as described by OP.

I have the exact same problem . Drives me mad ! 

On both my Sonos one and Sonos beam.

Please if there's a fix. I'm desperate for it.

 

/P

Userlevel 4
Badge +12

Hi @Patrikteodor, thank you for reaching out and welcome to the community.

Sorry for the late response, I would like to take a look at your Sonos system.

Please take a diagnostic from the Sonos app. Setting > Help & Tips > Submit Diagnostic and post the confirmation.

This to make sure the issue doesn’t involve something else and have it isolated to just Google Assistant and Sonos.

Also, try asking the command first before taking a diagnostic were Google Assistant doesn’t do the command.

Update us with your findings.

Hi I did as you asked and the number is 1811071446

It responded with I can't play on spotify yet. But in swedish. If I ask one more time it will work. Sometimes it says it will play it but doesn't. And one more command is required. 

Best regards

Patrik

Userlevel 4
Badge +12

Hi @Patrikteodor, thank you for the update.

I checked the diagnostic, the logs indicate Alexa skill; did you register the Sonos speakers to Alexa?

If so, disable the Sonos skill in the Alexa app and test Google Assistant after or completely remove Sonos from the Alexa under devices.

If you haven’t register them to Alexa, I recommend calling our Phone support to get it looked at.

It’s strange that you’re using Google Assistant with Alexa skill control logs.

1 800 680 2345 Monday to Friday from 10 am to 9 pm ET.

Update us with your findings.

This is driving us mental. Any room in the house whether playing on a designated Sonos (Play 5) from a Nest Hub or using the Google Assistant directly on a pair of One's, Google will say "okay, playing X from Spotify" but the music doesn't start... Try again with the exact same voice command and it will work perfectly. 

The Google Assistant seems to think it's worked perfectly... On the Nest Hub with the display, it even brings up the play controls. 

 

By the way, it's definitely a Spotify thing - asking for a radio station from TuneIn it works first time no problem. It's just Spotify requires the second ask. 

Diagnostic is 1796453835 if it helps. 

Hi @Patrikteodor, thank you for the update.

I checked the diagnostic, the logs indicate Alexa skill; did you register the Sonos speakers to Alexa?

If so, disable the Sonos skill in the Alexa app and test Google Assistant after or completely remove Sonos from the Alexa under devices.

If you haven’t register them to Alexa, I recommend calling our Phone support to get it looked at.

It’s strange that you’re using Google Assistant with Alexa skill control logs.

1 800 680 2345 Monday to Friday from 10 am to 9 pm ET.

Update us with your findings.

Hi

I’ve never used alexa. tried turning it on now. and deactivating it. But didnt make any difference. 
I think ill try to factory reset it and se what happens. 

It always works the second time i ask it to play on spotify (repeating myself that is). I have a feeling that the second time spotify have somehow already granted sonos/google assistant acces to play. 

 

Best Regards

Patrik

Userlevel 2
Badge +5

Hi folks, thank you for your response and for performing the steps provided. I'm sorry to hear that you're still experiencing the same.

I really appreciate the time and effort you've spent doing all the troubleshooting steps, and it would be best for you to continue working with us over the phone to expedite the process. 

To further assist you with this, I recommend contacting our Sonos Customer Care support with your full network setup including the make and model for each device to check what's going on and to provide the best option for you.

We're here to answer any further questions you have.

Reply