Answered

Google Assistant Alarm too Quiet on Sonos One

  • 23 February 2020
  • 35 replies
  • 2575 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

35 replies

Read that. This is the root of the issue. Sonos decided to tie the volume of Google Assistant (and its component audio) to the music playback volume instead of a dedicated volume control. Setting the volume correctly for music results in Assistant (and alarms, etc...) volume being extremely soft. Please implement a separate volume control for Assistant. Other smarthome devices already does that, so why not Sonos being a premium product?

I find it easier to personally use the in-built Sonos Alarm feature, rather than the Google Alarm, as the Sonos settings comes with its own volume control slider-bar, as per attached screenshot.

Maybe the way the Google alarm works is perhaps a restriction imposed by Google themselves, but the Sonos alarms seem to work fine, so maybe just give that a go instead.

Read that. This is the root of the issue. Sonos decided to tie the volume of Google Assistant (and its component audio) to the music playback volume instead of a dedicated volume control. Setting the volume correctly for music results in Assistant (and alarms, etc...) volume being extremely soft. Please implement a separate volume control for Assistant. Other smarthome devices already does that, so why not Sonos being a premium product?

I find it easier to personally use the in-built Sonos Alarm feature, rather than the Google Alarm, as the Sonos settings comes with its own volume control slider-bar, as per attached screenshot.

Maybe the way the Google alarm works is perhaps a restriction imposed by Google themselves, but the Sonos alarms seem to work fine, so maybe just give that a go instead.

Those who purchased a Sonos One to replace a google nest cant really run a routine before bed, i.e. “goodnight” to turn off all lights and set an alarm for the following morning, since the google alarm plays at the volume of the speaker. I haven't bothered to try the sonos alarm but I assume you cant turn it off or snooze it by triggering google assistant with your voice since google assistant cant set a sonos alarm.

Basically, a key feature of having google assistant is lost on the Sonos One so its not really a good enough replacement for a google nest. I ended up returning mine for this reason.

Userlevel 7
Badge +17

@Sanu.Jacob10 You state: “I haven't bothered to try the sonos alarm but I assume you cant turn it off or snooze it by triggering google assistant with your voice since google assistant cant set a sonos alarm.”

Since I never use a Sonos alarm I’m not in a position to comment on the workings of it, but maybe someone else can tell us if you can do this, so this thread does not end with unchecked facts.

When you command Google Assistant to set up an alarm on Sonos devices, it may or may not work.

 

what...what? So what do I do? Right now I say "Google, set an alarm for 30 minutes." It says, loudly, "okay, setting an alarm for [time]." My volume is always up moderately high for music or podcasts. But then I just don't hear an alarm, through either speaker. Is there a setting I should adjust somewhere??? So confused.

 

Please don't just say "the app," tell me if you mean Sonos or Google Assistant or what.

I also have the same issue, thanks for sharing the solution of answer. 

 

Been over two years since the original post and there still hasn't been an update to address this issue? I just bought a Sonos One with the intention of using it instead of my Google Nest Mini as the smart speaker in my room but if there still no update on this then I’m returning the Sonos One as there is no point in having it.

 

Moderator edit: removed dead link to community page.

yea I was looking into this and sadly seems like there’s no updates, only possible on an actual google device. The alarm sound is wayyy too quiet on sonos. At least the google assistant timer sound is louder.

 

I liked using the sonos voice control but it’s features are limited, not able to set multiple timers for when you’re cooking, etc. So we switched to google assistant. But I guess w/ sonos voice control settings, you can adjust the alarm volume.

 

Would love an update on this =) 

It would be great if this could be solved :)

This volume issue seems to be occurring with all Assistants on all Sonos products. May I suggest Sonos dev team implement a separate assistant volume controller in the app?

thank you

Same issue. Just missed an appointment. Sonos does other things so well, why can't this be fixed? Looking at the timeline, it doesn't seem as if this is a priority. Yes, I can do it in the Sonos app but why not be able to do it on the fly without having to open the app? Sending an alarm through the Google assistant is much more convenient!