Answered

Can't play music on Sonos Move via Google Assistant

  • 10 December 2020
  • 9 replies
  • 267 views

Hi,

For several days now that the sonos move speaker does not playing music when I request through Google Assistant and it's only saying "sorry, I can't to that on this device" how can I fix this issue?

Thanks.

 

icon

Best answer by Rowena B. 16 December 2020, 23:41

Hi @Matan Robert akoren

Thanks for your response and for updating us. I really appreciate the time and effort you've spent doing all the troubleshooting steps, and it would be best for you to continue working with us over the phone to expedite the process. 

Please contact our technical support team with your full network setup for more in-depth troubleshooting steps. Our phone support has the tools to check what's going on in your system. Feel free to reach out in the future if you have any other questions. You're always welcome here.

View original

9 replies

Userlevel 5
Badge +16

Hi @Matan Robert akoren

Welcome to the Sonos community and thanks for letting us know about your concern.

Let me help you with this. I'd like to ask some questions to understand what's going on.

1. When did it start happening?
2. Are you using multiple or only one Google account with Sonos within the Household?
3. Do you have other non-Sonos Google Assistant devices in the network? Have you tried powering them off?
4. Are your music service accounts both linked in Sonos and Google Assistant?
5. Are there any duplicate room names in the system?
6. Have you tried to remove and re-add Google Assistant from Sonos to re-establish the connection with Google Assistant servers?
 

Let us know how you get on with the advice above. If Google Assistant still not working, please check the Google Assistant troubleshooting guide. After performing the steps, run a diagnostic report from your Sonos system. Please include the confirmation number in your response for us to check. If you have any questions, feel free to let us know. We'll wait for your reply.

Hi!

1. It's started last week.

2. I have only the sonos move.

3. My phone is the only non-sonos Google Assistant device.

4. Yes.

5. No.

6. I had resetting the sonos move and now it's trying to play music and it's saying "sorry, it's look like sonos service is not available now" or " I can't do that hear but you can ask me to play on one of my other devices"

So I don't know what else can I do..

 

 

Userlevel 5
Badge +16

Hi @Matan Robert akoren

Thanks for your response and for updating us. I really appreciate the time and effort you've spent doing all the troubleshooting steps, and it would be best for you to continue working with us over the phone to expedite the process. 

Please contact our technical support team with your full network setup for more in-depth troubleshooting steps. Our phone support has the tools to check what's going on in your system. Feel free to reach out in the future if you have any other questions. You're always welcome here.

Badge +1

I have started getting the same issue on my Sonos Move (named “Bathroom”) recently. For example, “Hey Google, Play Radio 5” gets the response “I can’t do that here, but you can ask me to play it on one of your other devices”. If I then go to another room and say “Hey Google, Play Radio 5 on Bathroom Sonos” it starts playing on the Move just fine.

The only change I’ve made on my system recently was to add a second Spotify account, but Radio is played via TuneIn so shouldn’t be affected.

Userlevel 5
Badge +16

Hi @dsw,

Thanks for reaching out to the Sonos community and letting us know about your concern. Let me share with you about Google Assistant

When providing a command, you need to make sure that you are saying the voice command correctly. For example, when you say “OK Google, play Radio 5”, will only play through your Google Assistant-enabled device, or Google Assistant won’t be able to perform the command, whereas "OK Google, play Radio 5 in the bathroom" will direct your Google Assistant to play through the bathroom speaker. For a list of Google voice commands that can be used on Sonos, go here: Control Sonos with the Google Assistant.

You can also try removing Google Assistant from Sonos and setting it up again. This will ensure that your Sonos is using the correct Google account and re-establish the connection with Google Assistant servers.

Let us know how it works for you. In case you're still having the same issue, I'd recommend reaching out to our phone support team to look into your system and find out the cause. 

Please let us know if you have any other questions, please do not hesitate to reach out.

Badge +1

Hi @dsw,

Thanks for reaching out to the Sonos community and letting us know about your concern. Let me share with you about Google Assistant

When providing a command, you need to make sure that you are saying the voice command correctly. For example, when you say “OK Google, play Radio 5”, will only play through your Google Assistant-enabled device, or Google Assistant won’t be able to perform the command, whereas "OK Google, play Radio 5 in the bathroom" will direct your Google Assistant to play through the bathroom speaker. For a list of Google voice commands that can be used on Sonos, go here: Control Sonos with the Google Assistant.

You can also try removing Google Assistant from Sonos and setting it up again. This will ensure that your Sonos is using the correct Google account and re-establish the connection with Google Assistant servers.

Let us know how it works for you. In case you're still having the same issue, I'd recommend reaching out to our phone support team to look into your system and find out the cause. 

Please let us know if you have any other questions, please do not hesitate to reach out.

Hi,

Thanks for your reply but that’s not the case. When I say “Hey Google, Play Radio 5” on my Sonos One it starts playing no problem. The issue is that exactly the same command doesn’t work on my Sonos Move - both have Google Assistant built in and enabled.

Userlevel 5
Badge +16

Hi @dsw

Thanks for your response and for updating us.

Have you tried removing Google Assistant from Sonos and setting it up again? If so and the problem is the same, at this point, it would be best to contact our phone support for more in-depth troubleshooting steps. It would be great if you can provide our team with your full network setup including the make and model to look up the information. Please let us know if you have any further questions or concerns, we'll be glad to assist you.  

Badge +1

Hi,

I removed Google Assistant from the Move, set it up again and it now works. It sounds like this is a known issue. Can you share some details on what the issue is, if it’s likely to recur and when we can expect a fix?

many thanks

Userlevel 5
Badge +16

Hi @dsw

Thanks for your response and for updating us. I'm glad Google Assistant is now working with your Sonos Move. When the Google Assistant voice command doesn't work, it could be the settings and configurations in the Google app. Removing and re-adding Google Assistant in the Sonos app fix the issues. In some cases, the issue is network-related. Please continue to monitor your Sonos and if you run into any issues, submit a diagnostic report for us to check. 

Let us know if you need help with any other information, we're here to answer any further questions you have.

Reply